qutecom/qutecom-3.0.20141007hg-compile.patch

46 lines
1.8 KiB
Diff

--- qutecom-build/crashreport/CMakeLists.txt.bero 2012-12-04 18:01:25.418066887 +0100
+++ qutecom-build/crashreport/CMakeLists.txt 2012-12-04 18:03:53.022795280 +0100
@@ -8,6 +8,7 @@ use_public_libraries(
settings
boost
)
+link_libraries(boost_system-mt)
add_public_include_dirs(
${CMAKE_CURRENT_SOURCE_DIR}
--- qutecom-build/engine/qutecom-verona/codecs/g726/time.h.bero 2012-12-04 17:45:57.838166362 +0100
+++ qutecom-build/engine/qutecom-verona/codecs/g726/time.h 2012-12-04 17:46:03.035227562 +0100
@@ -1 +1,2 @@
+#warning wrong time.h
extern int gettimeofday(struct timeval *tv, void *tz);
--- qutecom-build/engine/verona/wcecompat/include/time.h.bero 2012-12-04 17:46:16.969391603 +0100
+++ qutecom-build/engine/verona/wcecompat/include/time.h 2012-12-04 17:46:22.306454417 +0100
@@ -1,3 +1,4 @@
+#warning WRONG time.h
/* wcecompat: Windows CE C Runtime Library "compatibility" library.
*
* Copyright (C) 2001-2002 Essemer Pty Ltd. All rights reserved.
--- qutecom-build/qutecom/src/CMakeLists.txt.bero 2012-12-04 18:20:20.321862957 +0100
+++ qutecom-build/qutecom/src/CMakeLists.txt 2012-12-04 18:22:48.636985151 +0100
@@ -211,6 +211,10 @@ if (USB_CONFIG_STORAGE)
)
endif (USB_CONFIG_STORAGE)
+# boost_system-mt for boost::system::generic_category()
+# X11 for XInitThreads
+link_libraries(boost_system-mt X11)
+
create_project_binary()
# TODO: test, xpcom, gtk?
--- qutecom-3.0/engine/qutecom-verona/mediastreamer2/plugins/CMakeLists-internal.txt.bero 2012-12-04 19:07:54.326151184 +0100
+++ qutecom-3.0/engine/qutecom-verona/mediastreamer2/plugins/CMakeLists-internal.txt 2012-12-04 19:07:59.665215482 +0100
@@ -14,6 +14,7 @@ endif(PHAPI_CODEC_ILBC_SUPPORT)
if(PHAPI_CODEC_G726_SUPPORT)
subdirs(
+ msg722
msg726
)
endif(PHAPI_CODEC_G726_SUPPORT)