package created using the webbuild interface [release 2.2.1-1mamba;Mon May 12 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 17:20:39 +01:00
parent 26fca84fb1
commit 3a07b96476
8 changed files with 902 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# qutecom
QuteCom (previously called OpenWengo) is a SIP-compliant voice-over-IP client that allows you to speak to other users of SIP-compliant softphones at no cost. It also allows users to call landlines and cell phones, send SMS text, and make video calls, and is compatible with any SIP provider.

View File

@ -0,0 +1,48 @@
diff -ru qutecom-2.2.1.orig/wifo/phapi/phcodec-h263.c qutecom-2.2.1/wifo/phapi/phcodec-h263.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-h263.c 2014-05-15 14:41:30.756704346 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-h263.c 2014-05-15 14:51:41.954407150 +0000
@@ -75,7 +75,7 @@
return 0;
}
- h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
+ //h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
#ifdef CODEC_FLAG_H263P_SLICE_STRUCT
h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
#else
diff -ru qutecom-2.2.1.orig/wifo/phapi/phcodec-h263flv1.c qutecom-2.2.1/wifo/phapi/phcodec-h263flv1.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-h263flv1.c 2014-05-15 14:41:30.756704346 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-h263flv1.c 2014-05-15 14:51:41.954407150 +0000
@@ -75,7 +75,7 @@
return 0;
}
- h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
+ //h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
#ifdef CODEC_FLAG_H263P_SLICE_STRUCT
h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
#else
diff -ru qutecom-2.2.1.orig/wifo/phapi/phcodec-h263plus.c qutecom-2.2.1/wifo/phapi/phcodec-h263plus.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-h263plus.c 2014-05-15 14:41:30.756704346 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-h263plus.c 2014-05-15 14:51:41.955407136 +0000
@@ -68,7 +68,7 @@
return 0;
}
- h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
+ //h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
#ifdef CODEC_FLAG_H263P_SLICE_STRUCT
h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
#else
diff -ru qutecom-2.2.1.orig/wifo/phapi/phcodec-mpeg4.c qutecom-2.2.1/wifo/phapi/phcodec-mpeg4.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-mpeg4.c 2014-05-15 14:58:45.895573355 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-mpeg4.c 2014-05-15 14:57:48.424365815 +0000
@@ -80,7 +80,7 @@
return 0;
}
- mpeg4t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
+ //mpeg4t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
//mpeg4t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_UMV;
//mpeg4t->encoder_ctx.context->flags |= CODEC_FLAG_4MV;
//mpeg4t->encoder_ctx.context->flags |= CODEC_FLAG_AC_PRED;

View File

@ -0,0 +1,416 @@
Fix build with latest ffmpeg: Sanitize include paths and port to the new API
Part of bug #443254
Index: qutecom-2.2_p20110210/libs/pixertool/src/pixertool.cpp
===================================================================
--- qutecom-2.2_p20110210.orig/libs/pixertool/src/pixertool.cpp
+++ qutecom-2.2_p20110210/libs/pixertool/src/pixertool.cpp
@@ -26,9 +26,10 @@
#ifdef __cplusplus
extern "C" {
#endif
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
+#include <libavutil/pixdesc.h>
#ifdef HAVE_SWSCALE
-#include <swscale.h>
+#include <libswscale/swscale.h>
#endif
#ifdef __cplusplus
}
@@ -54,8 +55,6 @@ static uint8_t * _nv12_to_yuv420p(uint8_
piximage * pix_alloc(pixosi pix, unsigned width, unsigned height) {
piximage * image = (piximage *) malloc(sizeof(piximage));
- avcodec_init();
-
image->width = width;
image->height = height;
image->palette = pix;
@@ -83,7 +82,7 @@ unsigned pix_size(pixosi pix, unsigned w
}
const char *pix_get_fmt_name(pixosi pixfmt) {
- return avcodec_get_pix_fmt_name(pix_ffmpeg_from_pix_osi(pixfmt));
+ return av_get_pix_fmt_name(pix_ffmpeg_from_pix_osi(pixfmt));
}
pixerrorcode pix_convert(int flags, piximage * img_dst, piximage * img_src) {
Index: qutecom-2.2_p20110210/owbuild/FindFFMPEG.cmake
===================================================================
--- qutecom-2.2_p20110210.orig/owbuild/FindFFMPEG.cmake
+++ qutecom-2.2_p20110210/owbuild/FindFFMPEG.cmake
@@ -47,16 +47,13 @@ else (FFMPEG_LIBRARIES AND FFMPEG_INCLUD
find_path(AVCODEC_INCLUDE_DIR
NAMES
- avcodec.h
+ libavcodec/avcodec.h
PATHS
${_AVCODEC_INCLUDEDIR}
/usr/include
/usr/local/include
/opt/local/include
/sw/include
- PATH_SUFFIXES
- libavcodec
- ffmpeg
NO_DEFAULT_PATH
)
@@ -66,32 +63,26 @@ else (FFMPEG_LIBRARIES AND FFMPEG_INCLUD
find_path(AVUTIL_INCLUDE_DIR
NAMES
- avutil.h
+ libavutil/avutil.h
PATHS
${_AVUTIL_INCLUDEDIR}
/usr/include
/usr/local/include
/opt/local/include
/sw/include
- PATH_SUFFIXES
- libavutil
- ffmpeg
NO_DEFAULT_PATH
)
mark_as_advanced(AVUTIL_INCLUDE_DIR)
find_path(AVFORMAT_INCLUDE_DIR
NAMES
- avformat.h
+ libavformat/avformat.h
PATHS
${_AVFORMAT_INCLUDEDIR}
/usr/include
/usr/local/include
/opt/local/include
/sw/include
- PATH_SUFFIXES
- libavformat
- ffmpeg
NO_DEFAULT_PATH
)
mark_as_advanced(AVFORMAT_INCLUDE_DIR)
@@ -99,32 +90,26 @@ else (FFMPEG_LIBRARIES AND FFMPEG_INCLUD
if (FALSE)
find_path(POSTPROC_INCLUDE_DIR
NAMES
- postprocess.h
+ libpostproc/postprocess.h
PATHS
${_POSTPROC_INCLUDEDIR}
/usr/include/postproc
/usr/local/include/postproc
/opt/local/include/postproc
/sw/include
- PATH_SUFFIXES
- libpostproc
- ffmpeg
)
mark_as_advanced(POSTPROC_INCLUDE_DIR)
endif(FALSE)
find_path(SWSCALE_INCLUDE_DIR
NAMES
- swscale.h
+ libswscale/swscale.h
PATHS
${_SWSCALE_INCLUDEDIR}
/usr/include
/usr/local/include
/opt/local/include
/sw/include
- PATH_SUFFIXES
- libswscale
- ffmpeg
NO_DEFAULT_PATH
)
mark_as_advanced(SWSCALE_INCLUDE_DIR)
Index: qutecom-2.2_p20110210/libs/pixertool/include/pixertool/ffmpeg-pixertool.h
===================================================================
--- qutecom-2.2_p20110210.orig/libs/pixertool/include/pixertool/ffmpeg-pixertool.h
+++ qutecom-2.2_p20110210/libs/pixertool/include/pixertool/ffmpeg-pixertool.h
@@ -28,14 +28,14 @@
extern "C" {
#endif
#ifdef HAVE_SWSCALE
-#include <swscale.h>
+#include <libswscale/swscale.h>
#endif
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#ifdef __cplusplus
}
#endif
-#include <avutil.h>
+#include <libavutil/avutil.h>
#ifdef __cplusplus
extern "C" {
Index: qutecom-2.2_p20110210/libs/pixertool/src/ffmpeg/ffmpeg-pixertool.c
===================================================================
--- qutecom-2.2_p20110210.orig/libs/pixertool/src/ffmpeg/ffmpeg-pixertool.c
+++ qutecom-2.2_p20110210/libs/pixertool/src/ffmpeg/ffmpeg-pixertool.c
@@ -23,9 +23,9 @@
#include <stdlib.h>
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#ifdef HAVE_SWSCALE
-#include <swscale.h>
+#include <libswscale/swscale.h>
#endif
Index: qutecom-2.2_p20110210/qutecom/src/QuteComBuildId.cpp
===================================================================
--- qutecom-2.2_p20110210.orig/qutecom/src/QuteComBuildId.cpp
+++ qutecom-2.2_p20110210/qutecom/src/QuteComBuildId.cpp
@@ -29,7 +29,7 @@
#include <boost/version.hpp>
#include <tinyxml.h>
extern "C" {
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#if defined (IMWRAPPER_BACKEND_MULTI)
#include <glib.h>
#include <libpurple/core.h>
Index: qutecom-2.2_p20110210/wifo/phapi/phapi-old.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phapi-old.c
+++ qutecom-2.2_p20110210/wifo/phapi/phapi-old.c
@@ -59,7 +59,7 @@
#define SKIP(x)
#ifdef PHAPI_VIDEO_SUPPORT
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <webcam/webcam.h>
#endif
@@ -2295,7 +2295,9 @@ void
ph_avcodec_init()
{
#ifdef PHAPI_VIDEO_SUPPORT
+#if LIBAVCODEC_VERSION_MAJOR < 54
avcodec_init();
+#endif
avcodec_register_all();
//phcfg.video_config.video_line_configuration = PHAPI_VIDEO_LINE_128KBPS;
#endif
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-avcodec-wrapper.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-avcodec-wrapper.c
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-avcodec-wrapper.c
@@ -36,7 +36,7 @@
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <ortp.h>
#include <osip2/osip_mt.h>
#include <osipparser2/osip_list.h>
@@ -53,7 +53,9 @@
void ph_avcodec_wrapper_init()
{
+#if LIBAVCODEC_VERSION_MAJOR < 54
avcodec_init();
+#endif
avcodec_register_all();
}
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-avcodec-wrapper.h
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-avcodec-wrapper.h
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-avcodec-wrapper.h
@@ -22,7 +22,7 @@
#include "phapi.h"
#include "phcall.h"
#include "phmedia.h"
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#define PHCODEC_DEFAULT_BITRATE 1000000
// 99 = 11*9 = (176/16)*(144/16) = a partition of macroblocs ( 1 MB = four 8x8 squares)
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-h263.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-h263.c
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-h263.c
@@ -23,7 +23,7 @@
*
*/
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <ortp.h>
#include <osip2/osip_mt.h>
#include <osipparser2/osip_list.h>
@@ -76,7 +76,6 @@ void *h263_encoder_init(void *ctx) {
}
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
- h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QSCALE;
//h263t->encoder_ctx.context->flags |= CODEC_FLAG_INPUT_PRESERVED;
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-h263flv1.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-h263flv1.c
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-h263flv1.c
@@ -23,7 +23,7 @@
*
*/
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <ortp.h>
#include <osip2/osip_mt.h>
#include <osipparser2/osip_list.h>
@@ -76,7 +76,6 @@ void *h263flv1_encoder_init(void *ctx) {
}
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
- h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QSCALE;
//h263t->encoder_ctx.context->flags |= CODEC_FLAG_INPUT_PRESERVED;
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-h263flv1.h
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-h263flv1.h
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-h263flv1.h
@@ -25,7 +25,7 @@
#include "phcall.h"
#include "phmedia.h"
#include "phcodec-h263.h"
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include "phcodec-avcodec-wrapper.h"
#define MAX_ENC_BUFFER_SIZE (FF_MIN_BUFFER_SIZE * 32)
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-h263.h
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-h263.h
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-h263.h
@@ -24,7 +24,7 @@
#include "phapi.h"
#include "phcall.h"
#include "phmedia.h"
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include "phcodec-avcodec-wrapper.h"
#define MAX_ENC_BUFFER_SIZE (FF_MIN_BUFFER_SIZE * 32)
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-h263plus.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-h263plus.c
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-h263plus.c
@@ -16,7 +16,7 @@
* Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <ortp.h>
#include <osip2/osip_mt.h>
#include <osipparser2/osip_list.h>
@@ -69,7 +69,6 @@ void *h263p_encoder_init(void *ctx) {
}
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
- h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QSCALE;
//h263t->encoder_ctx.context->flags |= CODEC_FLAG_INPUT_PRESERVED;
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-h263plus.h
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-h263plus.h
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-h263plus.h
@@ -25,7 +25,7 @@
#include "phcall.h"
#include "phmedia.h"
#include "phcodec-h263.h"
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include "phcodec-avcodec-wrapper.h"
#define MAX_ENC_BUFFER_SIZE (FF_MIN_BUFFER_SIZE * 32)
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-h264.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-h264.c
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-h264.c
@@ -21,7 +21,7 @@
*
*/
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <ortp.h>
#include <osip2/osip_mt.h>
#include <osipparser2/osip_list.h>
Index: qutecom-2.2_p20110210/wifo/phapi/phcodec-mpeg4.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phcodec-mpeg4.c
+++ qutecom-2.2_p20110210/wifo/phapi/phcodec-mpeg4.c
@@ -24,7 +24,7 @@
*/
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <ortp.h>
#include <osip2/osip_mt.h>
#include <osipparser2/osip_list.h>
Index: qutecom-2.2_p20110210/wifo/phapi/phmedia-video-bwcontrol.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phmedia-video-bwcontrol.c
+++ qutecom-2.2_p20110210/wifo/phapi/phmedia-video-bwcontrol.c
@@ -36,7 +36,7 @@
#include <stdio.h>
#include <math.h>
#include <webcam/webcam.h>
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include "phlog.h"
#include "phcodec.h"
Index: qutecom-2.2_p20110210/wifo/phapi/phmedia-video.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phmedia-video.c
+++ qutecom-2.2_p20110210/wifo/phapi/phmedia-video.c
@@ -34,7 +34,7 @@
#include <fcntl.h>
#include <stdio.h>
#include <webcam/webcam.h>
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include <pixertool/ffmpeg-pixertool.h>
#include <pixertool/pixertool.h>
@@ -867,7 +867,7 @@ int ph_media_video_flush_queue(phvstream
stream->stat_num_decoded_total_over_5s++;
gettimeofday(&now_time, 0);
ph_tvsub(&now_time, &stream->last_decode_time);
- if (picIn->pict_type != FF_I_TYPE && (now_time.tv_usec / 1000) < stream->fps_interleave_time)
+ if (picIn->pict_type != AV_PICTURE_TYPE_I && (now_time.tv_usec / 1000) < stream->fps_interleave_time)
{
stream->stat_num_decoded_dropped_over_5s++;
return 0;
Index: qutecom-2.2_p20110210/wifo/phapi/phmedia-video-control.c
===================================================================
--- qutecom-2.2_p20110210.orig/wifo/phapi/phmedia-video-control.c
+++ qutecom-2.2_p20110210/wifo/phapi/phmedia-video-control.c
@@ -29,7 +29,7 @@
#include <fcntl.h>
#include <stdio.h>
#include <webcam/webcam.h>
-#include <avcodec.h>
+#include <libavcodec/avcodec.h>
#include "phcodec.h"
#include "phapi.h"

View File

@ -0,0 +1,23 @@
diff -ur a/libs/owutil/thread/src/Thread.cpp b/libs/owutil/thread/src/Thread.cpp
--- a/libs/owutil/thread/src/Thread.cpp 2011-02-10 11:03:43.000000000 +0100
+++ b/libs/owutil/thread/src/Thread.cpp 2012-10-03 14:58:00.000000000 +0200
@@ -24,6 +24,7 @@
#include <cutil/global.h>
#include <util/SafeDelete.h>
+#include <boost/version.hpp>
#include <boost/thread/thread.hpp>
#include <boost/thread/xtime.hpp>
@@ -105,7 +106,11 @@
}
boost::xtime xt;
+#if BOOST_VERSION >= 105000
+ boost::xtime_get(&xt, boost::TIME_UTC_);
+#else
boost::xtime_get(&xt, boost::TIME_UTC);
+#endif /* BOOST_VERSION >= 105000 */
xt.sec += seconds;
boost::thread::sleep(xt);
}

View File

@ -0,0 +1,97 @@
--- libs/3rdparty/psiidle/psiidle/CMakeLists.txt.link 2010-02-23 23:49:25.000000000 +0100
+++ libs/3rdparty/psiidle/psiidle/CMakeLists.txt 2010-02-23 23:49:46.000000000 +0100
@@ -46,6 +46,7 @@
-DHAVE_XSS
)
ow_add_private_libraries(
+ X11
Xss
)
else (LIBXSS_LINK_FLAGS)
--- libs/3rdparty/googlebreakpad/CMakeLists-internal-unix.txt.link 2010-01-20 16:19:25.000000000 +0100
+++ libs/3rdparty/googlebreakpad/CMakeLists-internal-unix.txt 2010-08-05 16:19:24.000000000 +0200
@@ -6,6 +6,8 @@
${CMAKE_CURRENT_SOURCE_DIR}/src/client/linux/handler
)
+ow_add_private_libraries(md5)
+
ow_add_sources(
src/common/convert_UTF.c
src/common/string_conversion.cc
@@ -25,4 +27,3 @@
)
ow_create_project_binary()
-
--- owbuild/FindBoost.cmake~ 2011-02-10 18:03:43.000000000 +0800
+++ owbuild/FindBoost.cmake 2013-04-06 10:49:49.653968941 +0800
@@ -313,6 +313,15 @@
endif (NOT BOOST_DATE_TIME_LIBRARY)
+ if (NOT BOOST_SYSTEM_LIBRARY)
+ find_library(BOOST_SYSTEM_LIBRARY
+ NAMES
+ boost_system${TMP_BOOST_LIBRARIES_SUFFIX}
+ PATHS
+ ${BOOST_LIBRARIES_SEARCH_DIRS}
+ )
+ endif (NOT BOOST_SYSTEM_LIBRARY)
+
if (NOT BOOST_FILESYSTEM_LIBRARY)
find_library(BOOST_FILESYSTEM_LIBRARY
NAMES
@@ -427,6 +436,9 @@
if (BOOST_DATE_TIME_LIBRARY)
set(BOOST_DATE_TIME_FOUND TRUE)
endif (BOOST_DATE_TIME_LIBRARY)
+ if (BOOST_SYSTEM_LIBRARY)
+ set(BOOST_SYSTEM_FOUND TRUE)
+ endif (BOOST_SYSTEM_LIBRARY)
if (BOOST_FILESYSTEM_LIBRARY)
set(BOOST_FILESYSTEM_FOUND TRUE)
endif (BOOST_FILESYSTEM_LIBRARY)
@@ -548,6 +560,12 @@
${BOOST_WSERIALIZATION_LIBRARY}
)
endif (BOOST_WSERIALIZATION_FOUND)
+ if (BOOST_SYSTEM_FOUND)
+ set(BOOST_LIBRARIES
+ ${BOOST_LIBRARIES}
+ ${BOOST_SYSTEM_LIBRARY}
+ )
+ endif (BOOST_SYSTEM_FOUND)
if (BOOST_INCLUDE_DIRS AND BOOST_LIBRARIES)
set(BOOST_FOUND TRUE)
--- libs/3rdparty/boost/CMakeLists.txt~ 2011-02-10 18:03:43.000000000 +0800
+++ libs/3rdparty/boost/CMakeLists.txt 2013-04-06 11:24:56.165701506 +0800
@@ -17,6 +17,7 @@
${BOOST_SERIALIZATION_LIBRARY}
${BOOST_SIGNALS_LIBRARY}
${BOOST_THREAD_LIBRARY}
+ ${BOOST_SYSTEM_LIBRARY}
CACHE INTERNAL "${PROJECT_NAME} libraries"
)
endif (NOT MSVC)
--- libs/owutil/thread/CMakeLists.txt~ 2011-02-10 18:03:43.000000000 +0800
+++ libs/owutil/thread/CMakeLists.txt 2013-04-06 11:36:39.373273830 +0800
@@ -3,6 +3,7 @@
ow_use_public_libraries(
owutil
boost
+ pthread
)
ow_add_sources(
--- crashreport/CMakeLists.txt~ 2011-02-10 18:03:43.000000000 +0800
+++ crashreport/CMakeLists.txt 2013-04-06 12:13:20.179067519 +0800
@@ -40,6 +40,7 @@
qtmain.lib
)
endif (WIN32)
+ow_add_private_libraries(pthread)
# FIXME: This has been copied from qutecom/src/CMakeLists.txt, it would be
# nicer to avoid duplication.

View File

@ -0,0 +1,42 @@
Description: fix for linux/videodev.h moved to libv4l1-videodev.h in new kernels (2.6.38)
Author: Ludovico Cavedon <cavedon@debian.org>
Index: qutecom-2.2+dfsg1/libs/pixertool/src/v4l/v4l-pixertool.c
===================================================================
--- qutecom-2.2+dfsg1.orig/libs/pixertool/src/v4l/v4l-pixertool.c 2011-04-12 17:31:31.000000000 +0000
+++ qutecom-2.2+dfsg1/libs/pixertool/src/v4l/v4l-pixertool.c 2011-04-12 17:34:17.000000000 +0000
@@ -21,7 +21,7 @@
#include <sys/types.h>
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
pixosi pix_v4l_to_pix_osi(int pix) {
pixosi palette;
Index: qutecom-2.2+dfsg1/libs/webcam/include/webcam/V4LWebcamDriver.h
===================================================================
--- qutecom-2.2+dfsg1.orig/libs/webcam/include/webcam/V4LWebcamDriver.h 2011-04-12 17:31:17.000000000 +0000
+++ qutecom-2.2+dfsg1/libs/webcam/include/webcam/V4LWebcamDriver.h 2011-04-12 17:34:31.000000000 +0000
@@ -24,7 +24,7 @@
#include <thread/Thread.h>
-#include <linux/videodev.h>
+#include <libv4l1-videodev.h>
#include <map>
#include <string>
Index: qutecom-2.2+dfsg1/libs/webcam/src/v4l/V4LWebcamDriver.cpp
===================================================================
--- qutecom-2.2+dfsg1.orig/libs/webcam/src/v4l/V4LWebcamDriver.cpp 2011-04-12 17:31:51.000000000 +0000
+++ qutecom-2.2+dfsg1/libs/webcam/src/v4l/V4LWebcamDriver.cpp 2011-04-12 17:34:06.000000000 +0000
@@ -185,7 +185,7 @@
// format to such an unsupported format.
// Try to choose a palette that will be supported by ffmpeg.
- static const __u16 try_palettes[] = {
+ static const uint16_t try_palettes[] = {
VIDEO_PALETTE_RGB24,
VIDEO_PALETTE_RGB32,
VIDEO_PALETTE_YUV420P,

View File

@ -0,0 +1,163 @@
diff -Nru qutecom-2.2.1.orig/wifo/phapi/phcodec-avcodec-wrapper.c qutecom-2.2.1/wifo/phapi/phcodec-avcodec-wrapper.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-avcodec-wrapper.c 2014-05-15 14:34:08.441269093 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-avcodec-wrapper.c 2014-05-15 14:34:37.222928237 +0000
@@ -53,9 +53,6 @@
void ph_avcodec_wrapper_init()
{
-#if LIBAVCODEC_VERSION_MAJOR < 54
- avcodec_init();
-#endif
avcodec_register_all();
}
@@ -64,9 +61,13 @@
int dec_len, got_picture = 0;
ph_avcodec_decoder_ctx_t * decoder_t = (ph_avcodec_decoder_ctx_t *) ctx;
-
- dec_len = avcodec_decode_video(decoder_t->context,
- dst, &got_picture, (uint8_t *)src, srcsize);
+ AVPacket avpkt;
+ av_init_packet(&avpkt);
+ avpkt.data = (uint8_t *)src;
+ avpkt.size = srcsize;
+ avpkt.flags = AV_PKT_FLAG_KEY;
+ dec_len = avcodec_decode_video2(decoder_t->context,
+ dst, &got_picture, &avpkt);
if (got_picture)
{
@@ -95,7 +96,7 @@
dest_width = PHMEDIA_VIDEO_FRAME_WIDTH;
dest_height = PHMEDIA_VIDEO_FRAME_HEIGHT;
- encoder_t->context = avcodec_alloc_context();
+ encoder_t->context = avcodec_alloc_context3(NULL);
encoder_t->encoder = avcodec_find_encoder(
meta_t->avcodec_encoder_id);
@@ -144,7 +145,7 @@
dest_height = PHMEDIA_VIDEO_FRAME_HEIGHT;
- decoder_t->context = avcodec_alloc_context();
+ decoder_t->context = avcodec_alloc_context3(NULL);
decoder_t->pictureIn = avcodec_alloc_frame();
decoder_t->decoder = avcodec_find_decoder(meta_t->avcodec_decoder_id);
@@ -159,7 +160,7 @@
//decoder_t->context->dsp_mask = (FF_MM_MMX|FF_MM_MMXEXT|FF_MM_SSE|FF_MM_SSE2);
decoder_t->context->idct_algo = FF_IDCT_AUTO;
- if (avcodec_open(decoder_t->context, decoder_t->decoder) < 0)
+ if (avcodec_open2(decoder_t->context, decoder_t->decoder, NULL) < 0)
{
return -1;
}
diff -Nru qutecom-2.2.1.orig/wifo/phapi/phcodec-h263.c qutecom-2.2.1/wifo/phapi/phcodec-h263.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-h263.c 2014-05-15 14:34:08.441269093 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-h263.c 2014-05-15 14:34:37.222928237 +0000
@@ -76,6 +76,11 @@
}
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
+#ifdef CODEC_FLAG_H263P_SLICE_STRUCT
+ h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
+#else
+ av_opt_set_int(h263t->encoder_ctx.context->priv_data, "structured_slices", 1, 0);
+#endif
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QSCALE;
//h263t->encoder_ctx.context->flags |= CODEC_FLAG_INPUT_PRESERVED;
@@ -92,8 +97,8 @@
h263t->encoder_ctx.context->rc_buffer_size = DEFAULT_RATE * 64;
h263t->encoder_ctx.context->bit_rate = DEFAULT_RATE;
- if (avcodec_open(h263t->encoder_ctx.context,
- h263t->encoder_ctx.encoder) < 0)
+ if (avcodec_open2(h263t->encoder_ctx.context,
+ h263t->encoder_ctx.encoder, NULL) < 0)
{
return 0;
}
diff -Nru qutecom-2.2.1.orig/wifo/phapi/phcodec-h263flv1.c qutecom-2.2.1/wifo/phapi/phcodec-h263flv1.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-h263flv1.c 2014-05-15 14:34:08.442269081 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-h263flv1.c 2014-05-15 14:34:37.222928237 +0000
@@ -76,6 +76,11 @@
}
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
+#ifdef CODEC_FLAG_H263P_SLICE_STRUCT
+ h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
+#else
+ av_opt_set_int(h263t->encoder_ctx.context->priv_data, "structured_slices", 1, 0);
+#endif
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QSCALE;
//h263t->encoder_ctx.context->flags |= CODEC_FLAG_INPUT_PRESERVED;
@@ -92,8 +97,8 @@
h263t->encoder_ctx.context->rc_buffer_size = DEFAULT_RATE * 64;
h263t->encoder_ctx.context->bit_rate = DEFAULT_RATE;
- if (avcodec_open(h263t->encoder_ctx.context,
- h263t->encoder_ctx.encoder) < 0)
+ if (avcodec_open2(h263t->encoder_ctx.context,
+ h263t->encoder_ctx.encoder, NULL) < 0)
{
return 0;
}
diff -Nru qutecom-2.2.1.orig/wifo/phapi/phcodec-h263plus.c qutecom-2.2.1/wifo/phapi/phcodec-h263plus.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-h263plus.c 2014-05-15 14:34:08.442269081 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-h263plus.c 2014-05-15 14:34:37.222928237 +0000
@@ -69,6 +69,11 @@
}
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QP_RD;
+#ifdef CODEC_FLAG_H263P_SLICE_STRUCT
+ h263t->encoder_ctx.context->flags |= CODEC_FLAG_H263P_SLICE_STRUCT;
+#else
+ av_opt_set_int(h263t->encoder_ctx.context->priv_data, "structured_slices", 1, 0);
+#endif
h263t->encoder_ctx.context->flags |= CODEC_FLAG_QSCALE;
//h263t->encoder_ctx.context->flags |= CODEC_FLAG_INPUT_PRESERVED;
@@ -85,8 +90,8 @@
h263t->encoder_ctx.context->rc_buffer_size = DEFAULT_RATE * 64;
h263t->encoder_ctx.context->bit_rate = DEFAULT_RATE;
- if (avcodec_open(h263t->encoder_ctx.context,
- h263t->encoder_ctx.encoder) < 0)
+ if (avcodec_open2(h263t->encoder_ctx.context,
+ h263t->encoder_ctx.encoder, NULL) < 0)
{
return 0;
}
diff -Nru qutecom-2.2.1.orig/wifo/phapi/phcodec-h264.c qutecom-2.2.1/wifo/phapi/phcodec-h264.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-h264.c 2014-05-15 14:34:08.442269081 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-h264.c 2014-05-15 14:34:37.222928237 +0000
@@ -77,8 +77,8 @@
return 0;
}
- if (avcodec_open(h264t->encoder_ctx.context,
- h264t->encoder_ctx.encoder) < 0)
+ if (avcodec_open2(h264t->encoder_ctx.context,
+ h264t->encoder_ctx.encoder, NULL) < 0)
{
return -1;
}
diff -Nru qutecom-2.2.1.orig/wifo/phapi/phcodec-mpeg4.c qutecom-2.2.1/wifo/phapi/phcodec-mpeg4.c
--- qutecom-2.2.1.orig/wifo/phapi/phcodec-mpeg4.c 2014-05-15 14:34:08.443269070 +0000
+++ qutecom-2.2.1/wifo/phapi/phcodec-mpeg4.c 2014-05-15 14:34:37.222928237 +0000
@@ -96,8 +96,8 @@
mpeg4t->encoder_ctx.context->i_quant_factor = -0.8;
mpeg4t->encoder_ctx.context->thread_count = 1;
- if (avcodec_open(mpeg4t->encoder_ctx.context,
- mpeg4t->encoder_ctx.encoder) < 0)
+ if (avcodec_open2(mpeg4t->encoder_ctx.context,
+ mpeg4t->encoder_ctx.encoder, NULL) < 0)
{
return 0;
}

111
qutecom.spec Normal file
View File

@ -0,0 +1,111 @@
Name: qutecom
Version: 2.2.1
Release: 1mamba
Summary: A SIP-compliant VoIP client offering free calling to other softphones.
Group: Graphical Desktop/Applications/Communications
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://trac.qutecom.org
Source: http://downloads.sourceforge.net/project/qutecom.mirror/qutecom-%{version}.tar.gz
Patch0: qutecom-2.2.1-libboost-1.50.patch
Patch1: qutecom-2.2.1-ffmpeg-2.2.2.patch
Patch2: qutecom-2.2.1-new-videodev.patch
Patch3: qutecom-2.2.1-libboost-link.patch
Patch4: qutecom-2.2.1-phapi-ffmpeg-2.2.patch
Patch5: qutecom-2.2.1-ffmpeg-2.2-no_CODEC_FLAG_QP_RD.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libX11-devel
BuildRequires: libXScrnSaver-devel
BuildRequires: libXau-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXft-devel
BuildRequires: libXpm-devel
BuildRequires: libXv-devel
BuildRequires: libalsa-devel
BuildRequires: libavcodec-ffmpeg-devel
BuildRequires: libavformat-ffmpeg-devel
BuildRequires: libavutil-ffmpeg-devel
BuildRequires: libboost-devel
BuildRequires: libcurl-devel
BuildRequires: libgcc
BuildRequires: libglib-devel
BuildRequires: libgnutls-devel
BuildRequires: libopenssl-devel
BuildRequires: libqt4-devel
BuildRequires: libsamplerate-devel
BuildRequires: libsndfile-devel
BuildRequires: libspeex-devel
BuildRequires: libstdc++6-devel
BuildRequires: libswscale-ffmpeg-devel
BuildRequires: libuuid-devel
BuildRequires: libxml2-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
QuteCom (previously called OpenWengo) is a SIP-compliant voice-over-IP client that allows you to speak to other users of SIP-compliant softphones at no cost. It also allows users to call landlines and cell phones, send SMS text, and make video calls, and is compatible with any SIP provider.
%debug_package
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p0
%patch4 -p1
%patch5 -p1
%build
%cmake -d build
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
chmod 755 %{buildroot}%{_libdir}/pm-utils/sleep.d/70QuteCom
%find_lang %{name} || touch %{name}.lang
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%posttrans
if [ $1 -ge 1 ]; then
update-desktop-database -q >/dev/null 2>&1
update-mime-database %{_datadir}/mime >/dev/null 2>&1
gtk-update-icon-cache %{_datadir}/icons/hicolor >/dev/null 2>&1
fi
exit 0
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/qutecom
%{_libdir}/pm-utils/sleep.d/70QuteCom
%{_libdir}/qutecom/liblibpurple.so
%{_libdir}/qutecom/libowbase.so
%{_libdir}/qutecom/libowsl.so
%{_libdir}/qutecom/libowutil.so
%{_libdir}/qutecom/libphapi.so
%{_libdir}/qutecom/libphapiutil.so
%{_libdir}/qutecom/libphspeexplugin.so
%{_libdir}/qutecom/libpsiidle.so
%{_libdir}/qutecom/libsfp-plugin.so
%{_libdir}/qutecom/libwebcam.so
%{_datadir}/applications/qutecom.desktop
%{_datadir}/icons/hicolor/*/apps/qutecom.png
%dir %{_datadir}/qutecom
%{_datadir}/qutecom/*
%doc COPYING
%changelog
* Mon May 12 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1-1mamba
- package created using the webbuild interface