374 lines
13 KiB
RPMSpec
374 lines
13 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: qt6-qttools
|
|
Version: 6.7.0
|
|
Release: 1mamba
|
|
Summary: Qt6 tools
|
|
Group: Development/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.qt.io/
|
|
Source: https://download.qt.io/official_releases/qt/%{majver}/%{version}/submodules/qttools-everywhere-src-%{version}.tar.xz
|
|
Source1: libqt6-designer.desktop
|
|
Source2: libqt6-linguist.desktop
|
|
Source3: libqt6-assistant.desktop
|
|
Source4: libqt6-qdbusviewer.desktop
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libclang-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libllvm-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libxkbcommon-devel
|
|
BuildRequires: libzstd-devel
|
|
BuildRequires: qt6-qtbase-devel
|
|
BuildRequires: qt6-qtdeclarative-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libclang-devel >= 17.0.3
|
|
BuildRequires: libllvm-devel >= 17.0.3
|
|
BuildRequires: qt6-qtdeclarative-devel = %{version}
|
|
|
|
%description
|
|
Qt6 tools.
|
|
|
|
%package -n qt6-assistant
|
|
Group: Graphical Desktop/Applications/Development
|
|
Summary: Qt6 assistant
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n qt6-assistant
|
|
Qt6 assistant.
|
|
|
|
%package -n qt6-designer
|
|
Group: Graphical Desktop/Applications/Development
|
|
Summary: Qt6 designer
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: libQt6Designer = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n qt6-designer
|
|
Qt6 designer.
|
|
|
|
%package -n libQt6Designer
|
|
Group: System/Libraries
|
|
Summary: Qt6 designer shared libraries
|
|
|
|
%description -n libQt6Designer
|
|
Qt6 designer shared libraries.
|
|
|
|
%package -n qt6-doctools
|
|
Group: Graphical Desktop/Applications/Development
|
|
Summary: Qt6 doc tools
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: libQt6Help = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n qt6-doctools
|
|
Qt6 doctools.
|
|
|
|
%package -n libQt6Help
|
|
Group: System/Libraries
|
|
Summary: Qt6 help shared libraries
|
|
|
|
%description -n libQt6Help
|
|
Qt6 help shared libraries.
|
|
|
|
%package -n qt6-linguist
|
|
Group: Graphical Desktop/Applications/Development
|
|
Summary: Qt6 linguist
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n qt6-linguist
|
|
Qt6 linguist.
|
|
|
|
%package -n qt6-qdbusviewer
|
|
Group: Graphical Desktop/Applications/Development
|
|
Summary: Qt6 dbus viewer
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n qt6-qdbusviewer
|
|
Qt6 dbus viewer.
|
|
|
|
%package devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: qt6-assistant = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: qt6-designer = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: qt6-linguist = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: qt6-qdbusviewer = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: libQt6Designer = %{?epoch:%epoch:}%{version}-%{release}
|
|
Requires: libQt6Help = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n qttools-everywhere-src-%{version}
|
|
|
|
%build
|
|
%cmake -d build \
|
|
-G Ninja
|
|
|
|
cmake --build .
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
DESTDIR="%{buildroot}" cmake --install build
|
|
|
|
install -d -m0755 %{buildroot}%{_bindir}
|
|
for f in assistant designer lconvert linguist lrelease lupdate pixeltool \
|
|
qdbus qbusviewer qdoc qhelpgenerator qtdiag qtplugininfo qdistancefieldgenerator; do
|
|
ln -s ../%{_lib}/qt6/bin/${f} %{buildroot}%{_bindir}/${f}-qt6
|
|
done
|
|
|
|
# install desktop files
|
|
install -D -m0644 %{SOURCE1} %{buildroot}%{_datadir}/applications/designer-qt6.desktop
|
|
install -D -m0644 %{SOURCE2} %{buildroot}%{_datadir}/applications/linguist-qt6.desktop
|
|
install -D -m0644 %{SOURCE3} %{buildroot}%{_datadir}/applications/assistant-qt6.desktop
|
|
install -D -m0644 %{SOURCE4} %{buildroot}%{_datadir}/applications/qdbusviewer-qt6.desktop
|
|
|
|
# install icons
|
|
install -m644 -p -D src/assistant/assistant/images/assistant.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/assistant-qt6.png
|
|
install -m644 -p -D src/assistant/assistant/images/assistant-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/assistant-qt6.png
|
|
install -m644 -p -D src/designer/src/designer/images/designer.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/designer-qt6.png
|
|
install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/qdbusviewer-qt6.png
|
|
install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/qdbusviewer-qt6.png
|
|
|
|
# linguist icons
|
|
for icon in src/linguist/linguist/images/icons/linguist-*-32.png ; do
|
|
size=$(echo $(basename ${icon}) | cut -d- -f2)
|
|
install -p -m644 -D ${icon} %{buildroot}%{_datadir}/icons/hicolor/${size}x${size}/apps/linguist-qt6.png
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%post -n libQt6Designer -p /sbin/ldconfig
|
|
%postun -n libQt6Designer -p /sbin/ldconfig
|
|
|
|
%post -n libQt6Help -p /sbin/ldconfig
|
|
%postun -n libQt6Help -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/qdbus-qt6
|
|
%{_libdir}/qt6/bin/qdbus
|
|
%{_libdir}/libQt6UiTools.so.*
|
|
%doc LICENSES
|
|
|
|
%files -n qt6-assistant
|
|
%defattr(-,root,root)
|
|
%{_bindir}/assistant-qt6
|
|
%{_libdir}/qt6/bin/assistant
|
|
%{_datadir}/applications/assistant-qt6.desktop
|
|
%{_datadir}/icons/hicolor/*/apps/assistant-qt6.png
|
|
|
|
%files -n qt6-designer
|
|
%defattr(-,root,root)
|
|
%{_bindir}/designer-qt6
|
|
%{_libdir}/qt6/bin/designer
|
|
%{_datadir}/applications/designer-qt6.desktop
|
|
%{_datadir}/icons/hicolor/*/apps/designer-qt6.png
|
|
|
|
%files -n libQt6Designer
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libQt6Designer.so.*
|
|
%{_libdir}/libQt6DesignerComponents.so.*
|
|
%{_libdir}/qt6/plugins/designer/libqquickwidget.so
|
|
|
|
%files -n qt6-linguist
|
|
%defattr(-,root,root)
|
|
%{_bindir}/lconvert-qt6
|
|
%{_bindir}/lrelease-qt6
|
|
%{_bindir}/lupdate-qt6
|
|
%{_bindir}/linguist-qt6
|
|
%{_libdir}/qt6/bin/lconvert
|
|
%{_libdir}/qt6/bin/lrelease
|
|
%{_libdir}/qt6/bin/lupdate
|
|
%{_libdir}/qt6/bin/linguist
|
|
%{_libdir}/qt6/libexec/lprodump
|
|
%{_libdir}/qt6/libexec/lrelease-pro
|
|
%{_libdir}/qt6/libexec/lupdate-pro
|
|
%{_datadir}/applications/linguist-qt6.desktop
|
|
%{_datadir}/qt6/phrasebooks/danish.qph
|
|
%{_datadir}/qt6/phrasebooks/dutch.qph
|
|
%{_datadir}/qt6/phrasebooks/finnish.qph
|
|
%{_datadir}/qt6/phrasebooks/french.qph
|
|
%{_datadir}/qt6/phrasebooks/german.qph
|
|
%{_datadir}/qt6/phrasebooks/hungarian.qph
|
|
%{_datadir}/qt6/phrasebooks/italian.qph
|
|
%{_datadir}/qt6/phrasebooks/japanese.qph
|
|
%{_datadir}/qt6/phrasebooks/norwegian.qph
|
|
%{_datadir}/qt6/phrasebooks/polish.qph
|
|
%{_datadir}/qt6/phrasebooks/russian.qph
|
|
%{_datadir}/qt6/phrasebooks/spanish.qph
|
|
%{_datadir}/qt6/phrasebooks/swedish.qph
|
|
%{_datadir}/icons/hicolor/*/apps/linguist-qt6.png
|
|
|
|
%files -n qt6-qdbusviewer
|
|
%defattr(-,root,root)
|
|
%{_bindir}/qbusviewer-qt6
|
|
%{_libdir}/qt6/bin/qdbusviewer
|
|
%{_datadir}/applications/qdbusviewer-qt6.desktop
|
|
%{_datadir}/icons/hicolor/*/apps/qdbusviewer-qt6.png
|
|
|
|
%files -n qt6-doctools
|
|
%defattr(-,root,root)
|
|
%{_bindir}/qdoc-qt6
|
|
%{_bindir}/qdistancefieldgenerator-qt6
|
|
%{_bindir}/qhelpgenerator-qt6
|
|
%{_libdir}/qt6/bin/qdoc
|
|
%{_libdir}/qt6/bin/qdistancefieldgenerator
|
|
%{_libdir}/qt6/libexec/qhelpgenerator
|
|
%{_libdir}/qt6/libexec/qtattributionsscanner
|
|
|
|
%files -n libQt6Help
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libQt6Help.so.*
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%{_bindir}/pixeltool-qt6
|
|
%{_bindir}/qtdiag-qt6
|
|
%{_bindir}/qtplugininfo-qt6
|
|
%{_libdir}/qt6/bin/pixeltool
|
|
%{_libdir}/qt6/bin/qtdiag
|
|
%{_libdir}/qt6/bin/qtdiag6
|
|
%{_libdir}/qt6/bin/qtplugininfo
|
|
%dir %{_includedir}/qt6/QtDesigner
|
|
%{_includedir}/qt6/QtDesigner/*
|
|
%dir %{_includedir}/qt6/QtDesignerComponents
|
|
%{_includedir}/qt6/QtDesignerComponents/*
|
|
%dir %{_includedir}/qt6/QtQDocCatch
|
|
%{_includedir}/qt6/QtQDocCatch/*
|
|
%dir %{_includedir}/qt6/QtQDocCatchConversions
|
|
%{_includedir}/qt6/QtQDocCatchConversions/*
|
|
%dir %{_includedir}/qt6/QtQDocCatchGenerators
|
|
%{_includedir}/qt6/QtQDocCatchGenerators/*
|
|
%dir %{_includedir}/qt6/QtHelp
|
|
%{_includedir}/qt6/QtHelp/*
|
|
%dir %{_includedir}/qt6/QtUiPlugin
|
|
%{_includedir}/qt6/QtUiPlugin/*
|
|
%dir %{_includedir}/qt6/QtUiTools
|
|
%{_includedir}/qt6/QtUiTools/*
|
|
%dir %{_includedir}/qt6/QtTools
|
|
%{_includedir}/qt6/QtTools/*
|
|
%{_libdir}/libQt6Designer.prl
|
|
%{_libdir}/libQt6Designer.so
|
|
%{_libdir}/libQt6DesignerComponents.prl
|
|
%{_libdir}/libQt6DesignerComponents.so
|
|
%{_libdir}/libQt6Help.prl
|
|
%{_libdir}/libQt6Help.so
|
|
%{_libdir}/libQt6UiTools.so
|
|
%{_libdir}/libQt6UiTools.prl
|
|
%{_libdir}/qt6/metatypes/qt6*.json
|
|
%{_libdir}/qt6/modules/*.json
|
|
%{_libdir}/qt6/mkspecs/modules/qt_lib_*.pri
|
|
%{_libdir}/cmake/Qt6/FindWrapLibClang.cmake
|
|
%{_libdir}/cmake/Qt6BuildInternals/StandaloneTests/QtToolsTestsConfig.cmake
|
|
%dir %{_libdir}/cmake/Qt6Designer
|
|
%{_libdir}/cmake/Qt6Designer/Qt6Designer*.cmake
|
|
%{_libdir}/cmake/Qt6Designer/Qt6QQuickWidgetPlugin*.cmake
|
|
%dir %{_libdir}/cmake/Qt6DesignerComponentsPrivate
|
|
%{_libdir}/cmake/Qt6DesignerComponentsPrivate/Qt6DesignerComponentsPrivate*.cmake
|
|
%dir %{_libdir}/cmake/Qt6QDocCatchConversionsPrivate
|
|
%{_libdir}/cmake/Qt6QDocCatchConversionsPrivate/Qt6QDocCatchConversionsPrivate*.cmake
|
|
%dir %{_libdir}/cmake/Qt6QDocCatchGeneratorsPrivate
|
|
%{_libdir}/cmake/Qt6QDocCatchGeneratorsPrivate/Qt6QDocCatchGeneratorsPrivate*.cmake
|
|
%dir %{_libdir}/cmake/Qt6QDocCatchPrivate
|
|
%{_libdir}/cmake/Qt6QDocCatchPrivate/Qt6QDocCatchPrivate*.cmake
|
|
%dir %{_libdir}/cmake/Qt6Help
|
|
%{_libdir}/cmake/Qt6Help/Qt6Help*.cmake
|
|
%dir %{_libdir}/cmake/Qt6Linguist
|
|
%{_libdir}/cmake/Qt6Linguist/Qt6Linguist*.cmake
|
|
%dir %{_libdir}/cmake/Qt6LinguistTools
|
|
%{_libdir}/cmake/Qt6LinguistTools/Qt6LinguistTools*.cmake
|
|
%{_libdir}/cmake/Qt6LinguistTools/GenerateLUpdateProject.cmake
|
|
%dir %{_libdir}/cmake/Qt6Tools
|
|
%{_libdir}/cmake/Qt6Tools/Qt6Tools*.cmake
|
|
%dir %{_libdir}/cmake/Qt6ToolsTools
|
|
%{_libdir}/cmake/Qt6ToolsTools/Qt6ToolsTools*.cmake
|
|
%dir %{_libdir}/cmake/Qt6UiPlugin
|
|
%{_libdir}/cmake/Qt6UiPlugin/Qt6UiPlugin*.cmake
|
|
%dir %{_libdir}/cmake/Qt6UiTools
|
|
%{_libdir}/cmake/Qt6UiTools/Qt6UiTools*.cmake
|
|
%{_libdir}/pkgconfig/Qt6*.pc
|
|
|
|
%changelog
|
|
* Tue Apr 16 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.7.0-1mamba
|
|
- update to 6.7.0
|
|
|
|
* Sat Mar 30 2024 Automatic Build System <autodist@openmamba.org> 6.6.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 17 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.6.2-2mamba
|
|
- split assistant, designer, linguist, qdbusviewer into subpackages
|
|
|
|
* Fri Feb 16 2024 Automatic Build System <autodist@openmamba.org> 6.6.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 29 2023 Automatic Build System <autodist@mambasoft.it> 6.6.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 17 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 6.6.0-1mamba
|
|
- update to 6.6.0
|
|
|
|
* Sat Oct 07 2023 Automatic Build System <autodist@mambasoft.it> 6.5.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 22 2023 Automatic Build System <autodist@mambasoft.it> 6.5.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 29 2023 Automatic Build System <autodist@mambasoft.it> 6.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 23 2023 Sdk Build System <sdk@mambasoft.it> 6.5.0-2mamba
|
|
- rebuilt by autoport with build requirements: libllvm-devel>=0:16.0.4-1mamba
|
|
|
|
* Fri Apr 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 6.5.0-1mamba
|
|
- update to 6.5.0
|
|
|
|
* Sat Mar 18 2023 Automatic Build System <autodist@mambasoft.it> 6.4.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 08 2023 Automatic Build System <autodist@mambasoft.it> 6.4.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 22 2022 Automatic Build System <autodist@mambasoft.it> 6.4.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 07 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 6.4.0-1mamba
|
|
- update to 6.4.0
|
|
|
|
* Tue Sep 13 2022 Automatic Build System <autodist@mambasoft.it> 6.3.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jun 19 2022 Automatic Build System <autodist@mambasoft.it> 6.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 6.3.0-2mamba
|
|
- rebuilt with llvm 14.0.3
|
|
|
|
* Thu Apr 14 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 6.3.0-1mamba
|
|
- update to 6.3.0
|
|
|
|
* Mon Mar 21 2022 Automatic Build System <autodist@mambasoft.it> 6.2.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 26 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 6.2.3-1mamba
|
|
- update to 6.2.3
|
|
|
|
* Tue Nov 09 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.15.2-2mamba
|
|
- bump release
|
|
|
|
* Tue Nov 09 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.15.2-1mamba
|
|
- package created using the webbuild interface
|