273 lines
9.1 KiB
RPMSpec
273 lines
9.1 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
%define pkgver %(echo %version | tr _ -)
|
|
Name: qt-creator
|
|
Version: 6.0.2
|
|
Release: 1mamba
|
|
Summary: An integrated development environment (IDE) tailored to the needs of Qt developers
|
|
Group: Development/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.qt.io/product/development-tools
|
|
Source: http://download.qt.io/official_releases/qtcreator/%{majver}/%{version}/qt-creator-opensource-src-%{version}.tar.xz
|
|
Source1: qtcreator.desktop
|
|
Source2: qtcreator-wrapper
|
|
Patch0: qt-creator-4.12.1-enable-it-es-translations.patch
|
|
Patch1: qt-creator-opensource-src-5.0.2-libyaml-cpp-0.7.0.patch
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libQt6SerialPort-devel
|
|
BuildRequires: libclang-devel
|
|
BuildRequires: libdw-devel
|
|
BuildRequires: libelf-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libxkbcommon-devel
|
|
BuildRequires: libzstd-devel
|
|
BuildRequires: qt6-qt5compat-devel
|
|
BuildRequires: qt6-qtbase-devel
|
|
BuildRequires: qt6-qtdeclarative-devel
|
|
BuildRequires: qt6-qtquick3d-devel
|
|
BuildRequires: qt6-qtshadertools-devel
|
|
BuildRequires: qt6-qtsvg-devel
|
|
BuildRequires: qt6-qttools-devel
|
|
BuildRequires: qt6-qtwebengine-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libyaml-cpp-devel >= 0.7.0
|
|
Requires: libqt5-designer
|
|
Requires: gcc-c++
|
|
|
|
%description
|
|
Qt Creator is a cross-platform integrated development environment (IDE) tailored to the needs of Qt developers.
|
|
|
|
It includes:
|
|
* An advanced C++ code editor
|
|
* Integrated GUI layout and forms designer
|
|
* Project and build management tools
|
|
* Integrated, context-sensitive help system
|
|
* Visual debugger
|
|
* Rapid code navigation tools
|
|
* Supports multiple platforms
|
|
|
|
#% debug_package
|
|
|
|
%prep
|
|
%setup -q -n %{name}-opensource-src-%{pkgver}
|
|
#-D -T
|
|
#:<< _EOF
|
|
%patch0 -p1
|
|
%patch1 -p1
|
|
|
|
# fix hardcoded libexec path
|
|
sed -e 's|libexec\/qtcreator|%{_lib}\/qtcreator|g' -i qtcreator.pri
|
|
sed -e 's|libexec|%{_lib}|g' -i src/tools/tools.pro
|
|
|
|
%build
|
|
#:<< _EOF
|
|
%cmake -d build \
|
|
-DWITH_DOCS=ON \
|
|
-DBUILD_DEVELOPER_DOCS=ON \
|
|
-DBUILD_QBS=OFF \
|
|
-DQTC_CLANG_BUILDMODE_MATCH=ON \
|
|
-DBUILD_HELVIEWERBACKEND_QTWEBENGINE=ON
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
mv %{buildroot}%{_bindir}/qtcreator %{buildroot}%{_bindir}/qtcreator.bin
|
|
|
|
# install wrapper
|
|
install -D -m 755 %{S:2} %{buildroot}%{_bindir}/qtcreator
|
|
|
|
#install -d -m0755 %{buildroot}%{_datadir}/pixmaps
|
|
#cp %{buildroot}%{_datadir}/qtcreator/welcomescreen/widgets/images/qtcreator.png \
|
|
# %{buildroot}%{_datadir}/pixmaps/qtcreator.png
|
|
|
|
# link icons
|
|
#for i in 16 24 32 48 64 128 256
|
|
#do
|
|
# install -d %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
|
|
# ln -s ../../../../pixmaps/qtcreator_logo_${i}.png \
|
|
# %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/qtcreator.png
|
|
#done
|
|
|
|
# install desktop file
|
|
#install -D -m 644 %{S:1} %{buildroot}%{_datadir}/applications/qtcreator.desktop
|
|
|
|
# copy doc to its correct destination
|
|
#install -D share/doc/qtcreator/qtcreator.qch \
|
|
# %{buildroot}%{_qt4_docdir}/qch/qtcreator.qch
|
|
rm -rf %{buildroot}%{_docdir}
|
|
|
|
# remove useless devel libraries
|
|
rm -f %{buildroot}%{_libdir}/qtcreator/*.so
|
|
|
|
# Remove rpaths
|
|
for f in %{buildroot}{%{_libdir}/qtcreator/{plugins/Nokia/*.so,*.so.?.*},%{_bindir}/qtcreator.bin}; do
|
|
chrpath --list $f && chrpath --delete $f || :
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/*
|
|
%dir %{_libdir}/qtcreator
|
|
%{_libdir}/qtcreator/*
|
|
%dir %{_datadir}/qtcreator
|
|
%{_datadir}/qtcreator/*
|
|
%{_datadir}/applications/*.desktop
|
|
%{_datadir}/icons/hicolor/*/apps/*.png
|
|
%dir %{_prefix}/libexec/qtcreator
|
|
%{_prefix}/libexec/qtcreator/*
|
|
%{_datadir}/metainfo/org.qt-project.qtcreator.appdata.xml
|
|
%doc LICENSE.GPL3-EXCEPT
|
|
|
|
%changelog
|
|
* Mon Feb 28 2022 Automatic Build System <autodist@mambasoft.it> 6.0.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 12 2021 Automatic Build System <autodist@mambasoft.it> 5.0.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 21 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.0.2-1mamba
|
|
- update to 5.0.2
|
|
|
|
* Wed Mar 24 2021 Automatic Build System <autodist@mambasoft.it> 4.14.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 24 2021 Automatic Build System <autodist@mambasoft.it> 4.14.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 18 2020 Automatic Build System <autodist@mambasoft.it> 4.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 21 2020 Automatic Build System <autodist@mambasoft.it> 4.13.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 13 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.13.2-2mamba
|
|
- rebuilt with docs
|
|
|
|
* Sat Oct 03 2020 Automatic Build System <autodist@mambasoft.it> 4.13.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 17 2020 Automatic Build System <autodist@mambasoft.it> 4.13.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 26 2020 Automatic Build System <autodist@mambasoft.it> 4.13.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 08 2020 Automatic Build System <autodist@mambasoft.it> 4.12.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 18 2020 Automatic Build System <autodist@mambasoft.it> 4.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 03 2020 Automatic Build System <autodist@mambasoft.it> 4.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.1-1mamba
|
|
- update to 4.12.1
|
|
|
|
* Wed Apr 08 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.0_rc1-1mamba
|
|
- update to 4.12.0_rc1
|
|
|
|
* Tue Mar 31 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.1-3mamba
|
|
- translatons patch fixed
|
|
|
|
* Sun Mar 29 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.1-2mamba
|
|
- patched to enable it and es translations
|
|
|
|
* Sun Feb 09 2020 Automatic Build System <autodist@mambasoft.it> 4.11.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 12 2019 Automatic Build System <autodist@mambasoft.it> 4.11.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 06 2019 Automatic Build System <autodist@mambasoft.it> 4.10.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 09 2019 Automatic Build System <autodist@mambasoft.it> 4.10.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 06 2019 Automatic Build System <autodist@mambasoft.it> 4.10.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 28 2019 Automatic Build System <autodist@mambasoft.it> 4.9.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 29 2019 Automatic Build System <autodist@mambasoft.it> 4.9.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 15 2019 Automatic Build System <autodist@mambasoft.it> 4.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 02 2019 Automatic Build System <autodist@mambasoft.it> 4.8.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 25 2019 Automatic Build System <autodist@mambasoft.it> 4.8.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jun 17 2018 Automatic Build System <autodist@mambasoft.it> 4.6.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 03 2018 Automatic Build System <autodist@mambasoft.it> 4.6.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 28 2018 Automatic Build System <autodist@mambasoft.it> 4.6.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 17 2018 Automatic Build System <autodist@mambasoft.it> 4.5.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 13 2018 Automatic Build System <autodist@mambasoft.it> 4.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 27 2017 Automatic Build System <autodist@mambasoft.it> 4.5.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 23 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.1-1mamba
|
|
- update to 4.4.1
|
|
|
|
* Fri Jul 11 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.1-2mamba
|
|
- fixed menu icon
|
|
|
|
* Fri Jul 11 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.1-1mamba
|
|
- update to 2.8.1
|
|
|
|
* Tue Feb 12 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.2-1mamba
|
|
- update to 2.6.2
|
|
|
|
* Sun Aug 12 2012 Automatic Build System <autodist@mambasoft.it> 2.5.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 30 2012 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.5.0-1mamba
|
|
- update to 2.5.0
|
|
|
|
* Tue Oct 04 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.3.1-1mamba
|
|
- update to 2.3.1
|
|
|
|
* Wed Sep 07 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.3.0-1mamba
|
|
- update to 2.3.0
|
|
|
|
* Mon Jul 25 2011 Automatic Build System <autodist@mambasoft.it> 2.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 06 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.0-1mamba
|
|
- update to 2.2.0
|
|
|
|
* Thu Feb 17 2011 Automatic Build System <autodist@mambasoft.it> 2.1.0-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Nov 07 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.0.1-1mamba
|
|
- update to 2.0.1
|
|
|
|
* Mon Jul 12 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.3.1-1mamba
|
|
- package created by autospec
|