automatic version update by autodist [release 14.0.2-1mamba;Sat Oct 05 2024]
This commit is contained in:
parent
34668a6e1e
commit
a2f21b4bc5
15
qt-creator-14.0.2-clang-19.patch
Normal file
15
qt-creator-14.0.2-clang-19.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -rupN --no-dereference qt-creator-opensource-src-14.0.2/src/plugins/clangformat/clangformatutils.cpp qt-creator-opensource-src-14.0.2-new/src/plugins/clangformat/clangformatutils.cpp
|
||||
--- qt-creator-opensource-src-14.0.2/src/plugins/clangformat/clangformatutils.cpp 2024-09-27 03:17:48.000000000 +0200
|
||||
+++ qt-creator-opensource-src-14.0.2-new/src/plugins/clangformat/clangformatutils.cpp 2024-10-04 11:43:19.140491504 +0200
|
||||
@@ -117,7 +117,11 @@ clang::format::FormatStyle calculateQtcS
|
||||
style.IndentWrappedFunctionNames = false;
|
||||
style.JavaScriptQuotes = FormatStyle::JSQS_Leave;
|
||||
style.JavaScriptWrapImports = true;
|
||||
+#if LLVM_VERSION_MAJOR >= 19
|
||||
+ style.KeepEmptyLines = {false, false, false};
|
||||
+#else
|
||||
style.KeepEmptyLinesAtTheStartOfBlocks = false;
|
||||
+#endif
|
||||
// Do not add QT_BEGIN_NAMESPACE/QT_END_NAMESPACE as this will indent lines in between.
|
||||
style.MacroBlockBegin = "";
|
||||
style.MacroBlockEnd = "";
|
@ -1,8 +0,0 @@
|
||||
--- qt-creator-opensource-src-4.12.1/share/qtcreator/translations/CMakeLists.txt.orig 2020-05-21 12:38:47.614000000 +0200
|
||||
+++ qt-creator-opensource-src-4.12.1/share/qtcreator/translations/CMakeLists.txt 2020-05-21 12:38:54.189000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-set(languages cs da de fr hr ja pl ru sl uk zh_CN zh_TW)
|
||||
+set(languages cs da de fr hr it ja pl ru sl uk zh_CN zh_TW)
|
||||
set(bad_languages hu) # Fix these before including them in languages!
|
||||
|
||||
find_package(PythonInterp)
|
@ -1,7 +1,7 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
%define pkgver %(echo %version | tr _ -)
|
||||
Name: qt-creator
|
||||
Version: 14.0.1
|
||||
Version: 14.0.2
|
||||
Release: 1mamba
|
||||
Summary: An integrated development environment (IDE) tailored to the needs of Qt developers
|
||||
Group: Development/Tools
|
||||
@ -12,7 +12,7 @@ URL: https://www.qt.io/product/development-tools
|
||||
Source: http://download.qt.io/official_releases/qtcreator/%{majver}/%{version}/qt-creator-opensource-src-%{version}.tar.xz
|
||||
Source1: qtcreator.desktop
|
||||
Source2: qtcreator-wrapper
|
||||
Patch0: qt-creator-4.12.1-enable-it-es-translations.patch
|
||||
Patch1: qt-creator-14.0.2-clang-19.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -41,7 +41,7 @@ BuildRequires: qt6-qttools-devel
|
||||
BuildRequires: qt6-qtwebchannel-devel
|
||||
BuildRequires: qt6-qtwebengine-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libclang-devel >= 17.0.6-2mamba
|
||||
BuildRequires: libclang-devel >= 19.1.1
|
||||
BuildRequires: libyaml-cpp-devel >= 0.7.0
|
||||
Requires: qt6-designer
|
||||
Requires: gcc-c++
|
||||
@ -67,6 +67,7 @@ It includes:
|
||||
%setup -q -n %{name}-opensource-src-%{pkgver}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch 1 -p1 -b .clang-19
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
@ -109,6 +110,9 @@ sed -i 's|/qtcreator"|/qtcreator.bin"|' %{buildroot}%{_bindir}/qtcreator
|
||||
%doc LICENSE.GPL3-EXCEPT
|
||||
|
||||
%changelog
|
||||
* Sat Oct 05 2024 Automatic Build System <autodist@openmamba.org> 14.0.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 14 2024 Automatic Build System <autodist@openmamba.org> 14.0.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user