clean old specfile customizations, require qt6-designer [release 13.0.2-2mamba;Sat Jun 08 2024]
This commit is contained in:
parent
727036a857
commit
70296db150
@ -1,8 +0,0 @@
|
||||
--- qt-creator-opensource-src-5.0.2/src/plugins/clangtools/CMakeLists.txt.orig 2021-11-03 18:54:43.664016807 +0100
|
||||
+++ qt-creator-opensource-src-5.0.2/src/plugins/clangtools/CMakeLists.txt 2021-11-03 18:53:44.593602072 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-find_package(yaml-cpp QUIET MODULE)
|
||||
+#find_package(yaml-cpp QUIET MODULE)
|
||||
|
||||
add_qtc_plugin(ClangTools
|
||||
CONDITION TARGET yaml-cpp
|
@ -2,7 +2,7 @@
|
||||
%define pkgver %(echo %version | tr _ -)
|
||||
Name: qt-creator
|
||||
Version: 13.0.2
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: An integrated development environment (IDE) tailored to the needs of Qt developers
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
@ -13,17 +13,16 @@ Source: http://download.qt.io/official_releases/qtcreator/%{majver}/%{ver
|
||||
Source1: qtcreator.desktop
|
||||
Source2: qtcreator-wrapper
|
||||
Patch0: qt-creator-4.12.1-enable-it-es-translations.patch
|
||||
Patch1: qt-creator-opensource-src-5.0.2-libyaml-cpp-0.7.0.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt6SerialPort-devel
|
||||
BuildRequires: libclang-devel
|
||||
BuildRequires: libdw-devel
|
||||
BuildRequires: libelf-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libllvm-devel
|
||||
BuildRequires: libsecret-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
@ -42,7 +41,7 @@ BuildRequires: qt6-qtwebengine-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libclang-devel >= 17.0.6-2mamba
|
||||
BuildRequires: libyaml-cpp-devel >= 0.7.0
|
||||
Requires: libqt5-designer
|
||||
Requires: qt6-designer
|
||||
Requires: gcc-c++
|
||||
|
||||
%description
|
||||
@ -59,25 +58,24 @@ It includes:
|
||||
|
||||
%debug_package
|
||||
|
||||
# Don't clean build at the end
|
||||
%global __spec_rmbuild_cmd /bin/true
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-opensource-src-%{pkgver}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch 0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
## fix hardcoded libexec path
|
||||
#sed -e 's|libexec\/qtcreator|%{_lib}\/qtcreator|g' -i qtcreator.pri
|
||||
##sed -e 's|libexec|%{_lib}|g' -i src/tools/tools.pro
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake -d build \
|
||||
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
|
||||
-DCMAKE_INSTALL_LIBEXECDIR=%{_libexecdir} \
|
||||
-DWITH_DOCS=ON \
|
||||
-DBUILD_DEVELOPER_DOCS=ON \
|
||||
-DBUILD_QBS=OFF \
|
||||
-DQTC_CLANG_BUILDMODE_MATCH=ON \
|
||||
-DBUILD_HELVIEWERBACKEND_QTWEBENGINE=ON
|
||||
-DCLANGTOOLING_LINK_CLANG_DYLIB=ON
|
||||
|
||||
%make
|
||||
|
||||
@ -85,57 +83,34 @@ It includes:
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
mv %{buildroot}%{_bindir}/qtcreator %{buildroot}%{_bindir}/qtcreator.bin
|
||||
# Make qtcreator.sh the default binary and apply fixes
|
||||
mv %{buildroot}%{_bindir}/qtcreator{,.bin}
|
||||
mv %{buildroot}%{_bindir}/qtcreator{.sh,}
|
||||
|
||||
# install wrapper
|
||||
install -D -m 755 %{S:2} %{buildroot}%{_bindir}/qtcreator
|
||||
|
||||
#install -d -m0755 %{buildroot}%{_datadir}/pixmaps
|
||||
#cp %{buildroot}%{_datadir}/qtcreator/welcomescreen/widgets/images/qtcreator.png \
|
||||
# %{buildroot}%{_datadir}/pixmaps/qtcreator.png
|
||||
|
||||
# link icons
|
||||
#for i in 16 24 32 48 64 128 256
|
||||
#do
|
||||
# install -d %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
|
||||
# ln -s ../../../../pixmaps/qtcreator_logo_${i}.png \
|
||||
# %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/qtcreator.png
|
||||
#done
|
||||
|
||||
# install desktop file
|
||||
#install -D -m 644 %{S:1} %{buildroot}%{_datadir}/applications/qtcreator.desktop
|
||||
|
||||
# copy doc to its correct destination
|
||||
#install -D share/doc/qtcreator/qtcreator.qch \
|
||||
# %{buildroot}%{_qt4_docdir}/qch/qtcreator.qch
|
||||
rm -rf %{buildroot}%{_docdir}
|
||||
|
||||
# remove useless devel libraries
|
||||
rm -f %{buildroot}%{_libdir}/qtcreator/*.so
|
||||
|
||||
# Remove rpaths
|
||||
for f in %{buildroot}{%{_libdir}/qtcreator/{plugins/Nokia/*.so,*.so.?.*},%{_bindir}/qtcreator.bin}; do
|
||||
chrpath --list $f && chrpath --delete $f || :
|
||||
done
|
||||
sed -i 's|../lib"|../%{_lib}"|' %{buildroot}%{_bindir}/qtcreator
|
||||
sed -i 's|/qtcreator"|/qtcreator.bin"|' %{buildroot}%{_bindir}/qtcreator
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_bindir}/qtcreator*
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/metainfo/org.qt-project.qtcreator.appdata.xml
|
||||
%dir %{_libdir}/qtcreator
|
||||
%{_libdir}/qtcreator/*
|
||||
%dir %{_libexecdir}/qtcreator
|
||||
%{_libexecdir}/qtcreator/*
|
||||
%dir %{_datadir}/qtcreator
|
||||
%{_datadir}/qtcreator/*
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/*.png
|
||||
%dir %{_prefix}/libexec/qtcreator
|
||||
%{_prefix}/libexec/qtcreator/*
|
||||
%{_datadir}/metainfo/org.qt-project.qtcreator.appdata.xml
|
||||
%doc LICENSE.GPL3-EXCEPT
|
||||
|
||||
%changelog
|
||||
* Sat Jun 08 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 13.0.2-2mamba
|
||||
- clean old specfile customizations, require qt6-designer
|
||||
|
||||
* Thu Jun 06 2024 Automatic Build System <autodist@openmamba.org> 13.0.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user