automatic version update by autodist [release 5.0.3-1mamba;Fri Nov 12 2021]
This commit is contained in:
parent
7e1c4642c1
commit
4afec1e907
8
qt-creator-opensource-src-5.0.2-libyaml-cpp-0.7.0.patch
Normal file
8
qt-creator-opensource-src-5.0.2-libyaml-cpp-0.7.0.patch
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
--- qt-creator-opensource-src-5.0.2/src/plugins/clangtools/CMakeLists.txt.orig 2021-11-03 18:54:43.664016807 +0100
|
||||||
|
+++ qt-creator-opensource-src-5.0.2/src/plugins/clangtools/CMakeLists.txt 2021-11-03 18:53:44.593602072 +0100
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-find_package(yaml-cpp QUIET MODULE)
|
||||||
|
+#find_package(yaml-cpp QUIET MODULE)
|
||||||
|
|
||||||
|
add_qtc_plugin(ClangTools
|
||||||
|
CONDITION TARGET yaml-cpp
|
@ -1,34 +1,39 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
%define pkgver %(echo %version | tr _ -)
|
%define pkgver %(echo %version | tr _ -)
|
||||||
Name: qt-creator
|
Name: qt-creator
|
||||||
Version: 4.14.2
|
Version: 5.0.3
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: An integrated development environment (IDE) tailored to the needs of Qt developers
|
Summary: An integrated development environment (IDE) tailored to the needs of Qt developers
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://qt.digia.com/Product/Developer-Tools/
|
URL: https://www.qt.io/product/development-tools
|
||||||
Source: http://download.qt.io/official_releases/qtcreator/%{majver}/%{version}/qt-creator-opensource-src-%{version}.tar.xz
|
Source: http://download.qt.io/official_releases/qtcreator/%{majver}/%{version}/qt-creator-opensource-src-%{version}.tar.xz
|
||||||
#Source: http://download.qt.io/development_releases/qtcreator/%{majver}/%{pkgver}/qt-creator-opensource-src-%{pkgver}.tar.xz
|
|
||||||
#Source: http://download.qt.io/official_releases/qtcreator/%{majver}/%{version}/qt-creator-opensource-src-%{version}.tar.xz
|
|
||||||
Source1: qtcreator.desktop
|
Source1: qtcreator.desktop
|
||||||
Source2: qtcreator-wrapper
|
Source2: qtcreator-wrapper
|
||||||
Patch0: qt-creator-4.12.1-enable-it-es-translations.patch
|
Patch0: qt-creator-4.12.1-enable-it-es-translations.patch
|
||||||
|
Patch1: qt-creator-opensource-src-5.0.2-libyaml-cpp-0.7.0.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libGL-devel
|
BuildRequires: libQt5Positioning-devel
|
||||||
|
BuildRequires: libQt5SerialPort-devel
|
||||||
|
BuildRequires: libQt5Svg-devel
|
||||||
|
BuildRequires: libQt5WebChannel-devel
|
||||||
BuildRequires: libQt5WebEngine-devel
|
BuildRequires: libQt5WebEngine-devel
|
||||||
BuildRequires: libclang-devel
|
BuildRequires: libclang-devel
|
||||||
BuildRequires: libdw-devel
|
BuildRequires: libdw-devel
|
||||||
BuildRequires: libelf-devel
|
BuildRequires: libelf-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libllvm-devel
|
|
||||||
BuildRequires: libqt5-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libyaml-cpp-devel
|
BuildRequires: libsyntax-highlighting-devel
|
||||||
|
BuildRequires: libzstd-devel
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
|
BuildRequires: qt5-qtdeclarative-devel
|
||||||
|
BuildRequires: qt5-qttools-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libyaml-cpp-devel >= 0.7.0
|
||||||
Requires: libqt5-designer
|
Requires: libqt5-designer
|
||||||
Requires: gcc-c++
|
Requires: gcc-c++
|
||||||
|
|
||||||
@ -51,6 +56,7 @@ It includes:
|
|||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
# fix hardcoded libexec path
|
# fix hardcoded libexec path
|
||||||
sed -e 's|libexec\/qtcreator|%{_lib}\/qtcreator|g' -i qtcreator.pri
|
sed -e 's|libexec\/qtcreator|%{_lib}\/qtcreator|g' -i qtcreator.pri
|
||||||
@ -58,22 +64,18 @@ sed -e 's|libexec|%{_lib}|g' -i src/tools/tools.pro
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%{_qt5_qmake} \
|
%cmake -d build \
|
||||||
IDE_LIBRARY_BASENAME=%{_lib} \
|
-DWITH_DOCS=ON \
|
||||||
-r \
|
-DBUILD_DEVELOPER_DOCS=ON \
|
||||||
-spec linux-clang \
|
-DBUILD_QBS=OFF \
|
||||||
DEFINES+=QBS_ENABLE_PROJECT_FILE_UPDATES \
|
-DQTC_CLANG_BUILDMODE_MATCH=ON \
|
||||||
qtcreator.pro
|
-DBUILD_HELVIEWERBACKEND_QTWEBENGINE=ON
|
||||||
|
|
||||||
%make
|
%make
|
||||||
make docs
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall \
|
%makeinstall -C build
|
||||||
INSTALL_ROOT=%{buildroot}%{_prefix}
|
|
||||||
|
|
||||||
%makeinstall docs INSTALL_ROOT=%{buildroot}%{_prefix}
|
|
||||||
|
|
||||||
mv %{buildroot}%{_bindir}/qtcreator %{buildroot}%{_bindir}/qtcreator.bin
|
mv %{buildroot}%{_bindir}/qtcreator %{buildroot}%{_bindir}/qtcreator.bin
|
||||||
|
|
||||||
@ -120,12 +122,18 @@ done
|
|||||||
%{_datadir}/qtcreator/*
|
%{_datadir}/qtcreator/*
|
||||||
%{_datadir}/applications/*.desktop
|
%{_datadir}/applications/*.desktop
|
||||||
%{_datadir}/icons/hicolor/*/apps/*.png
|
%{_datadir}/icons/hicolor/*/apps/*.png
|
||||||
#%dir %{_prefix}/libexec/qtcreator
|
%dir %{_prefix}/libexec/qtcreator
|
||||||
#%{_prefix}/libexec/qtcreator/*
|
%{_prefix}/libexec/qtcreator/*
|
||||||
%{_datadir}/metainfo/org.qt-project.qtcreator.appdata.xml
|
%{_datadir}/metainfo/org.qt-project.qtcreator.appdata.xml
|
||||||
%doc LICENSE.GPL3-EXCEPT
|
%doc LICENSE.GPL3-EXCEPT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 12 2021 Automatic Build System <autodist@mambasoft.it> 5.0.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Oct 21 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.0.2-1mamba
|
||||||
|
- update to 5.0.2
|
||||||
|
|
||||||
* Wed Mar 24 2021 Automatic Build System <autodist@mambasoft.it> 4.14.2-1mamba
|
* Wed Mar 24 2021 Automatic Build System <autodist@mambasoft.it> 4.14.2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user