package created using the webbuild interface [release 2.2.0-1mamba;Mon Sep 12 2022]
This commit is contained in:
parent
61044e3bf5
commit
c75da0933f
@ -1,2 +1,4 @@
|
|||||||
# qt-color-widgets
|
# qt-color-widgets
|
||||||
|
|
||||||
|
A user-friendly color dialog and several color-related widgets for Qt.
|
||||||
|
|
||||||
|
39
qt-color-widgets-2.2.0-cmake-install-libdir.patch
Normal file
39
qt-color-widgets-2.2.0-cmake-install-libdir.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- Qt-Color-Widgets-2.2.0/cmake/install.cmake.orig 2022-09-12 19:18:05.487645650 +0200
|
||||||
|
+++ Qt-Color-Widgets-2.2.0/cmake/install.cmake 2022-09-12 19:18:24.941460200 +0200
|
||||||
|
@@ -11,8 +11,8 @@
|
||||||
|
EXPORT ${i_target_name}
|
||||||
|
RUNTIME DESTINATION bin
|
||||||
|
INCLUDES DESTINATION include
|
||||||
|
- ARCHIVE DESTINATION lib
|
||||||
|
- LIBRARY DESTINATION lib)
|
||||||
|
+ ARCHIVE DESTINATION lib64
|
||||||
|
+ LIBRARY DESTINATION lib64)
|
||||||
|
|
||||||
|
install (DIRECTORY include/
|
||||||
|
DESTINATION include
|
||||||
|
@@ -30,7 +30,7 @@
|
||||||
|
|
||||||
|
install(
|
||||||
|
EXPORT ${i_target_name}
|
||||||
|
- DESTINATION lib/cmake/${i_target_name}${i_target_output_suffix}
|
||||||
|
+ DESTINATION lib64/cmake/${i_target_name}${i_target_output_suffix}
|
||||||
|
FILE "${i_target_name}${i_target_output_suffix}.cmake"
|
||||||
|
COMPONENT Devel)
|
||||||
|
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
@ONLY
|
||||||
|
)
|
||||||
|
|
||||||
|
- set(ConfigPackageLocation "lib/cmake/${i_target_name}${i_target_output_suffix}")
|
||||||
|
+ set(ConfigPackageLocation "lib64/cmake/${i_target_name}${i_target_output_suffix}")
|
||||||
|
install(EXPORT ${i_target_name}
|
||||||
|
FILE
|
||||||
|
"${CMAKE_BASE_FILE_NAME}${CMAKE_FILE_OUTPUT_SUFFIX}-targets.cmake"
|
||||||
|
@@ -83,6 +83,6 @@
|
||||||
|
install(FILES
|
||||||
|
${CMAKE_CURRENT_BINARY_DIR}/${i_target_name}${i_target_output_suffix}.pc
|
||||||
|
DESTINATION
|
||||||
|
- lib/pkgconfig
|
||||||
|
+ lib64/pkgconfig
|
||||||
|
)
|
||||||
|
endfunction (install_project)
|
81
qt-color-widgets.spec
Normal file
81
qt-color-widgets.spec
Normal file
@ -0,0 +1,81 @@
|
|||||||
|
Name: qt-color-widgets
|
||||||
|
Version: 2.2.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A user-friendly color dialog and several color-related widgets for Qt
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://gitlab.com/mattbas/Qt-Color-Widgets
|
||||||
|
Source: https://gitlab.com/mattbas/Qt-Color-Widgets.git/v%{version}/Qt-Color-Widgets-%{version}.tar.bz2
|
||||||
|
Patch0: qt-color-widgets-2.2.0-cmake-install-libdir.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: cmake
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description
|
||||||
|
A user-friendly color dialog and several color-related widgets for Qt.
|
||||||
|
|
||||||
|
%package -n libQtColorWidgets-Qt5
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Shared libraries for %{name}
|
||||||
|
|
||||||
|
%description -n libQtColorWidgets-Qt5
|
||||||
|
A user-friendly color dialog and several color-related widgets for Qt.
|
||||||
|
This package contains shared libraries for %{name}.
|
||||||
|
|
||||||
|
%package -n libQtColorWidgets-Qt5-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: libQtColorWidgets-Qt5 = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n libQtColorWidgets-Qt5-devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n Qt-Color-Widgets-%{version}
|
||||||
|
%ifarch x86_64 aarch64
|
||||||
|
%patch0 -p1
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake -d build
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -n libQtColorWidgets-Qt5 -p /sbin/ldconfig
|
||||||
|
%postun -n libQtColorWidgets-Qt5 -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files -n libQtColorWidgets-Qt5
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libQtColorWidgets-Qt52.so.*
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%files -n libQtColorWidgets-Qt5-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/QtColorWidgets
|
||||||
|
%{_includedir}/QtColorWidgets/*
|
||||||
|
%dir %{_libdir}/cmake/QtColorWidgets-Qt52
|
||||||
|
%{_libdir}/cmake/QtColorWidgets-Qt52/QtColorWidgets*.cmake
|
||||||
|
%{_libdir}/cmake/QtColorWidgets-Qt52/qtcolorwidgets-qt52-*.cmake
|
||||||
|
%{_libdir}/libQtColorWidgets-Qt52.so
|
||||||
|
%{_libdir}/pkgconfig/QtColorWidgets-Qt52.pc
|
||||||
|
%doc README.md
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Sep 12 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.0-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user