use pulseaudio instead of alsa as default backend [release 0.3.8-2mamba;Thu Dec 04 2014]
This commit is contained in:
parent
7d60907fc0
commit
c0488d74db
12
qsynth-0.3.8-default_pulseaudio.patch
Normal file
12
qsynth-0.3.8-default_pulseaudio.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru qsynth-0.3.6.orig/src/qsynthOptions.cpp qsynth-0.3.6/src/qsynthOptions.cpp
|
||||||
|
--- qsynth-0.3.6.orig/src/qsynthOptions.cpp 2012-06-12 18:48:46.340291361 +0200
|
||||||
|
+++ qsynth-0.3.6/src/qsynthOptions.cpp 2012-06-12 18:51:07.838932135 +0200
|
||||||
|
@@ -485,7 +485,7 @@
|
||||||
|
pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 8).toInt();
|
||||||
|
#else
|
||||||
|
pSetup->sMidiDriver = m_settings.value("/MidiDriver", "alsa_seq").toString();
|
||||||
|
- pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
|
||||||
|
+ pSetup->sAudioDriver = m_settings.value("/AudioDriver", "alsa").toString();
|
||||||
|
pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 64).toInt();
|
||||||
|
pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 2).toInt();
|
||||||
|
#endif
|
18
qsynth.spec
18
qsynth.spec
@ -1,6 +1,6 @@
|
|||||||
Name: qsynth
|
Name: qsynth
|
||||||
Version: 0.3.8
|
Version: 0.3.8
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A fluidsynth GUI front-end application written in C++ around the Qt3 toolkit
|
Summary: A fluidsynth GUI front-end application written in C++ around the Qt3 toolkit
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -11,6 +11,7 @@ Source: http://downloads.sourceforge.net/sourceforge/qsynth/%{name}-%{ver
|
|||||||
Patch0: %{name}-0.2.4-wrongincludes.patch
|
Patch0: %{name}-0.2.4-wrongincludes.patch
|
||||||
Patch1: %{name}-0.3.1-soundfonts.patch
|
Patch1: %{name}-0.3.1-soundfonts.patch
|
||||||
Patch2: %{name}-0.3.6-default_alsa.patch
|
Patch2: %{name}-0.3.6-default_alsa.patch
|
||||||
|
Patch3: qsynth-0.3.8-default_pulseaudio.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -31,7 +32,8 @@ QSynth is a fluidsynth GUI front-end application written in C++ around the Qt3 t
|
|||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
#%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export QTDIR=/usr/lib/qt4
|
export QTDIR=/usr/lib/qt4
|
||||||
@ -43,8 +45,8 @@ export QMAKESPEC=linux-g++
|
|||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
%makeinstall
|
%makeinstall
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications
|
mkdir -p %{buildroot}%{_datadir}/applications
|
||||||
cat > $RPM_BUILD_ROOT/%{_datadir}/applications/qsynth.desktop << EOF
|
cat > %{buildroot}%{_datadir}/applications/qsynth.desktop << EOF
|
||||||
[Desktop Entry]
|
[Desktop Entry]
|
||||||
Name=Qsynth
|
Name=Qsynth
|
||||||
GenericName=Fluidsynth control interface
|
GenericName=Fluidsynth control interface
|
||||||
@ -73,17 +75,21 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc AUTHORS COPYING ChangeLog README README-OSX TODO
|
|
||||||
%{_datadir}/icons/hicolor/32x32/apps/qsynth.png
|
|
||||||
%{_bindir}/qsynth
|
%{_bindir}/qsynth
|
||||||
%{_datadir}/applications/qsynth.desktop
|
%{_datadir}/applications/qsynth.desktop
|
||||||
|
%{_datadir}/icons/hicolor/32x32/apps/qsynth.png
|
||||||
%lang(cs) %{_datadir}/locale/qsynth_cs.qm
|
%lang(cs) %{_datadir}/locale/qsynth_cs.qm
|
||||||
%lang(de) %{_datadir}/locale/qsynth_de.qm
|
%lang(de) %{_datadir}/locale/qsynth_de.qm
|
||||||
%lang(fr) %{_datadir}/locale/qsynth_fr.qm
|
%lang(fr) %{_datadir}/locale/qsynth_fr.qm
|
||||||
%lang(ru) %{_datadir}/locale/qsynth_ru.qm
|
%lang(ru) %{_datadir}/locale/qsynth_ru.qm
|
||||||
%lang(sr) %{_datadir}/locale/qsynth_sr.qm
|
%lang(sr) %{_datadir}/locale/qsynth_sr.qm
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
#ChangeLog README README-OSX TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 04 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.8-2mamba
|
||||||
|
- use pulseaudio instead of alsa as default backend
|
||||||
|
|
||||||
* Fri Jan 03 2014 Automatic Build System <autodist@mambasoft.it> 0.3.8-1mamba
|
* Fri Jan 03 2014 Automatic Build System <autodist@mambasoft.it> 0.3.8-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user