automatic version update by autodist [release 0.3.8-1mamba;Fri Jan 03 2014]
This commit is contained in:
parent
f951f0a0ea
commit
7d60907fc0
@ -1,2 +1,4 @@
|
|||||||
# qsynth
|
# qsynth
|
||||||
|
|
||||||
|
QSynth is a fluidsynth GUI front-end application written in C++ around the Qt3 toolkit using Qt Designer. Eventually it may evolve into a softsynth management application allowing the user to control and manage a variety of command line softsynth but for the moment it wraps the excellent FluidSynth.
|
||||||
|
|
||||||
|
12
qsynth-0.2.4-wrongincludes.patch
Normal file
12
qsynth-0.2.4-wrongincludes.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -ru qsynth-0.2.4.orig/src/qsynthMainForm.ui qsynth-0.2.4/src/qsynthMainForm.ui
|
||||||
|
--- qsynth-0.2.4.orig/src/qsynthMainForm.ui 2005-10-27 00:30:01.000000000 +0200
|
||||||
|
+++ qsynth-0.2.4/src/qsynthMainForm.ui 2005-10-27 00:30:44.000000000 +0200
|
||||||
|
@@ -1796,8 +1796,4 @@
|
||||||
|
</functions>
|
||||||
|
<pixmapinproject/>
|
||||||
|
<layoutdefaults spacing="4" margin="8"/>
|
||||||
|
-<includehints>
|
||||||
|
- <includehint>qsynthmeter.h</includehint>
|
||||||
|
- <includehint>qsynthtabbar.h</includehint>
|
||||||
|
-</includehints>
|
||||||
|
</UI>
|
26
qsynth-0.3.1-soundfonts.patch
Normal file
26
qsynth-0.3.1-soundfonts.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff -Nru qsynth-0.3.1.orig/src/qsynthOptions.cpp qsynth-0.3.1/src/qsynthOptions.cpp
|
||||||
|
--- qsynth-0.3.1.orig/src/qsynthOptions.cpp 2007-07-10 10:00:11.000000000 +0200
|
||||||
|
+++ qsynth-0.3.1/src/qsynthOptions.cpp 2007-09-25 23:55:58.000000000 +0200
|
||||||
|
@@ -55,6 +55,9 @@
|
||||||
|
// Load defaults...
|
||||||
|
m_settings.beginGroup("/Defaults");
|
||||||
|
sSoundFontDir = m_settings.value("/SoundFontDir").toString();
|
||||||
|
+ if (sSoundFontDir == "") {
|
||||||
|
+ sSoundFontDir = "/usr/share/soundfonts";
|
||||||
|
+ }
|
||||||
|
bPresetPreview = m_settings.value("/PresetPreview", false).toBool();
|
||||||
|
m_settings.endGroup();
|
||||||
|
|
||||||
|
@@ -386,7 +389,11 @@
|
||||||
|
return false;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
-
|
||||||
|
+
|
||||||
|
+ if (m_pDefaultSetup->soundfonts.empty() && ::fluid_is_soundfont("/usr/share/soundfonts/default.sf2")) {
|
||||||
|
+ m_pDefaultSetup->soundfonts.append("/usr/share/soundfonts/default.sf2");
|
||||||
|
+ m_pDefaultSetup->bankoffsets.append(QString::null);
|
||||||
|
+ }
|
||||||
|
// Alright with argument parsing.
|
||||||
|
return true;
|
||||||
|
}
|
12
qsynth-0.3.6-default_alsa.patch
Normal file
12
qsynth-0.3.6-default_alsa.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru qsynth-0.3.6.orig/src/qsynthOptions.cpp qsynth-0.3.6/src/qsynthOptions.cpp
|
||||||
|
--- qsynth-0.3.6.orig/src/qsynthOptions.cpp 2012-06-12 18:48:46.340291361 +0200
|
||||||
|
+++ qsynth-0.3.6/src/qsynthOptions.cpp 2012-06-12 18:51:07.838932135 +0200
|
||||||
|
@@ -485,7 +485,7 @@
|
||||||
|
pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 8).toInt();
|
||||||
|
#else
|
||||||
|
pSetup->sMidiDriver = m_settings.value("/MidiDriver", "alsa_seq").toString();
|
||||||
|
- pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
|
||||||
|
+ pSetup->sAudioDriver = m_settings.value("/AudioDriver", "alsa").toString();
|
||||||
|
pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 64).toInt();
|
||||||
|
pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 2).toInt();
|
||||||
|
#endif
|
138
qsynth.spec
Normal file
138
qsynth.spec
Normal file
@ -0,0 +1,138 @@
|
|||||||
|
Name: qsynth
|
||||||
|
Version: 0.3.8
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A fluidsynth GUI front-end application written in C++ around the Qt3 toolkit
|
||||||
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://qsynth.sourceforge.net/qsynth-index.html
|
||||||
|
Source: http://downloads.sourceforge.net/sourceforge/qsynth/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-0.2.4-wrongincludes.patch
|
||||||
|
Patch1: %{name}-0.3.1-soundfonts.patch
|
||||||
|
Patch2: %{name}-0.3.6-default_alsa.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: fluidsynth-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires: fluidsynth >= 1.0.5
|
||||||
|
Requires: soundfont-2rock9
|
||||||
|
|
||||||
|
%description
|
||||||
|
QSynth is a fluidsynth GUI front-end application written in C++ around the Qt3 toolkit using Qt Designer. Eventually it may evolve into a softsynth management application allowing the user to control and manage a variety of command line softsynth but for the moment it wraps the excellent FluidSynth.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
export QTDIR=/usr/lib/qt4
|
||||||
|
export QMAKESPEC=linux-g++
|
||||||
|
%configure
|
||||||
|
%make -j1
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications
|
||||||
|
cat > $RPM_BUILD_ROOT/%{_datadir}/applications/qsynth.desktop << EOF
|
||||||
|
[Desktop Entry]
|
||||||
|
Name=Qsynth
|
||||||
|
GenericName=Fluidsynth control interface
|
||||||
|
GenericName[it]=Interfaccia per fluidsynth
|
||||||
|
Exec=qsynth
|
||||||
|
Type=Application
|
||||||
|
Categories=Qt;KDE;AudioVideo;Music;
|
||||||
|
Terminal=0
|
||||||
|
Icon=qsynth
|
||||||
|
EOF
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%post
|
||||||
|
if [ $1 -ge 1 ]; then
|
||||||
|
[ -x %{_bindir}/gtk-update-icon-cache ] && %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
|
||||||
|
fi
|
||||||
|
:
|
||||||
|
|
||||||
|
%postun
|
||||||
|
if [ $1 -eq 0 ]; then
|
||||||
|
[ -x %{_bindir}/gtk-update-icon-cache ] && %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
|
||||||
|
fi
|
||||||
|
:
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%doc AUTHORS COPYING ChangeLog README README-OSX TODO
|
||||||
|
%{_datadir}/icons/hicolor/32x32/apps/qsynth.png
|
||||||
|
%{_bindir}/qsynth
|
||||||
|
%{_datadir}/applications/qsynth.desktop
|
||||||
|
%lang(cs) %{_datadir}/locale/qsynth_cs.qm
|
||||||
|
%lang(de) %{_datadir}/locale/qsynth_de.qm
|
||||||
|
%lang(fr) %{_datadir}/locale/qsynth_fr.qm
|
||||||
|
%lang(ru) %{_datadir}/locale/qsynth_ru.qm
|
||||||
|
%lang(sr) %{_datadir}/locale/qsynth_sr.qm
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Jan 03 2014 Automatic Build System <autodist@mambasoft.it> 0.3.8-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Apr 19 2013 Automatic Build System <autodist@mambasoft.it> 0.3.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Jun 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.6-2mamba
|
||||||
|
- added patch to use alsa by default
|
||||||
|
|
||||||
|
* Sun Jun 26 2011 Automatic Build System <autodist@mambasoft.it> 0.3.6-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Jun 27 2010 Automatic Build System <autodist@mambasoft.it> 0.3.5-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Dec 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.4-2mamba
|
||||||
|
- fixed default soundfonts patch to prevent duplicate entries
|
||||||
|
|
||||||
|
* Thu May 28 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.4-1mamba
|
||||||
|
- update to 0.3.4
|
||||||
|
|
||||||
|
* Sun Jan 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.3-2mamba
|
||||||
|
- moved menu entry to music category
|
||||||
|
|
||||||
|
* Sat Oct 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Sep 25 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.1-1mamba
|
||||||
|
- update to 0.3.1
|
||||||
|
|
||||||
|
* Tue May 15 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.6-1mamba
|
||||||
|
- update to 0.2.6
|
||||||
|
- desktop menu link moved to %{_datadir}/applications
|
||||||
|
|
||||||
|
* Wed Mar 01 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.4-4qilnx
|
||||||
|
- rpm group fixed
|
||||||
|
|
||||||
|
* Thu Nov 10 2005 Massimo Pintore <massimo.pintore@qilinux.it> 0.2.4-3qilnx
|
||||||
|
- added patch to start with a default soundfont
|
||||||
|
|
||||||
|
* Wed Nov 09 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.4-2qilnx
|
||||||
|
- add default soundfont (2rock9) requirement
|
||||||
|
|
||||||
|
* Thu Oct 27 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.4-1qilnx
|
||||||
|
- update to version 0.2.4 by autospec
|
||||||
|
|
||||||
|
* Mon Feb 21 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.2-2qilnx
|
||||||
|
- added desktop menu icons
|
||||||
|
- added requirement for fluidsynth
|
||||||
|
|
||||||
|
* Sun Feb 20 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.2-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user