automatic version update by autodist [release 0.9.90-1mamba;Mon Apr 15 2024]
This commit is contained in:
parent
fa9bd191d0
commit
4e1eb4f901
@ -1,12 +0,0 @@
|
||||
diff -ru qsynth-0.2.4.orig/src/qsynthMainForm.ui qsynth-0.2.4/src/qsynthMainForm.ui
|
||||
--- qsynth-0.2.4.orig/src/qsynthMainForm.ui 2005-10-27 00:30:01.000000000 +0200
|
||||
+++ qsynth-0.2.4/src/qsynthMainForm.ui 2005-10-27 00:30:44.000000000 +0200
|
||||
@@ -1796,8 +1796,4 @@
|
||||
</functions>
|
||||
<pixmapinproject/>
|
||||
<layoutdefaults spacing="4" margin="8"/>
|
||||
-<includehints>
|
||||
- <includehint>qsynthmeter.h</includehint>
|
||||
- <includehint>qsynthtabbar.h</includehint>
|
||||
-</includehints>
|
||||
</UI>
|
@ -1,26 +0,0 @@
|
||||
diff -Nru qsynth-0.3.1.orig/src/qsynthOptions.cpp qsynth-0.3.1/src/qsynthOptions.cpp
|
||||
--- qsynth-0.3.1.orig/src/qsynthOptions.cpp 2007-07-10 10:00:11.000000000 +0200
|
||||
+++ qsynth-0.3.1/src/qsynthOptions.cpp 2007-09-25 23:55:58.000000000 +0200
|
||||
@@ -55,6 +55,9 @@
|
||||
// Load defaults...
|
||||
m_settings.beginGroup("/Defaults");
|
||||
sSoundFontDir = m_settings.value("/SoundFontDir").toString();
|
||||
+ if (sSoundFontDir == "") {
|
||||
+ sSoundFontDir = "/usr/share/soundfonts";
|
||||
+ }
|
||||
bPresetPreview = m_settings.value("/PresetPreview", false).toBool();
|
||||
m_settings.endGroup();
|
||||
|
||||
@@ -386,7 +389,11 @@
|
||||
return false;
|
||||
}
|
||||
}
|
||||
-
|
||||
+
|
||||
+ if (m_pDefaultSetup->soundfonts.empty() && ::fluid_is_soundfont("/usr/share/soundfonts/default.sf2")) {
|
||||
+ m_pDefaultSetup->soundfonts.append("/usr/share/soundfonts/default.sf2");
|
||||
+ m_pDefaultSetup->bankoffsets.append(QString::null);
|
||||
+ }
|
||||
// Alright with argument parsing.
|
||||
return true;
|
||||
}
|
@ -1,12 +0,0 @@
|
||||
diff -Nru qsynth-0.3.6.orig/src/qsynthOptions.cpp qsynth-0.3.6/src/qsynthOptions.cpp
|
||||
--- qsynth-0.3.6.orig/src/qsynthOptions.cpp 2012-06-12 18:48:46.340291361 +0200
|
||||
+++ qsynth-0.3.6/src/qsynthOptions.cpp 2012-06-12 18:51:07.838932135 +0200
|
||||
@@ -485,7 +485,7 @@
|
||||
pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 8).toInt();
|
||||
#else
|
||||
pSetup->sMidiDriver = m_settings.value("/MidiDriver", "alsa_seq").toString();
|
||||
- pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
|
||||
+ pSetup->sAudioDriver = m_settings.value("/AudioDriver", "alsa").toString();
|
||||
pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 64).toInt();
|
||||
pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 2).toInt();
|
||||
#endif
|
@ -1,27 +0,0 @@
|
||||
From 30cfd10cd23ca204f694ac2defb7a94f999c6e38 Mon Sep 17 00:00:00 2001
|
||||
From: rncbc <rncbc@gamma.rncbc.lan>
|
||||
Date: Mon, 30 May 2016 11:38:37 +0100
|
||||
Subject: [PATCH] =?UTF-8?q?-=20Removed=20manual=20setting=20of=20system=20?=
|
||||
=?UTF-8?q?include=20paths=20(a=20configure=20=20=20patch=20by=20Romain=20?=
|
||||
=?UTF-8?q?L=C3=A9tendart=20on=20qsampler,=20thanks).?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 73e8aac..218b1ed 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -61,7 +61,7 @@ AC_ARG_ENABLE(stacktrace,
|
||||
|
||||
|
||||
# Standard installation base dirs.
|
||||
-ac_with_paths="/usr /usr/local"
|
||||
+ac_with_paths=""
|
||||
|
||||
# Set for alternate Qt4/5 installation dir.
|
||||
AC_ARG_WITH(qt4,
|
26
qsynth.spec
26
qsynth.spec
@ -1,5 +1,5 @@
|
||||
Name: qsynth
|
||||
Version: 0.9.13
|
||||
Version: 0.9.90
|
||||
Release: 1mamba
|
||||
Summary: A fluidsynth GUI front-end application written in C++ around the Qt3 toolkit
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
@ -8,11 +8,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://qsynth.sourceforge.io/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/qsynth/%{name}-%{version}.tar.gz
|
||||
Patch0: %{name}-0.2.4-wrongincludes.patch
|
||||
Patch1: %{name}-0.3.1-soundfonts.patch
|
||||
Patch2: %{name}-0.3.6-default_alsa.patch
|
||||
Patch3: qsynth-0.9.6-default_alsa.patch
|
||||
Patch4: qsynth-0.4.1-gcc-6.1.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -34,7 +30,6 @@ QSynth is a fluidsynth GUI front-end application written in C++ around the Qt3 t
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch1 -p1
|
||||
%patch 3 -p1
|
||||
|
||||
%build
|
||||
@ -46,19 +41,6 @@ QSynth is a fluidsynth GUI front-end application written in C++ around the Qt3 t
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall -C build
|
||||
|
||||
#mkdir -p %{buildroot}%{_datadir}/applications
|
||||
#cat > %{buildroot}%{_datadir}/applications/qsynth.desktop << EOF
|
||||
#[Desktop Entry]
|
||||
#Name=Qsynth
|
||||
#GenericName=Fluidsynth control interface
|
||||
#GenericName[it]=Interfaccia per fluidsynth
|
||||
#Exec=qsynth
|
||||
#Type=Application
|
||||
#Categories=Qt;KDE;AudioVideo;Music;
|
||||
#Terminal=0
|
||||
#Icon=qsynth
|
||||
#EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
@ -87,6 +69,9 @@ fi
|
||||
%lang(fr) %{_datadir}/qsynth/translations/qsynth_fr.qm
|
||||
%lang(ru) %{_datadir}/qsynth/translations/qsynth_ru.qm
|
||||
%lang(sr) %{_datadir}/qsynth/translations/qsynth_sr.qm
|
||||
%dir %{_datadir}/qsynth/palette
|
||||
%{_datadir}/qsynth/palette/KXStudio.conf
|
||||
%{_datadir}/qsynth/palette/Wonton*Soup.conf
|
||||
%{_mandir}/man1/qsynth.1*
|
||||
%lang(fr) %{_mandir}/fr/man1/qsynth.1*
|
||||
%{_datadir}/icons/hicolor/32x32/apps/org.rncbc.qsynth.png
|
||||
@ -94,6 +79,9 @@ fi
|
||||
%doc LICENSE
|
||||
|
||||
%changelog
|
||||
* Mon Apr 15 2024 Automatic Build System <autodist@openmamba.org> 0.9.90-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jan 23 2024 Automatic Build System <autodist@openmamba.org> 0.9.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user