automatic version update by autodist [release 0.9.6-1mamba;Sun Mar 13 2022]
This commit is contained in:
parent
5eadf40f7d
commit
45d3c4bb17
@ -1,3 +1,4 @@
|
||||
# qsynth
|
||||
|
||||
QSynth is a fluidsynth GUI front-end application written in C++ around the Qt3 toolkit using Qt Designer. Eventually it may evolve into a softsynth management application allowing the user to control and manage a variety of command line softsynth but for the moment it wraps the excellent FluidSynth.
|
||||
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- qsynth-0.5.7/src/qsynthOptions.cpp.orig 2019-08-18 13:37:43.405000000 +0200
|
||||
+++ qsynth-0.5.7/src/qsynthOptions.cpp 2019-08-18 13:38:05.245000000 +0200
|
||||
@@ -496,7 +496,7 @@
|
||||
pSetup->sAudioDriver = m_settings.value("/AudioDriver", "dsound").toString();
|
||||
--- qsynth-0.9.6/src/qsynthOptions.cpp.orig 2022-02-19 11:39:24.421881551 +0100
|
||||
+++ qsynth-0.9.6/src/qsynthOptions.cpp 2022-02-19 11:39:32.921833027 +0100
|
||||
@@ -765,7 +765,7 @@
|
||||
pSetup->sAudioDriver = m_settings.value("/AudioDriver", "sndio").toString();
|
||||
#else
|
||||
pSetup->sMidiDriver = m_settings.value("/MidiDriver", "alsa_seq").toString();
|
||||
- pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
|
||||
+ pSetup->sAudioDriver = m_settings.value("/AudioDriver", "alsa").toString();
|
||||
#endif
|
||||
#if defined(__WIN32__) || defined(_WIN32) || defined(WIN32)
|
||||
#if defined(Q_OS_WINDOWS)
|
||||
pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 512).toInt();
|
59
qsynth.spec
59
qsynth.spec
@ -1,5 +1,5 @@
|
||||
Name: qsynth
|
||||
Version: 0.9.4
|
||||
Version: 0.9.6
|
||||
Release: 1mamba
|
||||
Summary: A fluidsynth GUI front-end application written in C++ around the Qt3 toolkit
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
@ -11,7 +11,7 @@ Source: http://downloads.sourceforge.net/sourceforge/qsynth/%{name}-%{ver
|
||||
Patch0: %{name}-0.2.4-wrongincludes.patch
|
||||
Patch1: %{name}-0.3.1-soundfonts.patch
|
||||
Patch2: %{name}-0.3.6-default_alsa.patch
|
||||
Patch3: qsynth-0.5.7-default_pulseaudio.patch
|
||||
Patch3: qsynth-0.9.6-default_alsa.patch
|
||||
Patch4: qsynth-0.4.1-gcc-6.1.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
@ -19,8 +19,8 @@ BuildRequires: glibc-devel
|
||||
BuildRequires: libfluidsynth-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: qt6-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: fluidsynth >= 1.0.5
|
||||
Requires: soundfont-2rock9
|
||||
@ -28,39 +28,34 @@ Requires: soundfont-2rock9
|
||||
%description
|
||||
QSynth is a fluidsynth GUI front-end application written in C++ around the Qt3 toolkit using Qt Designer. Eventually it may evolve into a softsynth management application allowing the user to control and manage a variety of command line softsynth but for the moment it wraps the excellent FluidSynth.
|
||||
|
||||
#% debug_package
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch1 -p1
|
||||
%patch3 -p1
|
||||
#%patch4 -p1
|
||||
./autogen.sh
|
||||
|
||||
%build
|
||||
export QMAKESPEC=linux-g++
|
||||
%configure
|
||||
%cmake -d build
|
||||
|
||||
%make -j1
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
%makeinstall -C build
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
cat > %{buildroot}%{_datadir}/applications/qsynth.desktop << EOF
|
||||
[Desktop Entry]
|
||||
Name=Qsynth
|
||||
GenericName=Fluidsynth control interface
|
||||
GenericName[it]=Interfaccia per fluidsynth
|
||||
Exec=qsynth
|
||||
Type=Application
|
||||
Categories=Qt;KDE;AudioVideo;Music;
|
||||
Terminal=0
|
||||
Icon=qsynth
|
||||
EOF
|
||||
#mkdir -p %{buildroot}%{_datadir}/applications
|
||||
#cat > %{buildroot}%{_datadir}/applications/qsynth.desktop << EOF
|
||||
#[Desktop Entry]
|
||||
#Name=Qsynth
|
||||
#GenericName=Fluidsynth control interface
|
||||
#GenericName[it]=Interfaccia per fluidsynth
|
||||
#Exec=qsynth
|
||||
#Type=Application
|
||||
#Categories=Qt;KDE;AudioVideo;Music;
|
||||
#Terminal=0
|
||||
#Icon=qsynth
|
||||
#EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
@ -80,10 +75,8 @@ fi
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/qsynth
|
||||
%{_datadir}/applications/qsynth.desktop
|
||||
%{_datadir}/icons/hicolor/32x32/apps/qsynth.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/qsynth.svg
|
||||
%{_datadir}/metainfo/qsynth.appdata.xml
|
||||
%{_datadir}/applications/org.rncbc.qsynth.desktop
|
||||
%{_datadir}/metainfo/org.rncbc.qsynth.metainfo.xml
|
||||
%dir %{_datadir}/qsynth
|
||||
%dir %{_datadir}/qsynth/translations
|
||||
%lang(cs) %{_datadir}/qsynth/translations/qsynth_cs.qm
|
||||
@ -94,10 +87,14 @@ fi
|
||||
%lang(sr) %{_datadir}/qsynth/translations/qsynth_sr.qm
|
||||
%{_mandir}/man1/qsynth.1*
|
||||
%lang(fr) %{_mandir}/fr/man1/qsynth.1*
|
||||
%doc AUTHORS COPYING
|
||||
#ChangeLog README README-OSX TODO
|
||||
%{_datadir}/icons/hicolor/32x32/apps/qsynth.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/qsynth.svg
|
||||
%doc LICENSE
|
||||
|
||||
%changelog
|
||||
* Sun Mar 13 2022 Automatic Build System <autodist@mambasoft.it> 0.9.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jul 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.4-1mamba
|
||||
- update to 0.9.4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user