update to 2.12.0 [release 2.12.0-1mamba;Sat Feb 27 2021]
This commit is contained in:
parent
6c004168e8
commit
f5dc9bcfbb
@ -1,41 +0,0 @@
|
||||
02_configure.dpatch by Torsten Marek <shlomme@debian.org>
|
||||
Updated for Qscintilla 2.8.2 configure.py changes by Scott Kitterman
|
||||
<scott@kitterman.com>
|
||||
patch the configure script for the Python bindings to support object dir
|
||||
builds
|
||||
Index: qscintilla2-2.8.3+dfsg/Python/configure.py
|
||||
===================================================================
|
||||
--- qscintilla2-2.8.3+dfsg.orig/Python/configure.py 2014-07-05 10:02:02.318834374 -0400
|
||||
+++ qscintilla2-2.8.3+dfsg/Python/configure.py 2014-07-05 10:02:02.306834375 -0400
|
||||
@@ -31,6 +31,8 @@
|
||||
import glob
|
||||
import optparse
|
||||
|
||||
+src_dir = os.path.dirname(os.path.abspath(__file__))
|
||||
+
|
||||
try:
|
||||
import sysconfig
|
||||
except ImportError:
|
||||
@@ -210,6 +212,8 @@
|
||||
"The QScintilla version number could not be determined by "
|
||||
"reading %s." % sciglobal)
|
||||
|
||||
+ return # Debian: do not check for the installed version, we're good this way.
|
||||
+
|
||||
lib_dir = target_configuration.qsci_lib_dir
|
||||
if lib_dir is None:
|
||||
lib_dir = target_configuration.qt_lib_dir
|
||||
@@ -264,7 +268,12 @@
|
||||
the target configuration.
|
||||
"""
|
||||
|
||||
- return 'sip/qscimod5.sip' if target_configuration.pyqt_package == 'PyQt5' else 'sip/qscimod4.sip'
|
||||
+ if target_configuration.pyqt_package == 'PyQt5':
|
||||
+ return os.path.join(src_dir, 'sip/qscimod5.sip')
|
||||
+ else:
|
||||
+ return os.path.join(src_dir, 'sip/qscimod4.sip')
|
||||
+
|
||||
+ #return 'sip/qscimod5.sip' if target_configuration.pyqt_package == 'PyQt5' else 'sip/qscimod4.sip'
|
||||
|
||||
def get_sip_installs(self, target_configuration):
|
||||
""" Return a tuple of the installation directory of the module's .sip
|
@ -1,16 +0,0 @@
|
||||
Index: qscintilla2-2.8.3+dfsg/Python/configure.py
|
||||
===================================================================
|
||||
--- qscintilla2-2.8.3+dfsg.orig/Python/configure.py 2014-07-05 10:05:48.614827688 -0400
|
||||
+++ qscintilla2-2.8.3+dfsg/Python/configure.py 2014-07-05 10:05:48.610827688 -0400
|
||||
@@ -1434,7 +1434,10 @@
|
||||
|
||||
libs = qmake_config.get('LIBS')
|
||||
if libs:
|
||||
- pro.write('LIBS += %s\n' % libs)
|
||||
+ if target_config.pyqt_package == 'PyQt5':
|
||||
+ pro.write('LIBS += %s -lqt5scintilla2\n' % libs)
|
||||
+ else:
|
||||
+ pro.write('LIBS += %s -lqscintilla2\n' % libs)
|
||||
|
||||
if not opts.static:
|
||||
pro.write('''
|
134
qscintilla.spec
134
qscintilla.spec
@ -1,43 +1,26 @@
|
||||
%define pythonsip_ver %(sip5 -V)
|
||||
Name: qscintilla
|
||||
Version: 2.11.4
|
||||
Release: 4mamba
|
||||
Version: 2.12.0
|
||||
Release: 1mamba
|
||||
Summary: A port to Qt of Neil Hodgson's Scintilla C++ editor control
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.riverbankcomputing.co.uk/software/qscintilla
|
||||
Source: https://www.riverbankcomputing.com/static/Downloads/QScintilla/%{version}/QScintilla-%{version}.tar.gz
|
||||
#Source: https://sourceforge.net/projects/pyqt/files/QScintilla2/QScintilla-%{version}/QScintilla_gpl-%{version}.tar.gz
|
||||
URL: https://www.riverbankcomputing.co.uk/software/qscintilla
|
||||
Source: https://www.riverbankcomputing.com/static/Downloads/QScintilla/%{version}/QScintilla_src-%{version}.tar.gz
|
||||
Patch0: qscintilla-2.7.2-prepend-local-includes.patch
|
||||
Patch1: qscintilla-2.10.8-designer-prepend-local-includes.patch
|
||||
Patch2: qscintilla-2.8.4-python-build-from-objdir.patch
|
||||
Patch3: qscintilla-2.8.4-python-qsci-link.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
#BuildRequires: qt-designer
|
||||
# following build requirements are for Python bindings
|
||||
# WARNING: do not parametrize python-sip-devel version or it will be useless for ports
|
||||
BuildRequires: python-sip-py3 >= 5.1.2
|
||||
BuildRequires: python-sip-py36 >= 5.1.2
|
||||
BuildRequires: PyQt4-devel
|
||||
BuildRequires: PyQt5-devel
|
||||
#BuildRequires: chrpath
|
||||
%if "%?with_pyver"
|
||||
#BuildRequires: PyQt4-py%{with_pyver}
|
||||
BuildRequires: PyQt5-py%{with_pyver}
|
||||
%endif
|
||||
Provides: QScintilla2
|
||||
Obsoletes: QScintilla2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: QScintilla2 < 2.21.0
|
||||
|
||||
%description
|
||||
QScintilla is a port to Qt of the Scintilla editing component.
|
||||
@ -52,18 +35,6 @@ Scintilla includes features especially useful when editing and debugging source
|
||||
* recordable macros
|
||||
* multiple views printing.
|
||||
|
||||
%if "%?with_pyver"
|
||||
%define pyver %{with_pyver}
|
||||
%define __python %(rpm --eval %{__python%{with_pyver}})
|
||||
%define python_sitearch %(rpm --eval %{python%{with_pyver}_sitearch})
|
||||
%define python_sitelib %(rpm --eval %{python%{with_pyver}_sitelib})
|
||||
%define python_inc %(rpm --eval %{python%{with_pyver}_inc})
|
||||
%define python_version %(rpm --eval %{python%{with_pyver}_version})
|
||||
%define python_provides %(rpm --eval %{python%{with_pyver}_provides})
|
||||
%define python_requires %(rpm --eval %{python%{with_pyver}_requires})
|
||||
%define py_requires %(rpm --eval %{py%{with_pyver}_requires})
|
||||
%endif
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Libraries and headers for %{name}
|
||||
@ -84,96 +55,34 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
QScintilla is a port to Qt of the Scintilla editing component.
|
||||
This package contains QScintilla designer plugin.
|
||||
|
||||
%package -n python-%{name}%{?with_pyver:-py%{pyver}}
|
||||
Summary: QScintilla PyQt4 bindings
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: python-sip%{?with_pyver:-py%{pyver}} >= %{pythonsip_ver}
|
||||
%if "%?with_pyver" == "3"
|
||||
Provides: python-QScintilla2
|
||||
Obsoletes: python-QScintilla2
|
||||
Provides: python-qscintilla
|
||||
Obsoletes: python-qscintilla
|
||||
%endif
|
||||
|
||||
%description -n python-%{name}%{?with_pyver:-py%{pyver}}
|
||||
QScintilla is a port to Qt of the Scintilla editing component.
|
||||
This package contains QScintilla PyQt4 bindings.
|
||||
|
||||
%package -n python-%{name}-devel
|
||||
Summary: Development files for QScintilla PyQt4 bindings
|
||||
Group: Development/Libraries
|
||||
Requires: python-%{name}-py3 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: python-QScintilla2-devel
|
||||
Obsoletes: python-QScintilla2-devel
|
||||
|
||||
%description -n python-%{name}-devel
|
||||
QScintilla is a port to Qt of the Scintilla editing component.
|
||||
|
||||
This package contains development files for QScintilla PyQt4 bindings.
|
||||
|
||||
#% debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n QScintilla-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
|
||||
sed -i "s/^DESTDIR = \$(QTDIR)/DESTDIR = \$(INSTALL_ROOT)\$(QTDIR)/" */*.pro
|
||||
|
||||
# fix permissions on doc files
|
||||
find doc example-Qt4Qt5 -type f -exec chmod 0644 {} ';'
|
||||
find src include -type f -exec chmod 0644 {} ';'
|
||||
%setup -q -n QScintilla_src-%{version}
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
|
||||
cd Qt4Qt5
|
||||
#sed -i 's/INSTALLS += header trans qsci/INSTALLS += header trans qsci target/g' qscintilla.pro
|
||||
cd src
|
||||
%{_qt5_qmake} qscintilla.pro
|
||||
%make
|
||||
cd ..
|
||||
|
||||
cd designer-Qt4Qt5
|
||||
%{_qt5_qmake} QMAKE_LIBDIR=../Qt4Qt5 designer.pro
|
||||
cd designer
|
||||
%{_qt5_qmake} designer.pro
|
||||
%make
|
||||
cd ..
|
||||
|
||||
cd Python
|
||||
%{__python} configure.py \
|
||||
-c \
|
||||
-d %{python_sitearch}/PyQt5 \
|
||||
--qsci-incdir=../Qt4Qt5 \
|
||||
--qsci-libdir=../Qt4Qt5 \
|
||||
--qmake /usr/bin/qmake-qt5 \
|
||||
--pyqt=PyQt5
|
||||
|
||||
|
||||
%make CXX="c++ -I/usr/include/qt5/QtWidgets -I/usr/include/qt5/QtPrintSupport"
|
||||
cd ..
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%makeinstall -C Qt4Qt5 \
|
||||
%makeinstall -C src \
|
||||
INSTALL_ROOT=%{buildroot}
|
||||
|
||||
%makeinstall -C designer-Qt4Qt5 \
|
||||
%makeinstall -C designer \
|
||||
INSTALL_ROOT=%{buildroot}
|
||||
|
||||
%makeinstall -C Python INSTALL_ROOT=%{buildroot}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
:
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -189,25 +98,16 @@ cd ..
|
||||
%{_libdir}/libqscintilla2_qt5.so
|
||||
%{_libdir}/qt5/mkspecs/features/qscintilla2.prf
|
||||
%doc NEWS
|
||||
%doc doc/html-Qt4Qt5 doc/Scintilla example-Qt4Qt5
|
||||
%doc doc/html doc/Scintilla example
|
||||
|
||||
%files designer
|
||||
%defattr(-,root,root)
|
||||
%{_qt5_prefix}/plugins/designer/libqscintillaplugin.so
|
||||
|
||||
%files -n python-%{name}%{?with_pyver:-py%{pyver}}
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/PyQt5/Qsci.so
|
||||
%{python_sitearch}/PyQt5/Qsci.pyi
|
||||
%dir %{python_sitearch}/QScintilla-%{version}.dist-info
|
||||
%{python_sitearch}/QScintilla-%{version}.dist-info/*
|
||||
|
||||
%files -n python-%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_datadir}/sip/PyQt5/Qsci
|
||||
%{_datadir}/sip/PyQt5/Qsci/*.sip
|
||||
|
||||
%changelog
|
||||
* Sat Feb 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.0-1mamba
|
||||
- update to 2.12.0
|
||||
|
||||
* Mon Apr 13 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.11.4-4mamba
|
||||
- python-qscintilla-py3: obsolete python-qscintilla
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user