automatic version update by autodist [release 0.9.90-1mamba;Mon Apr 15 2024]
This commit is contained in:
parent
fb8b4b9daa
commit
f9900efa98
@ -1,16 +0,0 @@
|
|||||||
diff -Nru qjackctl-0.3.6.orig//qjackctl.desktop.in qjackctl-0.3.6/qjackctl.desktop.in
|
|
||||||
--- qjackctl-0.3.6.orig//qjackctl.desktop.in 2009-09-25 20:35:05.000000000 +0200
|
|
||||||
+++ qjackctl-0.3.6/qjackctl.desktop.in 2010-05-08 21:20:53.995216193 +0200
|
|
||||||
@@ -3,10 +3,12 @@
|
|
||||||
GenericName=JACK Control
|
|
||||||
GenericName[de]=JACK-Steuerung
|
|
||||||
GenericName[fr]=Contrôle JACK
|
|
||||||
+GenericName[it]=Controllo di JACK
|
|
||||||
GenericName[ru]=Управление JACK
|
|
||||||
Comment=QjackCtl is a JACK Audio Connection Kit Qt GUI Interface
|
|
||||||
Comment[de]=Grafisches Werkzeug zur Steuerung des JACK-Audio-Systems
|
|
||||||
Comment[fr]=QjackCtl est une interface graphique Qt pour le kit de connexion audio JACK
|
|
||||||
+Comment[it]=Interfaccia di controllo per il kit di connessione audio JACK
|
|
||||||
Comment[ru]=Программа для управления звуковым сервером JACK
|
|
||||||
Exec=@ac_prefix@/bin/qjackctl
|
|
||||||
Icon=@ac_prefix@/share/pixmaps/qjackctl.png
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru qjackctl-0.3.7.orig//src/qjackctlSetup.cpp qjackctl-0.3.7/src/qjackctlSetup.cpp
|
|
||||||
--- qjackctl-0.3.7.orig//src/qjackctlSetup.cpp 2010-09-25 23:53:44.000000000 +0200
|
|
||||||
+++ qjackctl-0.3.7/src/qjackctlSetup.cpp 2011-03-07 01:40:32.664490708 +0100
|
|
||||||
@@ -107,7 +107,7 @@
|
|
||||||
bServerConfigTemp = m_settings.value("/ServerConfigTemp", false).toBool();
|
|
||||||
bQueryShutdown = m_settings.value("/QueryShutdown", true).toBool();
|
|
||||||
bAlsaSeqEnabled = m_settings.value("/AlsaSeqEnabled", true).toBool();
|
|
||||||
- bDBusEnabled = m_settings.value("/DBusEnabled", false).toBool();
|
|
||||||
+ bDBusEnabled = m_settings.value("/DBusEnabled", true).toBool();
|
|
||||||
bAliasesEnabled = m_settings.value("/AliasesEnabled", false).toBool();
|
|
||||||
bAliasesEditing = m_settings.value("/AliasesEditing", false).toBool();
|
|
||||||
bLeftButtons = m_settings.value("/LeftButtons", true).toBool();
|
|
@ -1,23 +0,0 @@
|
|||||||
diff -Nru qjackctl-0.3.9.orig/src/qjackctlMainForm.cpp qjackctl-0.3.9/src/qjackctlMainForm.cpp
|
|
||||||
--- qjackctl-0.3.9.orig/src/qjackctlMainForm.cpp 2012-05-14 23:33:11.000000000 +0200
|
|
||||||
+++ qjackctl-0.3.9/src/qjackctlMainForm.cpp 2012-08-07 15:41:20.403517472 +0200
|
|
||||||
@@ -1326,19 +1326,6 @@
|
|
||||||
m_pJack->terminate();
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
- #ifdef CONFIG_DBUS
|
|
||||||
- // Jack D-BUS server backend...
|
|
||||||
- if (m_pDBusControl) {
|
|
||||||
- QDBusMessage dbusm = m_pDBusControl->call("StopServer");
|
|
||||||
- if (dbusm.type() == QDBusMessage::ReplyMessage) {
|
|
||||||
- appendMessages(
|
|
||||||
- tr("D-BUS: JACK server is stopping..."));
|
|
||||||
- } else {
|
|
||||||
- appendMessagesError(
|
|
||||||
- tr("D-BUS: JACK server could not be stopped.\n\nSorry"));
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- #endif
|
|
||||||
// Give it some time to terminate gracefully and stabilize...
|
|
||||||
stabilize(QJACKCTL_TIMER_MSECS);
|
|
||||||
// Keep on, if not exiting for good.
|
|
@ -1,27 +0,0 @@
|
|||||||
From a0c779285db433ab4e72670004111f306472e866 Mon Sep 17 00:00:00 2001
|
|
||||||
From: rncbc <rncbc@gamma.rncbc.lan>
|
|
||||||
Date: Mon, 30 May 2016 11:37:00 +0100
|
|
||||||
Subject: [PATCH] =?UTF-8?q?-=20Removed=20manual=20setting=20of=20system=20?=
|
|
||||||
=?UTF-8?q?include=20paths=20(a=20configure=20=20=20patch=20by=20Romain=20?=
|
|
||||||
=?UTF-8?q?L=C3=A9tendart=20on=20qsampler,=20thanks).?=
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
---
|
|
||||||
configure.ac | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 86f55f4..93f8c32 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -109,7 +109,7 @@ AC_ARG_ENABLE(stacktrace,
|
|
||||||
|
|
||||||
|
|
||||||
# Standard installation base dirs.
|
|
||||||
-ac_with_paths="/usr /usr/local"
|
|
||||||
+ac_with_paths=""
|
|
||||||
|
|
||||||
# Set for alternate Qt4/5 installation dir.
|
|
||||||
AC_ARG_WITH(qt4,
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru qjackctl-0.4.4.orig/src/qjackctlSetup.cpp qjackctl-0.4.4/src/qjackctlSetup.cpp
|
|
||||||
--- qjackctl-0.4.4.orig/src/qjackctlSetup.cpp 2017-08-14 18:23:02.535595994 +0200
|
|
||||||
+++ qjackctl-0.4.4/src/qjackctlSetup.cpp 2017-08-14 18:24:53.816055016 +0200
|
|
||||||
@@ -46,7 +46,7 @@
|
|
||||||
: m_settings(QJACKCTL_DOMAIN, QJACKCTL_TITLE)
|
|
||||||
{
|
|
||||||
bStartJackCmd = false;
|
|
||||||
- sDefPresetName = QObject::tr("(default)");
|
|
||||||
+ sDefPresetName = "(default)";
|
|
||||||
|
|
||||||
loadSetup();
|
|
||||||
}
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: qjackctl
|
Name: qjackctl
|
||||||
Version: 0.9.13
|
Version: 0.9.90
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A simple Qt application to control the JACK sound server daemon
|
Summary: A simple Qt application to control the JACK sound server daemon
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
@ -10,11 +10,6 @@ URL: https://qjackctl.sourceforge.io/
|
|||||||
Source: http://downloads.sourceforge.net/sourceforge/qjackctl/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/sourceforge/qjackctl/%{name}-%{version}.tar.gz
|
||||||
Source1: qjackctl-loop2jack
|
Source1: qjackctl-loop2jack
|
||||||
Patch1: qjackctl-0.3.10-loop2jack_postStartup_enable.patch
|
Patch1: qjackctl-0.3.10-loop2jack_postStartup_enable.patch
|
||||||
Patch2: qjackctl-0.3.6-desktop.patch
|
|
||||||
Patch3: qjackctl-0.3.7-jackdbus_enable_by_default.patch
|
|
||||||
Patch4: qjackctl-0.3.9-jackdbus_dont_stop_on_exit.patch
|
|
||||||
Patch5: qjackctl-0.4.2-gcc-6.1.0.patch
|
|
||||||
Patch6: qjackctl-0.4.4-preset-no-translate.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -40,7 +35,6 @@ A simple Qt application to control the JACK sound server daemon
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch 1 -p1
|
%patch 1 -p1
|
||||||
#%patch6 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
%cmake -d build
|
||||||
@ -53,11 +47,6 @@ A simple Qt application to control the JACK sound server daemon
|
|||||||
|
|
||||||
install -D -m0755 %{SOURCE1} %{buildroot}%{_bindir}/loop2jack
|
install -D -m0755 %{SOURCE1} %{buildroot}%{_bindir}/loop2jack
|
||||||
|
|
||||||
#install -d -m0755 %{buildroot}%{_sysconfdir}/modules-load.d
|
|
||||||
#cat > %{buildroot}%{_sysconfdir}/modules-load.d/snd-aloop.conf << _EOF
|
|
||||||
#snd-aloop
|
|
||||||
#_EOF
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
@ -67,6 +56,9 @@ install -D -m0755 %{SOURCE1} %{buildroot}%{_bindir}/loop2jack
|
|||||||
%{_bindir}/loop2jack
|
%{_bindir}/loop2jack
|
||||||
%dir %{_datadir}/qjackctl/translations
|
%dir %{_datadir}/qjackctl/translations
|
||||||
%{_datadir}/qjackctl/translations/qjackctl_*.qm
|
%{_datadir}/qjackctl/translations/qjackctl_*.qm
|
||||||
|
%dir %{_datadir}/qjackctl/palette
|
||||||
|
%{_datadir}/qjackctl/palette/KXStudio.conf
|
||||||
|
%{_datadir}/qjackctl/palette/Wonton*Soup.conf
|
||||||
%{_datadir}/applications/org.rncbc.qjackctl.desktop
|
%{_datadir}/applications/org.rncbc.qjackctl.desktop
|
||||||
%{_datadir}/metainfo/org.rncbc.qjackctl.metainfo.xml
|
%{_datadir}/metainfo/org.rncbc.qjackctl.metainfo.xml
|
||||||
%{_datadir}/icons/hicolor/*x*/apps/*.png
|
%{_datadir}/icons/hicolor/*x*/apps/*.png
|
||||||
@ -76,6 +68,9 @@ install -D -m0755 %{SOURCE1} %{buildroot}%{_bindir}/loop2jack
|
|||||||
%doc LICENSE
|
%doc LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 15 2024 Automatic Build System <autodist@openmamba.org> 0.9.90-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Jan 23 2024 Automatic Build System <autodist@openmamba.org> 0.9.13-1mamba
|
* Tue Jan 23 2024 Automatic Build System <autodist@openmamba.org> 0.9.13-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user