automatic version update by autodist [release 0.3.11-1mamba;Thu Jan 02 2014]
This commit is contained in:
parent
93f40054e4
commit
7f85e32dd0
@ -1,2 +1,4 @@
|
||||
# qjackctl
|
||||
|
||||
A simple Qt application to control the JACK sound server daemon
|
||||
|
||||
|
23
qjackctl-0.2.18-wrongincludes.patch
Normal file
23
qjackctl-0.2.18-wrongincludes.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -ru qjackctl-0.2.18/src/qjackctlConnectionsForm.ui qjackctl-0.2.18.patched/src/qjackctlConnectionsForm.ui
|
||||
--- qjackctl-0.2.18/src/qjackctlConnectionsForm.ui 2005-01-27 17:11:46.000000000 +0100
|
||||
+++ qjackctl-0.2.18.patched/src/qjackctlConnectionsForm.ui 2005-10-27 00:01:29.000000000 +0200
|
||||
@@ -446,8 +446,4 @@
|
||||
</functions>
|
||||
<pixmapinproject/>
|
||||
<layoutdefaults spacing="4" margin="4"/>
|
||||
-<includehints>
|
||||
- <includehint>qjackctlconnectview.h</includehint>
|
||||
- <includehint>qjackctlconnectview.h</includehint>
|
||||
-</includehints>
|
||||
</UI>
|
||||
diff -ru qjackctl-0.2.18/src/qjackctlPatchbayForm.ui qjackctl-0.2.18.patched/src/qjackctlPatchbayForm.ui
|
||||
--- qjackctl-0.2.18/src/qjackctlPatchbayForm.ui 2005-05-04 13:30:52.000000000 +0200
|
||||
+++ qjackctl-0.2.18.patched/src/qjackctlPatchbayForm.ui 2005-10-27 00:01:14.000000000 +0200
|
||||
@@ -941,7 +941,4 @@
|
||||
</functions>
|
||||
<pixmapinproject/>
|
||||
<layoutdefaults spacing="4" margin="4"/>
|
||||
-<includehints>
|
||||
- <includehint>qjackctlpatchbayview.h</includehint>
|
||||
-</includehints>
|
||||
</UI>
|
14
qjackctl-0.3.10-loop2jack_postStartup_enable.patch
Normal file
14
qjackctl-0.3.10-loop2jack_postStartup_enable.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -Nru qjackctl-0.3.10.orig/src/qjackctlSetup.cpp qjackctl-0.3.10/src/qjackctlSetup.cpp
|
||||
--- qjackctl-0.3.10.orig/src/qjackctlSetup.cpp 2013-07-24 19:32:50.098127983 +0200
|
||||
+++ qjackctl-0.3.10/src/qjackctlSetup.cpp 2013-07-24 19:34:48.700028791 +0200
|
||||
@@ -77,8 +77,8 @@
|
||||
bStopJack = m_settings.value("/StopJack", true).toBool();
|
||||
bStartupScript = m_settings.value("/StartupScript", false).toBool();
|
||||
sStartupScriptShell = m_settings.value("/StartupScriptShell").toString();
|
||||
- bPostStartupScript = m_settings.value("/PostStartupScript", false).toBool();
|
||||
- sPostStartupScriptShell = m_settings.value("/PostStartupScriptShell").toString();
|
||||
+ bPostStartupScript = m_settings.value("/PostStartupScript", true).toBool();
|
||||
+ sPostStartupScriptShell = m_settings.value("/PostStartupScriptShell", "loop2jack").toString();
|
||||
bShutdownScript = m_settings.value("/ShutdownScript", false).toBool();
|
||||
sShutdownScriptShell = m_settings.value("/ShutdownScriptShell").toString();
|
||||
bPostShutdownScript = m_settings.value("/PostShutdownScript", false).toBool();
|
16
qjackctl-0.3.6-desktop.patch
Normal file
16
qjackctl-0.3.6-desktop.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -Nru qjackctl-0.3.6.orig//qjackctl.desktop.in qjackctl-0.3.6/qjackctl.desktop.in
|
||||
--- qjackctl-0.3.6.orig//qjackctl.desktop.in 2009-09-25 20:35:05.000000000 +0200
|
||||
+++ qjackctl-0.3.6/qjackctl.desktop.in 2010-05-08 21:20:53.995216193 +0200
|
||||
@@ -3,10 +3,12 @@
|
||||
GenericName=JACK Control
|
||||
GenericName[de]=JACK-Steuerung
|
||||
GenericName[fr]=Contrôle JACK
|
||||
+GenericName[it]=Controllo di JACK
|
||||
GenericName[ru]=Управление JACK
|
||||
Comment=QjackCtl is a JACK Audio Connection Kit Qt GUI Interface
|
||||
Comment[de]=Grafisches Werkzeug zur Steuerung des JACK-Audio-Systems
|
||||
Comment[fr]=QjackCtl est une interface graphique Qt pour le kit de connexion audio JACK
|
||||
+Comment[it]=Interfaccia di controllo per il kit di connessione audio JACK
|
||||
Comment[ru]=Программа для управления звуковым сервером JACK
|
||||
Exec=@ac_prefix@/bin/qjackctl
|
||||
Icon=@ac_prefix@/share/pixmaps/qjackctl.png
|
12
qjackctl-0.3.7-jackdbus_enable_by_default.patch
Normal file
12
qjackctl-0.3.7-jackdbus_enable_by_default.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru qjackctl-0.3.7.orig//src/qjackctlSetup.cpp qjackctl-0.3.7/src/qjackctlSetup.cpp
|
||||
--- qjackctl-0.3.7.orig//src/qjackctlSetup.cpp 2010-09-25 23:53:44.000000000 +0200
|
||||
+++ qjackctl-0.3.7/src/qjackctlSetup.cpp 2011-03-07 01:40:32.664490708 +0100
|
||||
@@ -107,7 +107,7 @@
|
||||
bServerConfigTemp = m_settings.value("/ServerConfigTemp", false).toBool();
|
||||
bQueryShutdown = m_settings.value("/QueryShutdown", true).toBool();
|
||||
bAlsaSeqEnabled = m_settings.value("/AlsaSeqEnabled", true).toBool();
|
||||
- bDBusEnabled = m_settings.value("/DBusEnabled", false).toBool();
|
||||
+ bDBusEnabled = m_settings.value("/DBusEnabled", true).toBool();
|
||||
bAliasesEnabled = m_settings.value("/AliasesEnabled", false).toBool();
|
||||
bAliasesEditing = m_settings.value("/AliasesEditing", false).toBool();
|
||||
bLeftButtons = m_settings.value("/LeftButtons", true).toBool();
|
23
qjackctl-0.3.9-jackdbus_dont_stop_on_exit.patch
Normal file
23
qjackctl-0.3.9-jackdbus_dont_stop_on_exit.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -Nru qjackctl-0.3.9.orig/src/qjackctlMainForm.cpp qjackctl-0.3.9/src/qjackctlMainForm.cpp
|
||||
--- qjackctl-0.3.9.orig/src/qjackctlMainForm.cpp 2012-05-14 23:33:11.000000000 +0200
|
||||
+++ qjackctl-0.3.9/src/qjackctlMainForm.cpp 2012-08-07 15:41:20.403517472 +0200
|
||||
@@ -1326,19 +1326,6 @@
|
||||
m_pJack->terminate();
|
||||
#endif
|
||||
}
|
||||
- #ifdef CONFIG_DBUS
|
||||
- // Jack D-BUS server backend...
|
||||
- if (m_pDBusControl) {
|
||||
- QDBusMessage dbusm = m_pDBusControl->call("StopServer");
|
||||
- if (dbusm.type() == QDBusMessage::ReplyMessage) {
|
||||
- appendMessages(
|
||||
- tr("D-BUS: JACK server is stopping..."));
|
||||
- } else {
|
||||
- appendMessagesError(
|
||||
- tr("D-BUS: JACK server could not be stopped.\n\nSorry"));
|
||||
- }
|
||||
- }
|
||||
- #endif
|
||||
// Give it some time to terminate gracefully and stabilize...
|
||||
stabilize(QJACKCTL_TIMER_MSECS);
|
||||
// Keep on, if not exiting for good.
|
21
qjackctl-loop2jack
Normal file
21
qjackctl-loop2jack
Normal file
@ -0,0 +1,21 @@
|
||||
#!/bin/sh
|
||||
# script loop2jack, located in /usr/local/bin
|
||||
|
||||
# loop client creation
|
||||
/usr/bin/alsa_out -j alsa_out -d softvol_out -q 1 2>&1 1> /dev/null &
|
||||
/usr/bin/alsa_in -j alsa_in -d softvol_in -q 1 2>&1 1> /dev/null &
|
||||
|
||||
# give it some time before connecting to system ports
|
||||
sleep 1
|
||||
|
||||
# cloop ports -> jack output ports
|
||||
jack_connect alsa_in:capture_1 system:playback_1
|
||||
jack_connect alsa_in:capture_2 system:playback_2
|
||||
|
||||
|
||||
# system microphone (RME analog input 3) to "ploop" ports
|
||||
jack_connect system:capture_3 alsa_out:playback_1
|
||||
jack_connect system:capture_3 alsa_out:playback_2
|
||||
|
||||
# done
|
||||
exit 0
|
154
qjackctl.spec
Normal file
154
qjackctl.spec
Normal file
@ -0,0 +1,154 @@
|
||||
Name: qjackctl
|
||||
Version: 0.3.11
|
||||
Release: 1mamba
|
||||
Summary: A simple Qt application to control the JACK sound server daemon
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://qjackctl.sourceforge.net
|
||||
Source: http://downloads.sourceforge.net/sourceforge/qjackctl/%{name}-%{version}.tar.gz
|
||||
#http://downloads.sourceforge.net/sourceforge/qjackctl/%{name}-%{version}.tar.gz
|
||||
Source1: qjackctl-loop2jack
|
||||
Patch0: qjackctl-0.2.18-wrongincludes.patch
|
||||
Patch1: qjackctl-0.3.10-loop2jack_postStartup_enable.patch
|
||||
Patch2: qjackctl-0.3.6-desktop.patch
|
||||
Patch3: qjackctl-0.3.7-jackdbus_enable_by_default.patch
|
||||
Patch4: qjackctl-0.3.9-jackdbus_dont_stop_on_exit.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: jack >= 0.99.0
|
||||
Requires: alsa-utils >= 1.0.27.1-4mamba
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||
|
||||
%description
|
||||
A simple Qt application to control the JACK sound server daemon
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
#%patch4 -p1
|
||||
|
||||
%build
|
||||
export QTDIR=%{_qt4_prefix}
|
||||
#export QMAKESPEC=linux-g++
|
||||
%configure
|
||||
%make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
install -D -m0755 %{SOURCE1} %{buildroot}%{_bindir}/loop2jack
|
||||
|
||||
install -d -m0755 %{buildroot}%{_sysconfdir}/modules-load.d
|
||||
cat > %{buildroot}%{_sysconfdir}/modules-load.d/snd-aloop.conf << _EOF
|
||||
snd-aloop
|
||||
_EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/modules-load.d/snd-aloop.conf
|
||||
%{_bindir}/qjackctl
|
||||
%{_bindir}/loop2jack
|
||||
%{_datadir}/locale/qjackctl_*.qm
|
||||
#%{_datadir}/pixmaps/qjackctl.png
|
||||
%{_datadir}/applications/qjackctl.desktop
|
||||
%{_datadir}/icons/hicolor/*x*/apps/*.png
|
||||
%{_mandir}/man1/qjackctl.1*
|
||||
%doc AUTHORS COPYING
|
||||
#ChangeLog README TODO
|
||||
|
||||
%changelog
|
||||
* Thu Jan 02 2014 Automatic Build System <autodist@mambasoft.it> 0.3.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jul 24 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.10-2mamba
|
||||
- add and preconfigure loop2jack script
|
||||
- load snd-aloop module
|
||||
- set and enable run of loop2jack as post startup script
|
||||
|
||||
* Thu Apr 04 2013 Automatic Build System <autodist@mambasoft.it> 0.3.10-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.9-2mamba
|
||||
- remove don't stop on exit patch, now supported by a gui option
|
||||
|
||||
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 0.3.9-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Aug 08 2011 Automatic Build System <autodist@mambasoft.it> 0.3.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Mar 07 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.7-2mamba
|
||||
- added patch to enable jackdbus support by default
|
||||
|
||||
* Wed Dec 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.7-1mamba
|
||||
- update to 0.3.7
|
||||
|
||||
* Sun May 09 2010 Automatic Build System <autodist@mambasoft.it> 0.3.6-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Jan 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.4-2mamba
|
||||
- desktop entry moved to music category
|
||||
|
||||
* Mon Dec 08 2008 gil <puntogil@libero.it> 0.3.4-1mamba
|
||||
- update to 0.3.4
|
||||
|
||||
* Wed Aug 27 2008 gil <puntogil@libero.it> 0.3.3-1mamba
|
||||
- update to 0.3.3
|
||||
- added patch for desktop file
|
||||
- changed qt prefix
|
||||
|
||||
* Sun Feb 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.2-1mamba
|
||||
- update to 0.3.2
|
||||
|
||||
* Sat Nov 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.1a-2mamba
|
||||
- disable startup and shutdown scripts by default
|
||||
|
||||
* Tue Sep 25 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.1a-1mamba
|
||||
- update to 0.3.1a
|
||||
|
||||
* Tue May 15 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.22-1mamba
|
||||
- update to 0.2.22
|
||||
- move desktop entry to %{_datadir}/applications
|
||||
|
||||
* Wed Oct 11 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.21-1qilnx
|
||||
- update to version 0.2.21 by autospec
|
||||
|
||||
* Sun Jul 09 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.20-1qilnx
|
||||
- update to version 0.2.20 by autospec
|
||||
|
||||
* Mon Nov 28 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.19a-1qilnx
|
||||
- update to version 0.2.19a by autospec
|
||||
|
||||
* Wed Oct 26 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.18-1qilnx
|
||||
- update to version 0.2.18 by autospec
|
||||
|
||||
* Sun Mar 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.15a-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user