update to 5.2.0 [release 5.2.0-1mamba;Mon May 03 2021]
This commit is contained in:
parent
3b98c8470f
commit
21b22385e0
11
qemu-5.2.0-STATX_MNT_ID-missing-workaround.patch
Normal file
11
qemu-5.2.0-STATX_MNT_ID-missing-workaround.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- qemu-5.2.0/tools/virtiofsd/passthrough_ll.c.orig 2021-05-03 22:19:36.266659588 +0200
|
||||
+++ qemu-5.2.0/tools/virtiofsd/passthrough_ll.c 2021-05-03 22:25:22.351624454 +0200
|
||||
@@ -793,7 +793,7 @@
|
||||
{
|
||||
int res;
|
||||
|
||||
-#if defined(CONFIG_STATX) && defined(STATX_MNT_ID)
|
||||
+#if 0 && defined(CONFIG_STATX) && defined(STATX_MNT_ID)
|
||||
if (lo->use_statx) {
|
||||
struct statx statxbuf;
|
||||
|
70
qemu.spec
70
qemu.spec
@ -1,13 +1,14 @@
|
||||
Name: qemu
|
||||
Version: 5.1.0
|
||||
Release: 2mamba
|
||||
Version: 5.2.0
|
||||
Release: 1mamba
|
||||
Summary: A generic and open source processor emulator
|
||||
Group: Applications/Emulators
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://qemu.org
|
||||
Source: http://wiki.qemu.org/download/qemu-%{version}.tar.bz2
|
||||
URL: https://qemu.org
|
||||
Source: https://download.qemu.org/qemu-%{version}.tar.xz
|
||||
#Source: http://wiki.qemu.org/download/qemu-%{version}.tar.bz2
|
||||
Source1: %{name}-initscript
|
||||
Source2: qemu-guest-agent.service
|
||||
Source3: 99-qemu-guest-agent.rules
|
||||
@ -20,15 +21,14 @@ Patch3: %{name}-0.8.0-gcc4_ppc.patch
|
||||
Patch4: %{name}-0.8.0-ldscript_ppc.patch
|
||||
Patch5: qemu-1.4.1-texinfo-5.patch
|
||||
Patch6: qemu-1.7.0-virtfs-ftbfs.patch
|
||||
Patch7: qemu-5.2.0-STATX_MNT_ID-missing-workaround.patch
|
||||
License: GPL, LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libaio-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbrltty-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcacard-devel
|
||||
@ -36,21 +36,20 @@ BuildRequires: libcairo-devel
|
||||
BuildRequires: libcap-ng-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libepoxy-devel
|
||||
BuildRequires: libgbm-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgnutls-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblzo-devel
|
||||
BuildRequires: libmesa-devel
|
||||
BuildRequires: libmultipath-tools-devel
|
||||
BuildRequires: libndctl-devel
|
||||
BuildRequires: libnettle-devel
|
||||
BuildRequires: libnfs-devel
|
||||
BuildRequires: libnuma-devel
|
||||
BuildRequires: libpam-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpulseaudio-devel
|
||||
@ -65,11 +64,10 @@ BuildRequires: libudev-devel
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libusbredir-devel
|
||||
BuildRequires: libvte-devel
|
||||
%ifnarch arm
|
||||
%ifarch x86_64 %{ix86}
|
||||
BuildRequires: libxen-devel
|
||||
%endif
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
@ -84,7 +82,6 @@ BuildRequires: libbrltty-devel >= 6.1
|
||||
#% endif
|
||||
Conflicts: kvm
|
||||
%systemd_requires
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
QEMU is a generic and open source processor emulator which achieves a good emulation speed by using dynamic translation.
|
||||
@ -140,12 +137,16 @@ This package contains static user mode emulators. In this mode, QEMU can launch
|
||||
#%endif
|
||||
#%patch5 -p1
|
||||
#%patch6 -p1
|
||||
%patch7 -p1
|
||||
|
||||
%build
|
||||
#:<< ___EOF
|
||||
# static build for usermode emulation targets only
|
||||
# used by cross platform installation tools like makedist
|
||||
./configure \
|
||||
mkdir build-static
|
||||
cd build-static
|
||||
|
||||
../configure \
|
||||
--sysconfdir=%{_sysconfdir} \
|
||||
--prefix=%{_prefix} \
|
||||
--cc=%{_build}-gcc \
|
||||
@ -167,15 +168,17 @@ This package contains static user mode emulators. In this mode, QEMU can launch
|
||||
# --disable-usb-redir \
|
||||
# --disable-vde \
|
||||
|
||||
%make LIBSSH_LIBS="-lssh -lcrypto -ldl -lgss"
|
||||
mkdir static
|
||||
find *-linux-user -name qemu-\* -exec mv {} static/ \;
|
||||
#LIBSSH_LIBS="-lssh -lcrypto -ldl -lgss"
|
||||
%make
|
||||
|
||||
make clean
|
||||
cd ..
|
||||
#___EOF
|
||||
|
||||
mkdir build-dynamic
|
||||
cd build-dynamic
|
||||
|
||||
# dynamic build
|
||||
./configure \
|
||||
../configure \
|
||||
--sysconfdir=%{_sysconfdir} \
|
||||
--prefix=%{_prefix} \
|
||||
--libdir=%{_libdir} \
|
||||
@ -183,21 +186,16 @@ make clean
|
||||
--cc=%{_build}-gcc \
|
||||
--host-cc=%{_host}-gcc \
|
||||
--cpu=%{_host_cpu} \
|
||||
%if "%{_build_cpu}" == "ppc"
|
||||
--disable-gcc-check \
|
||||
#% else
|
||||
# --cc=%{_target_platform}-gcc34 \
|
||||
%endif
|
||||
--audio-drv-list="alsa pa" \
|
||||
--enable-spice \
|
||||
--enable-usb-redir \
|
||||
--enable-guest-agent
|
||||
|
||||
%make
|
||||
|
||||
%make LDFLAGS_NOPIE=""
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
%makeinstall -C build-dynamic
|
||||
|
||||
#install -D -m 755 %{S:1} \
|
||||
# %{buildroot}%{_prefix}/lib/systemd/scripts/%{name}-binfmt
|
||||
@ -208,10 +206,12 @@ install -d -m0755 %{buildroot}%{_binfmtdir}
|
||||
scripts/qemu-binfmt-conf.sh --exportdir %{buildroot}%{_binfmtdir}/ \
|
||||
--systemd ALL --qemu-path %{_bindir}
|
||||
|
||||
cd static
|
||||
for f in *; do
|
||||
cd build-static
|
||||
find *-linux-user -name qemu-\* | while read f; do
|
||||
cp -L ${f} %{buildroot}%{_bindir}/`basename $f`.static
|
||||
|
||||
## (obsolete?) disable stripping static binaries by installing without -x
|
||||
install -m755 $f %{buildroot}%{_bindir}/$f.static
|
||||
#install -m755 $f %{buildroot}%{_bindir}/$f.static
|
||||
done
|
||||
cd ..
|
||||
|
||||
@ -261,15 +261,15 @@ find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
%{_bindir}/%{name}*
|
||||
%{_bindir}/elf2dmp
|
||||
%exclude %{_bindir}/qemu-ga
|
||||
%{_bindir}/ivshmem-client
|
||||
%{_bindir}/ivshmem-server
|
||||
#%{_bindir}/ivshmem-client
|
||||
#%{_bindir}/ivshmem-server
|
||||
%exclude %{_bindir}/%{name}*.static
|
||||
%{_datadir}/applications/qemu.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/qemu.png
|
||||
%{_datadir}/icons/hicolor/*/apps/qemu.bmp
|
||||
%{_datadir}/icons/hicolor/scalable/apps/qemu.svg
|
||||
%{_libexecdir}/qemu-bridge-helper
|
||||
%{_libexecdir}/qemu-pr-helper
|
||||
#%{_libexecdir}/qemu-pr-helper
|
||||
%{_libexecdir}/virtfs-proxy-helper
|
||||
%{_libexecdir}/virtiofsd
|
||||
%{_datadir}/%{name}
|
||||
@ -282,6 +282,7 @@ find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
%{_mandir}/man7/qemu-block-drivers.7*
|
||||
%{_mandir}/man7/qemu-cpu-models.7*
|
||||
%{_mandir}/man8/qemu-nbd.8*
|
||||
%{_mandir}/man8/qemu-pr-helper.8*
|
||||
%doc COPYING COPYING.LIB
|
||||
|
||||
%files guest-agent
|
||||
@ -318,6 +319,9 @@ find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
%attr(0755,root,root) %{_bindir}/%{name}*.static
|
||||
|
||||
%changelog
|
||||
* Mon May 03 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.0-1mamba
|
||||
- update to 5.2.0
|
||||
|
||||
* Fri Oct 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 5.1.0-2mamba
|
||||
- rebuilt with libbrltty 6.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user