remove use of update-desktop-database
sort specfile heaeder entries in the usual way for openmamba list one build requirement per line remove version from deskt menu entry and other fixes [release 2.0.5.0-2mamba;Fri Mar 07 2008]
This commit is contained in:
parent
db44e00f46
commit
c68ca17202
@ -1,2 +1,5 @@
|
|||||||
# qcad
|
# qcad
|
||||||
|
|
||||||
|
QCad is a professional 2D CAD System. With QCad you can easily construct and change drawings with ISO-text and many other features and save them as DXF-files.
|
||||||
|
These DXF-files are the interface to many CAD-systems such as AutoCAD(TM) and many others.
|
||||||
|
|
||||||
|
12
qcad-nopedantic.patch
Normal file
12
qcad-nopedantic.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Naur qcad-2.0.5-orig/mkspecs/defs.pro qcad-2.0.5.0-1-community.src/mkspecs/defs.pro
|
||||||
|
--- qcad-2.0.5-orig/mkspecs/defs.pro 2008-01-19 14:59:44.000000000 +0100
|
||||||
|
+++ qcad-2.0.5.0-1-community.src/mkspecs/defs.pro 2008-01-19 15:15:37.000000000 +0100
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
# $Id: defs.pro 606 2004-12-25 03:08:40Z andrew $
|
||||||
|
-QMAKE_CXXFLAGS_DEBUG += -pedantic
|
||||||
|
-QMAKE_CXXFLAGS += -pedantic
|
||||||
|
+QMAKE_CXXFLAGS_DEBUG += -Wno-long-long -pedantic
|
||||||
|
+QMAKE_CXXFLAGS += -Wno-long-long -pedantic
|
||||||
|
|
||||||
|
win32 {
|
||||||
|
QMAKE_CFLAGS_THREAD -= -mthreads
|
187
qcad.spec
Normal file
187
qcad.spec
Normal file
@ -0,0 +1,187 @@
|
|||||||
|
%define _csver 2.0.4.0-1
|
||||||
|
%define _dever 2.1.0.0-1
|
||||||
|
%define _enver 2.1.0.0-1
|
||||||
|
%define _huver 2.0.4.0-1
|
||||||
|
|
||||||
|
Name: qcad
|
||||||
|
Version: 2.0.5.0
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A professional 2D CAD system
|
||||||
|
Group: Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
||||||
|
URL: http://www.qcad.org
|
||||||
|
Source0: ftp://ribbonsoft.com/archives/qcad/%{name}-%{version}-1-community.src.tar.gz
|
||||||
|
Source1: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-cs-%{_csver}.html.zip
|
||||||
|
Source2: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-de-%{_dever}.html.zip
|
||||||
|
Source3: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-en-%{_enver}.html.zip
|
||||||
|
Source4: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-hu-%{_huver}.html.zip
|
||||||
|
Patch0: qcad-nopedantic.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
BuildRequires: bash
|
||||||
|
BuildRequires: patch
|
||||||
|
BuildRequires: libqt-devel
|
||||||
|
BuildRequires: libmng-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libGLU-devel
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libXmu-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libIDL-devel
|
||||||
|
BuildRequires: libpthread-stubs-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
|
||||||
|
%description
|
||||||
|
QCad is a professional 2D CAD System. With QCad you can easily construct and change drawings with ISO-text and many other features and save them as DXF-files.
|
||||||
|
These DXF-files are the interface to many CAD-systems such as AutoCAD(TM) and many others.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{version}-1-community.src -a1 -a2 -a3 -a4
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
# QTDIR is always set to /usr/lib/qt3
|
||||||
|
export QTDIR=/usr/lib/qt3
|
||||||
|
export QMAKESPEC=$QTDIR/mkspecs/linux-g++
|
||||||
|
export PATH=$PATH:$QTDIR/bin
|
||||||
|
|
||||||
|
%define pkgdatadir %{_datadir}/qcad
|
||||||
|
|
||||||
|
[ -n "$QTDIR" ] || . %{_sysconfdir}/profile.d/qt.sh
|
||||||
|
(
|
||||||
|
cd scripts
|
||||||
|
./build_qcad.sh notrans
|
||||||
|
# ./build_qcad.sh prof notrans
|
||||||
|
)
|
||||||
|
|
||||||
|
#find -name '*.ts' -exec lrelease '{}' ';'
|
||||||
|
find -name '*.qm' -exec cp '{}' qcad/qm ';'
|
||||||
|
#cd ..
|
||||||
|
cwd=`pwd`
|
||||||
|
for dir in qcad qcadactions qcadguiqt qcadcmd qcadlib
|
||||||
|
do
|
||||||
|
pushd $dir/src
|
||||||
|
echo "running lrelease in $dir/src..."
|
||||||
|
find -type f -name '*.ts' -exec $QTDIR/bin/lrelease '{}' \;
|
||||||
|
find -type f -name '*.pro' -exec $QTDIR/bin/lrelease '{}' \;
|
||||||
|
popd
|
||||||
|
|
||||||
|
pushd $dir/src/ts
|
||||||
|
echo "copying from $dir/src/ts..."
|
||||||
|
for tf in *.qm
|
||||||
|
do
|
||||||
|
if [ ! -e $cwd/qcad/qm/$tf ]
|
||||||
|
then
|
||||||
|
cp $cwd/$dir/src/ts/$tf $cwd/qcad/qm/$tf
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
popd
|
||||||
|
done
|
||||||
|
echo "building translations finished"
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{pkgdatadir} \
|
||||||
|
%{buildroot}%{pkgdatadir}/icon \
|
||||||
|
%{buildroot}%{pkgdatadir}/doc
|
||||||
|
|
||||||
|
cp -LR scripts %{buildroot}%{_datadir}/qcad
|
||||||
|
cp -fr %{name}-manual-cs-%{_csver}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||||
|
cp -fr %{name}-manual-de-%{_dever}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||||
|
cp -fr %{name}-manual-en-%{_enver}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||||
|
cp -fr %{name}-manual-hu-%{_huver}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||||
|
|
||||||
|
cd qcad
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/applications
|
||||||
|
|
||||||
|
#cat > %{buildroot}%{_bindir}/qcad <<EOF
|
||||||
|
#!/bin/sh
|
||||||
|
#.%{_libdir}/qcad "\$@"
|
||||||
|
#EOF
|
||||||
|
|
||||||
|
#cd qcad
|
||||||
|
#cp -fr fonts %{buildroot}%{pkgdatadir}
|
||||||
|
#cp -fr patterns %{buildroot}%{pkgdatadir}
|
||||||
|
#cp -fr qm %{buildroot}%{pkgdatadir}
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||||
|
cp -f src/xpm/qcad.xpm %{buildroot}%{_datadir}/pixmaps
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_bindir}
|
||||||
|
cp -f qcad %{buildroot}%{_bindir}
|
||||||
|
|
||||||
|
# install -D -m755 qcad %{buildroot}/%{_bindir}/
|
||||||
|
|
||||||
|
install -D -m755 src/images/qcad.png %{buildroot}%{_datadir}/qcad/icon/qcad.png
|
||||||
|
|
||||||
|
install -m755 -d %{buildroot}%{_datadir}/qcad \
|
||||||
|
%{buildroot}%{_datadir}/qcad/icon
|
||||||
|
|
||||||
|
#install -s -m 755 qcad %{buildroot}/%{_libdir}/qcad
|
||||||
|
#install -D -m755 qcad %{buildroot}/%{_bindir}/
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/qcad/icon
|
||||||
|
install -D -m644 src/images/qcad.png %{buildroot}%{_datadir}/qcad/icon/qcad.png
|
||||||
|
|
||||||
|
for i in {data,doc,fonts,library,machines,patterns,qm}; do cp -r $i %{buildroot}%{_datadir}/qcad; done
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}/usr/lib/qt3/etc/settings
|
||||||
|
mkdir -p %{buildroot}%{pkgdatadir}/library
|
||||||
|
|
||||||
|
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||||
|
[Desktop Entry]
|
||||||
|
Name=QCad
|
||||||
|
Comment=A professional 2D CAD system
|
||||||
|
Comment[it]=Un sistema professionale di CAD 2D
|
||||||
|
GenericName=A professional 2D CAD system
|
||||||
|
GenericName[it]=Un sistema professionale di CAD 2D
|
||||||
|
Exec=qcad
|
||||||
|
Icon=/usr/share/qcad/icon/qcad.png
|
||||||
|
Terminal=0
|
||||||
|
Type=Application
|
||||||
|
Categories=KDE;Application;Graphics;
|
||||||
|
X-KDE-StartupNotify=false
|
||||||
|
EOF
|
||||||
|
|
||||||
|
# fix permissions
|
||||||
|
find %{buildroot}%{_bindir}/ -type d -print | xargs chmod 755
|
||||||
|
find %{buildroot}%{_libdir}/ -type d -print | xargs chmod 755
|
||||||
|
find %{buildroot}%{_datadir}/ -type d -print | xargs chmod 755
|
||||||
|
find %{buildroot}%{_datadir}/ -type f -print | xargs chmod 644
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%doc qcad/doc qcad/README qcad/data
|
||||||
|
%defattr(755,root,root)
|
||||||
|
%{_datadir}/qcad/*
|
||||||
|
%{_bindir}/*
|
||||||
|
%{_datadir}/applications/*
|
||||||
|
%{_datadir}/pixmaps/*
|
||||||
|
%changelog
|
||||||
|
* Fri Mar 07 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.5.0-2mamba
|
||||||
|
- remove use of update-desktop-database
|
||||||
|
- sort specfile heaeder entries in the usual way for openmamba
|
||||||
|
- list one build requirement per line
|
||||||
|
- remove version from deskt menu entry and other fixes
|
||||||
|
|
||||||
|
* Sat Dec 08 2007 Tiziana Ferro <tiziana.ferro@email.it> 2.0.5.0-1mamba
|
||||||
|
- update to 2.0.5.0
|
||||||
|
|
||||||
|
* Mon Apr 18 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.0.4.0-3qilnx
|
||||||
|
- rebuild and added a changelog entry
|
||||||
|
|
||||||
|
* Fri Apr 08 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.0.4.0-2qilnx
|
||||||
|
- rebuild and moved from devel-contrib repository to devel repository
|
||||||
|
|
||||||
|
* Sat Sep 25 2004 Matteo Bernasconi <voyagernm@virgilio.it> 2.0.4-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user