update to 3.5.1.4 [release 3.5.1.4-1mamba;Fri Jun 06 2014]
This commit is contained in:
parent
c68ca17202
commit
341dd44b9e
@ -1,12 +0,0 @@
|
||||
diff -Naur qcad-2.0.5-orig/mkspecs/defs.pro qcad-2.0.5.0-1-community.src/mkspecs/defs.pro
|
||||
--- qcad-2.0.5-orig/mkspecs/defs.pro 2008-01-19 14:59:44.000000000 +0100
|
||||
+++ qcad-2.0.5.0-1-community.src/mkspecs/defs.pro 2008-01-19 15:15:37.000000000 +0100
|
||||
@@ -1,6 +1,6 @@
|
||||
# $Id: defs.pro 606 2004-12-25 03:08:40Z andrew $
|
||||
-QMAKE_CXXFLAGS_DEBUG += -pedantic
|
||||
-QMAKE_CXXFLAGS += -pedantic
|
||||
+QMAKE_CXXFLAGS_DEBUG += -Wno-long-long -pedantic
|
||||
+QMAKE_CXXFLAGS += -Wno-long-long -pedantic
|
||||
|
||||
win32 {
|
||||
QMAKE_CFLAGS_THREAD -= -mthreads
|
196
qcad.spec
196
qcad.spec
@ -4,29 +4,32 @@
|
||||
%define _huver 2.0.4.0-1
|
||||
|
||||
Name: qcad
|
||||
Version: 2.0.5.0
|
||||
Release: 2mamba
|
||||
Version: 3.5.1.4
|
||||
Release: 1mamba
|
||||
Summary: A professional 2D CAD system
|
||||
Group: Applications/Graphics
|
||||
Group: Graphical Desktop/Applications/Graphics
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
||||
URL: http://www.qcad.org
|
||||
Source0: ftp://ribbonsoft.com/archives/qcad/%{name}-%{version}-1-community.src.tar.gz
|
||||
Source1: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-cs-%{_csver}.html.zip
|
||||
Source2: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-de-%{_dever}.html.zip
|
||||
Source3: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-en-%{_enver}.html.zip
|
||||
Source4: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-hu-%{_huver}.html.zip
|
||||
Patch0: qcad-nopedantic.patch
|
||||
Source0: git://github.com/qcad/qcad.git/v%{version}/%{name}-%{version}.tar.bz2
|
||||
#Source0: ftp://ribbonsoft.com/archives/qcad/%{name}-%{version}-1-community.src.tar.gz
|
||||
#Source1: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-cs-%{_csver}.html.zip
|
||||
#Source2: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-de-%{_dever}.html.zip
|
||||
#Source3: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-en-%{_enver}.html.zip
|
||||
#Source4: ftp://ribbonsoft.com/archives/qcad/%{name}-manual-hu-%{_huver}.html.zip
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: bash
|
||||
BuildRequires: patch
|
||||
BuildRequires: libqt-devel
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libmng-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libICE-devel
|
||||
@ -34,106 +37,61 @@ BuildRequires: libIDL-devel
|
||||
BuildRequires: libpthread-stubs-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
QCad is a professional 2D CAD System. With QCad you can easily construct and change drawings with ISO-text and many other features and save them as DXF-files.
|
||||
These DXF-files are the interface to many CAD-systems such as AutoCAD(TM) and many others.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}-1-community.src -a1 -a2 -a3 -a4
|
||||
%patch0 -p1
|
||||
%setup -q
|
||||
#-n %{name}-%{version}-1-community.src -a1 -a2 -a3 -a4
|
||||
|
||||
if [ ! -e src/3rdparty/qt-labs-qtscriptgenerator-%{_qt4_version} ]; then
|
||||
cp -a src/3rdparty/qt-labs-qtscriptgenerator-4.8.4 src/3rdparty/qt-labs-qtscriptgenerator-%{_qt4_version}
|
||||
mv src/3rdparty/qt-labs-qtscriptgenerator-%{_qt4_version}/qt-labs-qtscriptgenerator-4.8.4.pro \
|
||||
src/3rdparty/qt-labs-qtscriptgenerator-%{_qt4_version}/qt-labs-qtscriptgenerator-%{_qt4_version}.pro
|
||||
fi
|
||||
|
||||
%build
|
||||
# QTDIR is always set to /usr/lib/qt3
|
||||
export QTDIR=/usr/lib/qt3
|
||||
export QMAKESPEC=$QTDIR/mkspecs/linux-g++
|
||||
export PATH=$PATH:$QTDIR/bin
|
||||
|
||||
%define pkgdatadir %{_datadir}/qcad
|
||||
|
||||
[ -n "$QTDIR" ] || . %{_sysconfdir}/profile.d/qt.sh
|
||||
(
|
||||
cd scripts
|
||||
./build_qcad.sh notrans
|
||||
# ./build_qcad.sh prof notrans
|
||||
)
|
||||
|
||||
#find -name '*.ts' -exec lrelease '{}' ';'
|
||||
find -name '*.qm' -exec cp '{}' qcad/qm ';'
|
||||
#cd ..
|
||||
cwd=`pwd`
|
||||
for dir in qcad qcadactions qcadguiqt qcadcmd qcadlib
|
||||
do
|
||||
pushd $dir/src
|
||||
echo "running lrelease in $dir/src..."
|
||||
find -type f -name '*.ts' -exec $QTDIR/bin/lrelease '{}' \;
|
||||
find -type f -name '*.pro' -exec $QTDIR/bin/lrelease '{}' \;
|
||||
popd
|
||||
|
||||
pushd $dir/src/ts
|
||||
echo "copying from $dir/src/ts..."
|
||||
for tf in *.qm
|
||||
do
|
||||
if [ ! -e $cwd/qcad/qm/$tf ]
|
||||
then
|
||||
cp $cwd/$dir/src/ts/$tf $cwd/qcad/qm/$tf
|
||||
fi
|
||||
done
|
||||
popd
|
||||
done
|
||||
echo "building translations finished"
|
||||
qmake
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
mkdir -p %{buildroot}%{pkgdatadir} \
|
||||
%{buildroot}%{pkgdatadir}/icon \
|
||||
%{buildroot}%{pkgdatadir}/doc
|
||||
# remove project files
|
||||
find . \( -name '*.pri' -or -name '.pro' -or -name '*.ts' \) -delete
|
||||
find . \( -name 'Makefile' -name '.gitignore' \) -delete
|
||||
|
||||
cp -LR scripts %{buildroot}%{_datadir}/qcad
|
||||
cp -fr %{name}-manual-cs-%{_csver}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||
cp -fr %{name}-manual-de-%{_dever}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||
cp -fr %{name}-manual-en-%{_enver}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||
cp -fr %{name}-manual-hu-%{_huver}.html/* %{buildroot}%{pkgdatadir}/doc
|
||||
install -dm755 %{buildroot}%{_datadir}/{qcad,pixmaps,applications}
|
||||
cp -r examples fonts libraries patterns plugins scripts ts %{buildroot}%{_datadir}/qcad
|
||||
cp release/* %{buildroot}%{_datadir}/qcad/
|
||||
#cp debug/* %{buildroot}%{_datadir}/qcad
|
||||
|
||||
cd qcad
|
||||
install -m755 readme.txt %{buildroot}%{_datadir}/qcad/readme.txt
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
# qtwebkit
|
||||
ln -sf %{_libdir}/qt4/plugins/designer/libqwebview.so %{buildroot}%{_datadir}/qcad/plugins/designer/libqwebview.so
|
||||
# qt
|
||||
for sofiles in %{_libdir}/qt4/plugins/imageformats/*.so
|
||||
do
|
||||
ln -sf ${sofiles} %{buildroot}%{_datadir}/qcad/plugins/imageformats/${sofiles##/*/}
|
||||
done
|
||||
for sofiles in %{_libdir}/qt4/plugins/sqldrivers/*.so
|
||||
do
|
||||
ln -sf ${sofiles} %{buildroot}%{_datadir}/qcad/plugins/sqldrivers/${sofiles##/*/}
|
||||
done
|
||||
|
||||
#cat > %{buildroot}%{_bindir}/qcad <<EOF
|
||||
#!/bin/sh
|
||||
#.%{_libdir}/qcad "\$@"
|
||||
#EOF
|
||||
install -Dm644 scripts/qcad_icon.png %{buildroot}%{_datadir}/pixmaps/qcad_icon.png
|
||||
#install -Dm644 QCad.desktop %{buildroot}%{_datadir}/applications/QCad.desktop
|
||||
|
||||
#cd qcad
|
||||
#cp -fr fonts %{buildroot}%{pkgdatadir}
|
||||
#cp -fr patterns %{buildroot}%{pkgdatadir}
|
||||
#cp -fr qm %{buildroot}%{pkgdatadir}
|
||||
install -dm0755 %{buildroot}%{_bindir}
|
||||
echo -e '#!/bin/sh\nLD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"/usr/share/qcad" exec /usr/share/qcad/qcad-bin "$@"' >%{buildroot}/usr/bin/qcad
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||
cp -f src/xpm/qcad.xpm %{buildroot}%{_datadir}/pixmaps
|
||||
rm -f %{buildroot}%{_datadir}/qcad/scripts/.gitignore
|
||||
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
cp -f qcad %{buildroot}%{_bindir}
|
||||
|
||||
# install -D -m755 qcad %{buildroot}/%{_bindir}/
|
||||
|
||||
install -D -m755 src/images/qcad.png %{buildroot}%{_datadir}/qcad/icon/qcad.png
|
||||
|
||||
install -m755 -d %{buildroot}%{_datadir}/qcad \
|
||||
%{buildroot}%{_datadir}/qcad/icon
|
||||
|
||||
#install -s -m 755 qcad %{buildroot}/%{_libdir}/qcad
|
||||
#install -D -m755 qcad %{buildroot}/%{_bindir}/
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/qcad/icon
|
||||
install -D -m644 src/images/qcad.png %{buildroot}%{_datadir}/qcad/icon/qcad.png
|
||||
|
||||
for i in {data,doc,fonts,library,machines,patterns,qm}; do cp -r $i %{buildroot}%{_datadir}/qcad; done
|
||||
|
||||
mkdir -p %{buildroot}/usr/lib/qt3/etc/settings
|
||||
mkdir -p %{buildroot}%{pkgdatadir}/library
|
||||
chmod 0755 %{buildroot}%{_bindir}/qcad
|
||||
|
||||
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
|
||||
[Desktop Entry]
|
||||
@ -142,32 +100,52 @@ Comment=A professional 2D CAD system
|
||||
Comment[it]=Un sistema professionale di CAD 2D
|
||||
GenericName=A professional 2D CAD system
|
||||
GenericName[it]=Un sistema professionale di CAD 2D
|
||||
Exec=qcad
|
||||
Icon=/usr/share/qcad/icon/qcad.png
|
||||
Exec=%{_bindir}/qcad
|
||||
Icon=%{_datadir}/pixmaps/qcad_icon.png
|
||||
Terminal=0
|
||||
Type=Application
|
||||
Categories=KDE;Application;Graphics;
|
||||
Categories=Application;Development;Electronics;Engineering;
|
||||
X-KDE-StartupNotify=false
|
||||
EOF
|
||||
|
||||
# fix permissions
|
||||
find %{buildroot}%{_bindir}/ -type d -print | xargs chmod 755
|
||||
find %{buildroot}%{_libdir}/ -type d -print | xargs chmod 755
|
||||
find %{buildroot}%{_datadir}/ -type d -print | xargs chmod 755
|
||||
find %{buildroot}%{_datadir}/ -type f -print | xargs chmod 644
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc qcad/doc qcad/README qcad/data
|
||||
%defattr(755,root,root)
|
||||
%{_datadir}/qcad/*
|
||||
%{_bindir}/*
|
||||
%{_bindir}/qcad
|
||||
%dir %{_datadir}/qcad
|
||||
%{_datadir}/qcad/*.a
|
||||
%{_datadir}/qcad/*.so
|
||||
%{_datadir}/qcad/mainwindow_prototype
|
||||
%{_datadir}/qcad/qcad-bin
|
||||
%{_datadir}/qcad/readme.txt
|
||||
%dir %{_datadir}/qcad/examples
|
||||
%{_datadir}/qcad/examples/*
|
||||
%dir %{_datadir}/qcad/fonts
|
||||
%{_datadir}/qcad/fonts/*
|
||||
%dir %{_datadir}/qcad/libraries
|
||||
%{_datadir}/qcad/libraries/*
|
||||
%dir %{_datadir}/qcad/patterns
|
||||
%{_datadir}/qcad/patterns/*
|
||||
%dir %{_datadir}/qcad/plugins
|
||||
%{_datadir}/qcad/plugins/*
|
||||
%dir %{_datadir}/qcad/scripts
|
||||
%{_datadir}/qcad/scripts/*
|
||||
%dir %{_datadir}/qcad/ts
|
||||
%{_datadir}/qcad/ts/*
|
||||
%{_datadir}/applications/*
|
||||
%{_datadir}/pixmaps/*
|
||||
%doc gpl-3.0.txt gpl-3.0-exceptions.txt LICENSE.txt
|
||||
#% doc qcad/doc qcad/README qcad/data
|
||||
|
||||
%changelog
|
||||
* Fri Jun 06 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.5.1.4-1mamba
|
||||
- update to 3.5.1.4
|
||||
|
||||
* Wed Jun 12 2013 Automatic Build System <autodist@mambasoft.it> 3.0.14.0-1mamba
|
||||
- update to 3.0.14.0
|
||||
|
||||
* Fri Mar 07 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.5.0-2mamba
|
||||
- remove use of update-desktop-database
|
||||
- sort specfile heaeder entries in the usual way for openmamba
|
||||
|
Loading…
Reference in New Issue
Block a user