automatic update by autodist [release 3.1.9-1mamba;Sun Mar 02 2014]
This commit is contained in:
parent
c441de31a1
commit
2d3742cefa
@ -1,2 +1,5 @@
|
||||
# qbittorrent
|
||||
|
||||
The qBittorrent project aims to provide a Free Software alternative to µtorrent.
|
||||
qBittorrent is based on Qt4 toolkit and libtorrent-rasterbar.
|
||||
|
||||
|
11
qbittorrent-3.0.9-gcc-4.8.patch
Normal file
11
qbittorrent-3.0.9-gcc-4.8.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- qbittorrent-3.0.9/src/main.cpp.orig 2013-06-05 03:31:19.268600050 +0200
|
||||
+++ qbittorrent-3.0.9/src/main.cpp 2013-06-05 03:30:06.407413357 +0200
|
||||
@@ -207,7 +207,7 @@
|
||||
qDebug("Message: %s", qPrintable(message));
|
||||
app.sendMessage(message);
|
||||
} else { // Raise main window
|
||||
- app.sendMessage("qbt://show");
|
||||
+ app.sendMessage((QString)"qbt://show");
|
||||
}
|
||||
return 0;
|
||||
}
|
11
qbittorrent-3.1.8-libqt4-4.8.5.patch
Normal file
11
qbittorrent-3.1.8-libqt4-4.8.5.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- qbittorrent-3.1.8/src/messageboxraised.h.orig 2014-02-23 15:07:30.560084578 +0100
|
||||
+++ qbittorrent-3.1.8/src/messageboxraised.h 2014-02-23 15:06:36.511629586 +0100
|
||||
@@ -31,7 +31,7 @@
|
||||
#ifndef MESSAGEBOXRAISED_H
|
||||
#define MESSAGEBOXRAISED_H
|
||||
|
||||
-#include <QMessageBox>
|
||||
+#include <QtGui/QMessageBox>
|
||||
|
||||
class MessageBoxRaised : public QMessageBox
|
||||
{
|
12
qbittorrent-nox.README
Normal file
12
qbittorrent-nox.README
Normal file
@ -0,0 +1,12 @@
|
||||
qbittorrent-nox
|
||||
--------------------------
|
||||
|
||||
qBittorrent-nox is a version of qBittorrent that does not require X and can
|
||||
be controlled via a WebUI, thus is more suitable for headless servers.
|
||||
|
||||
The Web User Interface is accessible as a default on http://localhost:8080.
|
||||
Access is secured and the default account user name is "admin" with
|
||||
"adminadmin" as a password. Please refer to qbittorrent-nox(1) manpage for
|
||||
more information.
|
||||
|
||||
-- Cristian Greco <cristian@regolo.cc> Wed, 20 Jan 2010 00:50:45 +0100
|
146
qbittorrent.spec
Normal file
146
qbittorrent.spec
Normal file
@ -0,0 +1,146 @@
|
||||
Name: qbittorrent
|
||||
Version: 3.1.9
|
||||
Release: 1mamba
|
||||
Summary: Free and reliable P2P Bittorrent client
|
||||
Group: Graphical Desktop/Applications/Networking
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||
URL: http://qbittorrent.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/qbittorrent/qbittorrent-%{version}.tar.gz
|
||||
Source1: qbittorrent-nox.README
|
||||
Patch0: qbittorrent-3.0.9-gcc-4.8.patch
|
||||
Patch1: qbittorrent-3.1.8-libqt4-4.8.5.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libnotify-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libqtsingleapplication-devel
|
||||
BuildRequires: libqtsinglecoreapplication-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtorrent-rasterbar-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: gcc-c++
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The qBittorrent project aims to provide a Free Software alternative to µtorrent.
|
||||
qBittorrent is based on Qt4 toolkit and libtorrent-rasterbar.
|
||||
|
||||
%package nox
|
||||
Summary: A Headless Bittorrent Client
|
||||
Group: Applications/Networking
|
||||
|
||||
%description nox
|
||||
A Headless Bittorrent Client with a feature rich Web UI allowing users to control the clinet remotely.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
cp -p %{S:1} doc/README
|
||||
|
||||
%build
|
||||
mkdir build-nox build-gui
|
||||
|
||||
# headless version
|
||||
pushd build-nox
|
||||
../configure \
|
||||
--prefix=%{_prefix} \
|
||||
--qtdir=%{_qt4_prefix} \
|
||||
--disable-gui \
|
||||
--with-qtsingleapplication=system
|
||||
|
||||
cp conf.pri ..
|
||||
%make
|
||||
mv -f ../conf.pri ../conf.pri.nox
|
||||
popd
|
||||
|
||||
# gui version
|
||||
pushd build-gui
|
||||
../configure \
|
||||
--prefix=%{_prefix} \
|
||||
--qtdir=%{_qt4_prefix} \
|
||||
--with-qtsingleapplication=system
|
||||
|
||||
cp conf.pri ..
|
||||
%make
|
||||
mv -f ../conf.pri ../conf.pri.gui
|
||||
popd
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
# headless version
|
||||
mv -f conf.pri.nox conf.pri
|
||||
make install -C build-nox \
|
||||
INSTALL_ROOT=%{buildroot}
|
||||
|
||||
# gui version
|
||||
mv -f conf.pri.gui conf.pri
|
||||
make install -C build-gui \
|
||||
INSTALL_ROOT=%{buildroot}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/qbittorrent
|
||||
%{_mandir}/man1/qbittorrent.1*
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/*.png
|
||||
%{_datadir}/pixmaps/qbittorrent.png
|
||||
%doc AUTHORS COPYING NEWS README TODO Changelog
|
||||
|
||||
%files nox
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/qbittorrent-nox
|
||||
%{_mandir}/man1/qbittorrent-nox.1*
|
||||
%doc AUTHORS COPYING doc/README
|
||||
|
||||
%changelog
|
||||
* Sun Mar 02 2014 Automatic Build System <autodist@mambasoft.it> 3.1.9-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Jun 05 2013 Automatic Build System <autodist@mambasoft.it> 3.0.9-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jan 30 2013 Automatic Build System <autodist@mambasoft.it> 3.0.8-2mamba
|
||||
- rebuilt with libtorrent-rasterbar 0.16.7
|
||||
|
||||
* Wed Jan 23 2013 Automatic Build System <autodist@mambasoft.it> 3.0.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 3.0.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 2.8.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jul 26 2011 Automatic Build System <autodist@mambasoft.it> 2.8.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Mar 14 2011 Automatic Build System <autodist@mambasoft.it> 2.6.9-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 2.6.6-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Jan 23 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.6.4-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user