update to 1.3.7 [release 1.3.7-1mamba;Sun Jul 08 2018]

This commit is contained in:
Ercole 'ercolinux' Carpanetto 2024-01-05 16:59:19 +01:00
parent 90ee095f12
commit 9a885c25eb
2 changed files with 70 additions and 4 deletions

60
q4wine-1.3.7-qt5.11.patch Normal file
View File

@ -0,0 +1,60 @@
diff -Nru q4wine-1.3.7-orig/src/q4wine-cli/CMakeLists.txt q4wine-1.3.7/src/q4wine-cli/CMakeLists.txt
--- q4wine-1.3.7-orig/src/q4wine-cli/CMakeLists.txt 2018-04-26 23:21:32.000000000 +0200
+++ q4wine-1.3.7/src/q4wine-cli/CMakeLists.txt 2018-08-07 11:00:09.303761989 +0200
@@ -34,7 +34,7 @@
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES FreeBSD)
if(QT5 MATCHES ON)
- qt5_use_modules(q4wine-cli Core DBus Network Sql Widgets Xml)
+ target_link_libraries(q4wine-cli Qt5::Core Qt5::DBus Qt5::Network Qt5::Sql Qt5::Widgets Qt5::Xml)
target_link_libraries(q4wine-cli q4wine-core ${BSD_LIBS})
else(QT5 MATCHES ON)
TARGET_LINK_LIBRARIES( q4wine-cli ${QT_LIBRARIES} q4wine-core ${BSD_LIBS})
diff -Nru q4wine-1.3.7-orig/src/q4wine-gui/CMakeLists.txt q4wine-1.3.7/src/q4wine-gui/CMakeLists.txt
--- q4wine-1.3.7-orig/src/q4wine-gui/CMakeLists.txt 2018-04-26 23:21:32.000000000 +0200
+++ q4wine-1.3.7/src/q4wine-gui/CMakeLists.txt 2018-08-07 11:01:17.565356435 +0200
@@ -209,7 +209,7 @@
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES FreeBSD)
if (QT5 MATCHES ON)
- qt5_use_modules(q4wine Core DBus Network Sql Widgets Xml)
+ target_link_libraries(q4wine Qt5::Core Qt5::DBus Qt5::Network Qt5::Sql Qt5::Widgets Qt5::Xml)
target_link_libraries(q4wine q4wine-core ${BSD_LIBS} ${QTSINGLEAPPLIB})
else (QT5 MATCHES ON)
TARGET_LINK_LIBRARIES( q4wine ${QT_LIBRARIES} q4wine-core ${BSD_LIBS} ${QTSINGLEAPPLIB})
diff -Nru q4wine-1.3.7-orig/src/q4wine-helper/CMakeLists.txt q4wine-1.3.7/src/q4wine-helper/CMakeLists.txt
--- q4wine-1.3.7-orig/src/q4wine-helper/CMakeLists.txt 2018-04-26 23:21:32.000000000 +0200
+++ q4wine-1.3.7/src/q4wine-helper/CMakeLists.txt 2018-08-07 11:01:57.501313010 +0200
@@ -60,7 +60,7 @@
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES FreeBSD)
if(QT5 MATCHES ON)
- qt5_use_modules(q4wine-helper Core DBus Network Sql Widgets Xml)
+ target_link_libraries(q4wine-helper Qt5::Core Qt5::DBus Qt5::Network Qt5::Sql Qt5::Widgets Qt5::Xml)
target_link_libraries(q4wine-helper q4wine-core ${BSD_LIBS})
else(QT5 MATCHES ON)
TARGET_LINK_LIBRARIES( q4wine-helper ${QT_LIBRARIES} q4wine-core ${BSD_LIBS})
diff -Nru q4wine-1.3.7-orig/src/q4wine-lib/CMakeLists.txt q4wine-1.3.7/src/q4wine-lib/CMakeLists.txt
--- q4wine-1.3.7-orig/src/q4wine-lib/CMakeLists.txt 2018-04-26 23:21:32.000000000 +0200
+++ q4wine-1.3.7/src/q4wine-lib/CMakeLists.txt 2018-08-07 11:02:51.324627183 +0200
@@ -85,7 +85,7 @@
ENDIF( ${CMAKE_SYSTEM_NAME} MATCHES Darwin )
if(QT5 MATCHES ON)
- qt5_use_modules(q4wine-core Core DBus Network Sql Widgets Xml)
+ target_link_libraries(q4wine-core Qt5::Core Qt5::DBus Qt5::Network Qt5::Sql Qt5::Widgets Qt5::Xml)
else(QT5 MATCHES ON)
target_link_libraries( q4wine-core ${QT_LIBRARIES})
endif(QT5 MATCHES ON)
diff -Nru q4wine-1.3.7-orig/src/qtsingleapplication/CMakeLists.txt q4wine-1.3.7/src/qtsingleapplication/CMakeLists.txt
--- q4wine-1.3.7-orig/src/qtsingleapplication/CMakeLists.txt 2018-04-26 23:21:32.000000000 +0200
+++ q4wine-1.3.7/src/qtsingleapplication/CMakeLists.txt 2018-08-07 11:08:01.558636121 +0200
@@ -23,5 +23,5 @@
ADD_LIBRARY( qtsingleapp STATIC ${QSINGLEAPP_LIB_SOURCES} ${QSINGLEAPP_LIB_HEADERS} ${QTSINGLEAPPLICATION-LIB-MOC-SRCS} )
if(QT5 MATCHES ON)
- qt5_use_modules(qtsingleapp Core Network Widgets)
-endif(QT5 MATCHES ON)
\ No newline at end of file
+ target_link_libraries(qtsingleapp Qt5::Core Qt5::Network Qt5::Widgets)
+endif(QT5 MATCHES ON)

View File

@ -1,6 +1,6 @@
%define pkgver %(echo %version | tr _ -)
Name: q4wine
Version: 1.3.6
Version: 1.3.7
Release: 1mamba
Summary: Q4Wine is a qt4 GUI for wine.
Summary(it): Q4Wine è un interfaccia grafica per wine
@ -13,16 +13,18 @@ Source: http://downloads.sourceforge.net/project/q4wine/q4wine/q4wine%20%
#Source1: it_it.ts
#Source2: q4wine.desktop
#Source3: en_us.ts
Patch0: q4wine-1.3.7-qt5.11.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libqt4-devel
BuildRequires: libqt5-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: cmake
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: icoutils
BuildRequires: fuseiso
Requires: wine
Requires: icoutils
Requires: fuseiso
@ -60,10 +62,11 @@ Q4Wine è un'interfaccia grafica per wine. Permette di gestire i prefissi di win
#cp %{SOURCE1} src/i18n/
#cp %{SOURCE3} src/i18n/
#cp %{SOURCE2} ./
#%patch -p1
%patch -p1
%build
cmake -d build -DWITH_WINETRIKS=ON -DWITH_APPSDB=ON -DWITH_EMBEDDED_FUSEISO=ON -DCMAKE_INSTALL_PREFIX=/usr .
#cmake -d build -DWITH_WINETRIKS=ON -DWITH_APPSDB=ON -DWITH_EMBEDDED_FUSEISO=ON -DCMAKE_INSTALL_PREFIX=/usr .
cmake -d build -DWITH_WINETRIKS=ON -DWITH_APPSDB=ON -DCMAKE_INSTALL_PREFIX=/usr .
%make
%install
@ -97,6 +100,9 @@ rm -rf %{buildroot}%{_datadir}/icons/ubuntu-mono-dark
%doc COPYING
%changelog
* Sun Jul 08 2018 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 1.3.7-1mamba
- update to 1.3.7
* Fri Oct 27 2017 Automatic Build System <autodist@mambasoft.it> 1.3.6-1mamba
- automatic version update by autodist