x86_64: fixed patch to support both lib64 and lib sitelib dir [release 3.7.4-5mamba;Wed Aug 28 2019]
This commit is contained in:
parent
5fc7c7615e
commit
847e435a2e
@ -1,6 +1,6 @@
|
||||
diff -ru Python-3.7.3.orig/Lib/distutils/command/install.py Python-3.7.3/Lib/distutils/command/install.py
|
||||
--- Python-3.7.3.orig/Lib/distutils/command/install.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/distutils/command/install.py 2019-03-30 16:51:16.484130678 +0100
|
||||
diff -ru Python-3.7.4.orig/Lib/distutils/command/install.py Python-3.7.4/Lib/distutils/command/install.py
|
||||
--- Python-3.7.4.orig/Lib/distutils/command/install.py 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/Lib/distutils/command/install.py 2019-08-28 15:52:48.373000000 +0200
|
||||
@@ -30,14 +30,14 @@
|
||||
INSTALL_SCHEMES = {
|
||||
'unix_prefix': {
|
||||
@ -18,10 +18,10 @@ diff -ru Python-3.7.3.orig/Lib/distutils/command/install.py Python-3.7.3/Lib/dis
|
||||
'headers': '$base/include/python/$dist_name',
|
||||
'scripts': '$base/bin',
|
||||
'data' : '$base',
|
||||
diff -ru Python-3.7.3.orig/Lib/distutils/sysconfig.py Python-3.7.3/Lib/distutils/sysconfig.py
|
||||
--- Python-3.7.3.orig/Lib/distutils/sysconfig.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/distutils/sysconfig.py 2019-03-30 16:51:16.485130682 +0100
|
||||
@@ -142,8 +142,12 @@
|
||||
diff -ru Python-3.7.4.orig/Lib/distutils/sysconfig.py Python-3.7.4/Lib/distutils/sysconfig.py
|
||||
--- Python-3.7.4.orig/Lib/distutils/sysconfig.py 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/Lib/distutils/sysconfig.py 2019-08-28 15:52:48.377000000 +0200
|
||||
@@ -147,8 +147,12 @@
|
||||
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
||||
|
||||
if os.name == "posix":
|
||||
@ -35,30 +35,28 @@ diff -ru Python-3.7.3.orig/Lib/distutils/sysconfig.py Python-3.7.3/Lib/distutils
|
||||
if standard_lib:
|
||||
return libpython
|
||||
else:
|
||||
Only in Python-3.7.3/Lib/distutils: sysconfig.py.orig
|
||||
diff -ru Python-3.7.3.orig/Lib/site.py Python-3.7.3/Lib/site.py
|
||||
--- Python-3.7.3.orig/Lib/site.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/site.py 2019-03-30 16:52:17.370361477 +0100
|
||||
@@ -334,12 +334,12 @@
|
||||
diff -ru Python-3.7.4.orig/Lib/site.py Python-3.7.4/Lib/site.py
|
||||
--- Python-3.7.4.orig/Lib/site.py 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/Lib/site.py 2019-08-28 15:54:01.948000000 +0200
|
||||
@@ -334,11 +334,15 @@
|
||||
seen.add(prefix)
|
||||
|
||||
if os.sep == '/':
|
||||
- sitepackages.append(os.path.join(prefix, "lib",
|
||||
+ sitepackages.append(os.path.join(prefix, "lib64",
|
||||
+ "python%d.%d" % sys.version_info[:2],
|
||||
+ "site-packages"))
|
||||
sitepackages.append(os.path.join(prefix, "lib",
|
||||
"python%d.%d" % sys.version_info[:2],
|
||||
"site-packages"))
|
||||
else:
|
||||
sitepackages.append(prefix)
|
||||
- sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
||||
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
||||
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
||||
return sitepackages
|
||||
|
||||
def addsitepackages(known_paths, prefixes=None):
|
||||
Only in Python-3.7.3/Lib: site.py.orig
|
||||
Only in Python-3.7.3/Lib: site.py.rej
|
||||
diff -ru Python-3.7.3.orig/Lib/sysconfig.py Python-3.7.3/Lib/sysconfig.py
|
||||
--- Python-3.7.3.orig/Lib/sysconfig.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/sysconfig.py 2019-03-30 16:51:16.485130682 +0100
|
||||
diff -ru Python-3.7.4.orig/Lib/sysconfig.py Python-3.7.4/Lib/sysconfig.py
|
||||
--- Python-3.7.4.orig/Lib/sysconfig.py 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/Lib/sysconfig.py 2019-08-28 15:52:48.380000000 +0200
|
||||
@@ -20,10 +20,10 @@
|
||||
|
||||
_INSTALL_SCHEMES = {
|
||||
@ -87,10 +85,9 @@ diff -ru Python-3.7.3.orig/Lib/sysconfig.py Python-3.7.3/Lib/sysconfig.py
|
||||
'include': '{userbase}/include/python{py_version_short}',
|
||||
'scripts': '{userbase}/bin',
|
||||
'data': '{userbase}',
|
||||
Only in Python-3.7.3/Lib: sysconfig.py.orig
|
||||
diff -ru Python-3.7.3.orig/Lib/test/test_site.py Python-3.7.3/Lib/test/test_site.py
|
||||
--- Python-3.7.3.orig/Lib/test/test_site.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/test/test_site.py 2019-03-30 16:51:16.486130686 +0100
|
||||
diff -ru Python-3.7.4.orig/Lib/test/test_site.py Python-3.7.4/Lib/test/test_site.py
|
||||
--- Python-3.7.4.orig/Lib/test/test_site.py 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/Lib/test/test_site.py 2019-08-28 15:52:48.380000000 +0200
|
||||
@@ -270,7 +270,7 @@
|
||||
if os.sep == '/':
|
||||
# OS X, Linux, FreeBSD, etc
|
||||
@ -109,11 +106,10 @@ diff -ru Python-3.7.3.orig/Lib/test/test_site.py Python-3.7.3/Lib/test/test_site
|
||||
self.assertEqual(dirs[1], wanted)
|
||||
|
||||
def test_no_home_directory(self):
|
||||
Only in Python-3.7.3/Lib/test: test_site.py.orig
|
||||
diff -ru Python-3.7.3.orig/Makefile.pre.in Python-3.7.3/Makefile.pre.in
|
||||
--- Python-3.7.3.orig/Makefile.pre.in 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Makefile.pre.in 2019-03-30 16:51:16.486130686 +0100
|
||||
@@ -142,7 +142,7 @@
|
||||
diff -ru Python-3.7.4.orig/Makefile.pre.in Python-3.7.4/Makefile.pre.in
|
||||
--- Python-3.7.4.orig/Makefile.pre.in 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/Makefile.pre.in 2019-08-28 15:52:48.381000000 +0200
|
||||
@@ -144,7 +144,7 @@
|
||||
MANDIR= @mandir@
|
||||
INCLUDEDIR= @includedir@
|
||||
CONFINCLUDEDIR= $(exec_prefix)/include
|
||||
@ -122,10 +118,9 @@ diff -ru Python-3.7.3.orig/Makefile.pre.in Python-3.7.3/Makefile.pre.in
|
||||
ABIFLAGS= @ABIFLAGS@
|
||||
|
||||
# Detailed destination directories
|
||||
Only in Python-3.7.3: Makefile.pre.in.orig
|
||||
diff -ru Python-3.7.3.orig/Modules/getpath.c Python-3.7.3/Modules/getpath.c
|
||||
--- Python-3.7.3.orig/Modules/getpath.c 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Modules/getpath.c 2019-03-30 16:54:33.220886416 +0100
|
||||
diff -ru Python-3.7.4.orig/Modules/getpath.c Python-3.7.4/Modules/getpath.c
|
||||
--- Python-3.7.4.orig/Modules/getpath.c 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/Modules/getpath.c 2019-08-28 15:52:48.382000000 +0200
|
||||
@@ -787,7 +787,7 @@
|
||||
else {
|
||||
wcsncpy(calculate->zip_path, calculate->prefix, MAXPATHLEN);
|
||||
@ -144,12 +139,10 @@ diff -ru Python-3.7.3.orig/Modules/getpath.c Python-3.7.3/Modules/getpath.c
|
||||
if (!calculate->lib_python) {
|
||||
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
|
||||
}
|
||||
Only in Python-3.7.3/Modules: getpath.c.orig
|
||||
Only in Python-3.7.3/Modules: getpath.c.rej
|
||||
diff -ru Python-3.7.3.orig/setup.py Python-3.7.3/setup.py
|
||||
--- Python-3.7.3.orig/setup.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/setup.py 2019-03-30 16:56:03.735242523 +0100
|
||||
@@ -546,7 +546,7 @@
|
||||
diff -ru Python-3.7.4.orig/setup.py Python-3.7.4/setup.py
|
||||
--- Python-3.7.4.orig/setup.py 2019-07-08 20:03:50.000000000 +0200
|
||||
+++ Python-3.7.4/setup.py 2019-08-28 15:52:48.384000000 +0200
|
||||
@@ -585,7 +585,7 @@
|
||||
# directories (i.e. '.' and 'Include') must be first. See issue
|
||||
# 10520.
|
||||
if not cross_compiling:
|
||||
@ -158,5 +151,3 @@ diff -ru Python-3.7.3.orig/setup.py Python-3.7.3/setup.py
|
||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||
# only change this for cross builds for 3.3, issues on Mageia
|
||||
if cross_compiling:
|
||||
Only in Python-3.7.3: setup.py.orig
|
||||
Only in Python-3.7.3: setup.py.rej
|
15
python3.spec
15
python3.spec
@ -4,7 +4,7 @@
|
||||
%define __libdir %{_libdir}
|
||||
Name: python3
|
||||
Version: 3.7.4
|
||||
Release: 4mamba
|
||||
Release: 5mamba
|
||||
Summary: An interpreted, interactive, object-oriented programming language
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
@ -17,7 +17,7 @@ Source2: pythondeps3.sh
|
||||
Patch0: python-2.4.2-tex3-fix.patch
|
||||
Patch1: python-2.4.2-cgi.patch
|
||||
Patch2: python-2.7.3-use_system_Sphinx.patch
|
||||
Patch3: python3-3.7.3-lib64.patch
|
||||
Patch3: python3-3.7.4-lib64.patch
|
||||
License: GPL
|
||||
BuildRequires: glibc-devel >= 2.3.5
|
||||
BuildRequires: libbluez-devel >= 2.21
|
||||
@ -40,7 +40,7 @@ BuildRequires: latex2html >= 2002
|
||||
BuildRequires: tetex >= 3.0
|
||||
BuildRequires: libtk >= 8.4.11
|
||||
%endif
|
||||
Requires: %{libname} = %{version}
|
||||
Requires: %{libname} = %{version}-%{release}
|
||||
Provides: python-abi = %{majversion}
|
||||
Provides: python(abi) = %{majversion}
|
||||
Provides: /usr/bin/python
|
||||
@ -70,8 +70,8 @@ This package contains the libraries for Python.
|
||||
%package -n %{libname}-devel
|
||||
Group: Development/Libraries/Python
|
||||
Summary: Devel package for Python
|
||||
Requires: %{libname} = %{version}
|
||||
Provides: %{name}-devel = %{version}
|
||||
Requires: %{libname} = %{version}-%{release}
|
||||
Provides: %{name}-devel = %{version}-%{release}
|
||||
Obsoletes: %{name}-devel
|
||||
|
||||
%description -n %{libname}-devel
|
||||
@ -100,7 +100,7 @@ This package contains the documentation files for Python in HTML format.
|
||||
%package tk
|
||||
Group: System/Libraries/Python
|
||||
Summary: Tk library for Python
|
||||
Requires: %{name} = %{version}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description tk
|
||||
Python is an interpreted, interactive, object-oriented programming language. It is often compared to Tcl, Perl, Scheme or Java.
|
||||
@ -255,6 +255,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Aug 28 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.7.4-5mamba
|
||||
- x86_64: fixed patch to support both lib64 and lib sitelib dir
|
||||
|
||||
* Thu Aug 08 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.7.4-4mamba
|
||||
- fix installation name of pythondeps3.sh
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user