fix installation name of pythondeps3.sh [release 3.7.4-4mamba;Thu Aug 08 2019]
This commit is contained in:
parent
d8a4685f55
commit
5fc7c7615e
@ -1,200 +0,0 @@
|
||||
diff -up cpython-59223da36dec/Lib/distutils/command/install.py.lib64 cpython-59223da36dec/Lib/distutils/command/install.py
|
||||
--- cpython-59223da36dec/Lib/distutils/command/install.py.lib64 2012-08-07 06:10:57.000000000 -0400
|
||||
+++ cpython-59223da36dec/Lib/distutils/command/install.py 2012-08-07 16:41:00.573477549 -0400
|
||||
@@ -45,14 +45,14 @@ else:
|
||||
INSTALL_SCHEMES = {
|
||||
'unix_prefix': {
|
||||
'purelib': '$base/lib/python$py_version_short/site-packages',
|
||||
- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
|
||||
+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
|
||||
'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
|
||||
'scripts': '$base/bin',
|
||||
'data' : '$base',
|
||||
},
|
||||
'unix_home': {
|
||||
'purelib': '$base/lib/python',
|
||||
- 'platlib': '$base/lib/python',
|
||||
+ 'platlib': '$base/lib64/python',
|
||||
'headers': '$base/include/python/$dist_name',
|
||||
'scripts': '$base/bin',
|
||||
'data' : '$base',
|
||||
diff -up cpython-59223da36dec/Lib/distutils/sysconfig.py.lib64 cpython-59223da36dec/Lib/distutils/sysconfig.py
|
||||
--- cpython-59223da36dec/Lib/distutils/sysconfig.py.lib64 2012-08-07 06:10:57.000000000 -0400
|
||||
+++ cpython-59223da36dec/Lib/distutils/sysconfig.py 2012-08-07 16:41:00.573477549 -0400
|
||||
@@ -139,8 +139,12 @@ def get_python_lib(plat_specific=0, stan
|
||||
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
||||
|
||||
if os.name == "posix":
|
||||
+ if plat_specific or standard_lib:
|
||||
+ lib = "lib64"
|
||||
+ else:
|
||||
+ lib = "lib"
|
||||
libpython = os.path.join(prefix,
|
||||
- "lib", "python" + get_python_version())
|
||||
+ lib, "python" + get_python_version())
|
||||
if standard_lib:
|
||||
return libpython
|
||||
else:
|
||||
diff -up cpython-59223da36dec/Lib/site.py.lib64 cpython-59223da36dec/Lib/site.py
|
||||
--- cpython-59223da36dec/Lib/site.py.lib64 2012-08-07 06:10:57.000000000 -0400
|
||||
+++ cpython-59223da36dec/Lib/site.py 2012-08-07 16:41:00.573477549 -0400
|
||||
@@ -303,12 +303,16 @@ def getsitepackages(prefixes=None):
|
||||
if sys.platform in ('os2emx', 'riscos'):
|
||||
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
||||
elif os.sep == '/':
|
||||
+ sitepackages.append(os.path.join(prefix, "lib64",
|
||||
+ "python" + sys.version[:3],
|
||||
+ "site-packages"))
|
||||
sitepackages.append(os.path.join(prefix, "lib",
|
||||
"python" + sys.version[:3],
|
||||
"site-packages"))
|
||||
sitepackages.append(os.path.join(prefix, "lib", "site-python"))
|
||||
else:
|
||||
sitepackages.append(prefix)
|
||||
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
||||
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
||||
if sys.platform == "darwin":
|
||||
# for framework builds *only* we add the standard Apple
|
||||
diff -up cpython-59223da36dec/Lib/sysconfig.py.lib64 cpython-59223da36dec/Lib/sysconfig.py
|
||||
--- cpython-59223da36dec/Lib/sysconfig.py.lib64 2012-08-07 06:10:57.000000000 -0400
|
||||
+++ cpython-59223da36dec/Lib/sysconfig.py 2012-08-07 16:41:00.574477549 -0400
|
||||
@@ -21,10 +21,10 @@ __all__ = [
|
||||
|
||||
_INSTALL_SCHEMES = {
|
||||
'posix_prefix': {
|
||||
- 'stdlib': '{installed_base}/lib/python{py_version_short}',
|
||||
- 'platstdlib': '{platbase}/lib/python{py_version_short}',
|
||||
+ 'stdlib': '{installed_base}/lib64/python{py_version_short}',
|
||||
+ 'platstdlib': '{platbase}/lib64/python{py_version_short}',
|
||||
'purelib': '{base}/lib/python{py_version_short}/site-packages',
|
||||
- 'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
|
||||
+ 'platlib': '{platbase}/lib64/python{py_version_short}/site-packages',
|
||||
'include':
|
||||
'{installed_base}/include/python{py_version_short}{abiflags}',
|
||||
'platinclude':
|
||||
@@ -81,10 +81,10 @@ _INSTALL_SCHEMES = {
|
||||
'data': '{userbase}',
|
||||
},
|
||||
'posix_user': {
|
||||
- 'stdlib': '{userbase}/lib/python{py_version_short}',
|
||||
- 'platstdlib': '{userbase}/lib/python{py_version_short}',
|
||||
+ 'stdlib': '{userbase}/lib64/python{py_version_short}',
|
||||
+ 'platstdlib': '{userbase}/lib64/python{py_version_short}',
|
||||
'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
|
||||
- 'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
|
||||
+ 'platlib': '{userbase}/lib64/python{py_version_short}/site-packages',
|
||||
'include': '{userbase}/include/python{py_version_short}',
|
||||
'scripts': '{userbase}/bin',
|
||||
'data': '{userbase}',
|
||||
diff -up cpython-59223da36dec/Lib/test/test_site.py.lib64 cpython-59223da36dec/Lib/test/test_site.py
|
||||
--- cpython-59223da36dec/Lib/test/test_site.py.lib64 2012-08-07 06:10:57.000000000 -0400
|
||||
+++ cpython-59223da36dec/Lib/test/test_site.py 2012-08-07 16:41:00.574477549 -0400
|
||||
@@ -239,12 +239,15 @@ class HelperFunctionsTests(unittest.Test
|
||||
self.assertEqual(dirs[2], wanted)
|
||||
elif os.sep == '/':
|
||||
# OS X non-framwework builds, Linux, FreeBSD, etc
|
||||
- self.assertEqual(len(dirs), 2)
|
||||
- wanted = os.path.join('xoxo', 'lib', 'python' + sys.version[:3],
|
||||
+ self.assertEqual(len(dirs), 3)
|
||||
+ wanted = os.path.join('xoxo', 'lib64', 'python' + sys.version[:3],
|
||||
'site-packages')
|
||||
self.assertEqual(dirs[0], wanted)
|
||||
- wanted = os.path.join('xoxo', 'lib', 'site-python')
|
||||
+ wanted = os.path.join('xoxo', 'lib', 'python' + sys.version[:3],
|
||||
+ 'site-packages')
|
||||
self.assertEqual(dirs[1], wanted)
|
||||
+ wanted = os.path.join('xoxo', 'lib', 'site-python')
|
||||
+ self.assertEqual(dirs[2], wanted)
|
||||
else:
|
||||
# other platforms
|
||||
self.assertEqual(len(dirs), 2)
|
||||
diff -up cpython-59223da36dec/Makefile.pre.in.lib64 cpython-59223da36dec/Makefile.pre.in
|
||||
--- cpython-59223da36dec/Makefile.pre.in.lib64 2012-08-07 16:41:00.557477550 -0400
|
||||
+++ cpython-59223da36dec/Makefile.pre.in 2012-08-07 16:41:00.575477549 -0400
|
||||
@@ -108,7 +108,7 @@ LIBDIR= @libdir@
|
||||
MANDIR= @mandir@
|
||||
INCLUDEDIR= @includedir@
|
||||
CONFINCLUDEDIR= $(exec_prefix)/include
|
||||
-SCRIPTDIR= $(prefix)/lib
|
||||
+SCRIPTDIR= $(prefix)/lib64
|
||||
ABIFLAGS= @ABIFLAGS@
|
||||
|
||||
# Detailed destination directories
|
||||
diff -up cpython-59223da36dec/Modules/getpath.c.lib64 cpython-59223da36dec/Modules/getpath.c
|
||||
--- cpython-59223da36dec/Modules/getpath.c.lib64 2012-08-07 06:10:57.000000000 -0400
|
||||
+++ cpython-59223da36dec/Modules/getpath.c 2012-08-07 16:41:00.575477549 -0400
|
||||
@@ -122,8 +122,8 @@
|
||||
#endif
|
||||
|
||||
#ifndef PYTHONPATH
|
||||
-#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
|
||||
- EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
|
||||
+#define PYTHONPATH PREFIX "/lib64/python" VERSION ":" \
|
||||
+ EXEC_PREFIX "/lib64/python" VERSION "/lib-dynload"
|
||||
#endif
|
||||
|
||||
#ifndef LANDMARK
|
||||
@@ -135,7 +135,7 @@ static wchar_t exec_prefix[MAXPATHLEN+1]
|
||||
static wchar_t progpath[MAXPATHLEN+1];
|
||||
static wchar_t *module_search_path = NULL;
|
||||
static int module_search_path_malloced = 0;
|
||||
-static wchar_t *lib_python = L"lib/python" VERSION;
|
||||
+static wchar_t *lib_python = L"lib64/python" VERSION;
|
||||
|
||||
static void
|
||||
reduce(wchar_t *dir)
|
||||
@@ -677,7 +677,7 @@ calculate_path(void)
|
||||
}
|
||||
else
|
||||
wcsncpy(zip_path, _prefix, MAXPATHLEN);
|
||||
- joinpath(zip_path, L"lib/python00.zip");
|
||||
+ joinpath(zip_path, L"lib64/python00.zip");
|
||||
bufsz = wcslen(zip_path); /* Replace "00" with version */
|
||||
zip_path[bufsz - 6] = VERSION[0];
|
||||
zip_path[bufsz - 5] = VERSION[2];
|
||||
@@ -687,7 +687,7 @@ calculate_path(void)
|
||||
fprintf(stderr,
|
||||
"Could not find platform dependent libraries <exec_prefix>\n");
|
||||
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
|
||||
- joinpath(exec_prefix, L"lib/lib-dynload");
|
||||
+ joinpath(exec_prefix, L"lib64/lib-dynload");
|
||||
}
|
||||
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
||||
|
||||
diff -up cpython-59223da36dec/setup.py.lib64 cpython-59223da36dec/setup.py
|
||||
--- cpython-59223da36dec/setup.py.lib64 2012-08-07 06:10:57.000000000 -0400
|
||||
+++ cpython-59223da36dec/setup.py 2012-08-07 16:41:32.153475390 -0400
|
||||
@@ -438,7 +438,7 @@ class PyBuildExt(build_ext):
|
||||
# directories (i.e. '.' and 'Include') must be first. See issue
|
||||
# 10520.
|
||||
if not cross_compiling:
|
||||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
||||
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||
# only change this for cross builds for 3.3, issues on Mageia
|
||||
if cross_compiling:
|
||||
@@ -708,11 +708,11 @@ class PyBuildExt(build_ext):
|
||||
elif curses_library:
|
||||
readline_libs.append(curses_library)
|
||||
elif self.compiler.find_library_file(lib_dirs +
|
||||
- ['/usr/lib/termcap'],
|
||||
+ ['/usr/lib64/termcap'],
|
||||
'termcap'):
|
||||
readline_libs.append('termcap')
|
||||
exts.append( Extension('readline', ['readline.c'],
|
||||
- library_dirs=['/usr/lib/termcap'],
|
||||
+ library_dirs=['/usr/lib64/termcap'],
|
||||
extra_link_args=readline_extra_link_args,
|
||||
libraries=readline_libs) )
|
||||
else:
|
||||
@@ -749,8 +749,8 @@ class PyBuildExt(build_ext):
|
||||
if krb5_h:
|
||||
ssl_incs += krb5_h
|
||||
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
||||
- ['/usr/local/ssl/lib',
|
||||
- '/usr/contrib/ssl/lib/'
|
||||
+ ['/usr/local/ssl/lib64',
|
||||
+ '/usr/contrib/ssl/lib64/'
|
||||
] )
|
||||
|
||||
if (ssl_incs is not None and
|
162
python3-3.7.3-lib64.patch
Normal file
162
python3-3.7.3-lib64.patch
Normal file
@ -0,0 +1,162 @@
|
||||
diff -ru Python-3.7.3.orig/Lib/distutils/command/install.py Python-3.7.3/Lib/distutils/command/install.py
|
||||
--- Python-3.7.3.orig/Lib/distutils/command/install.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/distutils/command/install.py 2019-03-30 16:51:16.484130678 +0100
|
||||
@@ -30,14 +30,14 @@
|
||||
INSTALL_SCHEMES = {
|
||||
'unix_prefix': {
|
||||
'purelib': '$base/lib/python$py_version_short/site-packages',
|
||||
- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
|
||||
+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
|
||||
'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
|
||||
'scripts': '$base/bin',
|
||||
'data' : '$base',
|
||||
},
|
||||
'unix_home': {
|
||||
'purelib': '$base/lib/python',
|
||||
- 'platlib': '$base/lib/python',
|
||||
+ 'platlib': '$base/lib64/python',
|
||||
'headers': '$base/include/python/$dist_name',
|
||||
'scripts': '$base/bin',
|
||||
'data' : '$base',
|
||||
diff -ru Python-3.7.3.orig/Lib/distutils/sysconfig.py Python-3.7.3/Lib/distutils/sysconfig.py
|
||||
--- Python-3.7.3.orig/Lib/distutils/sysconfig.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/distutils/sysconfig.py 2019-03-30 16:51:16.485130682 +0100
|
||||
@@ -142,8 +142,12 @@
|
||||
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
||||
|
||||
if os.name == "posix":
|
||||
+ if plat_specific or standard_lib:
|
||||
+ lib = "lib64"
|
||||
+ else:
|
||||
+ lib = "lib"
|
||||
libpython = os.path.join(prefix,
|
||||
- "lib", "python" + get_python_version())
|
||||
+ lib, "python" + get_python_version())
|
||||
if standard_lib:
|
||||
return libpython
|
||||
else:
|
||||
Only in Python-3.7.3/Lib/distutils: sysconfig.py.orig
|
||||
diff -ru Python-3.7.3.orig/Lib/site.py Python-3.7.3/Lib/site.py
|
||||
--- Python-3.7.3.orig/Lib/site.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/site.py 2019-03-30 16:52:17.370361477 +0100
|
||||
@@ -334,12 +334,12 @@
|
||||
seen.add(prefix)
|
||||
|
||||
if os.sep == '/':
|
||||
- sitepackages.append(os.path.join(prefix, "lib",
|
||||
+ sitepackages.append(os.path.join(prefix, "lib64",
|
||||
"python%d.%d" % sys.version_info[:2],
|
||||
"site-packages"))
|
||||
else:
|
||||
sitepackages.append(prefix)
|
||||
- sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
||||
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
||||
return sitepackages
|
||||
|
||||
def addsitepackages(known_paths, prefixes=None):
|
||||
Only in Python-3.7.3/Lib: site.py.orig
|
||||
Only in Python-3.7.3/Lib: site.py.rej
|
||||
diff -ru Python-3.7.3.orig/Lib/sysconfig.py Python-3.7.3/Lib/sysconfig.py
|
||||
--- Python-3.7.3.orig/Lib/sysconfig.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/sysconfig.py 2019-03-30 16:51:16.485130682 +0100
|
||||
@@ -20,10 +20,10 @@
|
||||
|
||||
_INSTALL_SCHEMES = {
|
||||
'posix_prefix': {
|
||||
- 'stdlib': '{installed_base}/lib/python{py_version_short}',
|
||||
- 'platstdlib': '{platbase}/lib/python{py_version_short}',
|
||||
+ 'stdlib': '{installed_base}/lib64/python{py_version_short}',
|
||||
+ 'platstdlib': '{platbase}/lib64/python{py_version_short}',
|
||||
'purelib': '{base}/lib/python{py_version_short}/site-packages',
|
||||
- 'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
|
||||
+ 'platlib': '{platbase}/lib64/python{py_version_short}/site-packages',
|
||||
'include':
|
||||
'{installed_base}/include/python{py_version_short}{abiflags}',
|
||||
'platinclude':
|
||||
@@ -62,10 +62,10 @@
|
||||
'data': '{userbase}',
|
||||
},
|
||||
'posix_user': {
|
||||
- 'stdlib': '{userbase}/lib/python{py_version_short}',
|
||||
- 'platstdlib': '{userbase}/lib/python{py_version_short}',
|
||||
+ 'stdlib': '{userbase}/lib64/python{py_version_short}',
|
||||
+ 'platstdlib': '{userbase}/lib64/python{py_version_short}',
|
||||
'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
|
||||
- 'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
|
||||
+ 'platlib': '{userbase}/lib64/python{py_version_short}/site-packages',
|
||||
'include': '{userbase}/include/python{py_version_short}',
|
||||
'scripts': '{userbase}/bin',
|
||||
'data': '{userbase}',
|
||||
Only in Python-3.7.3/Lib: sysconfig.py.orig
|
||||
diff -ru Python-3.7.3.orig/Lib/test/test_site.py Python-3.7.3/Lib/test/test_site.py
|
||||
--- Python-3.7.3.orig/Lib/test/test_site.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Lib/test/test_site.py 2019-03-30 16:51:16.486130686 +0100
|
||||
@@ -270,7 +270,7 @@
|
||||
if os.sep == '/':
|
||||
# OS X, Linux, FreeBSD, etc
|
||||
self.assertEqual(len(dirs), 1)
|
||||
- wanted = os.path.join('xoxo', 'lib',
|
||||
+ wanted = os.path.join('xoxo', 'lib64',
|
||||
'python%d.%d' % sys.version_info[:2],
|
||||
'site-packages')
|
||||
self.assertEqual(dirs[0], wanted)
|
||||
@@ -278,7 +278,7 @@
|
||||
# other platforms
|
||||
self.assertEqual(len(dirs), 2)
|
||||
self.assertEqual(dirs[0], 'xoxo')
|
||||
- wanted = os.path.join('xoxo', 'lib', 'site-packages')
|
||||
+ wanted = os.path.join('xoxo', 'lib64', 'site-packages')
|
||||
self.assertEqual(dirs[1], wanted)
|
||||
|
||||
def test_no_home_directory(self):
|
||||
Only in Python-3.7.3/Lib/test: test_site.py.orig
|
||||
diff -ru Python-3.7.3.orig/Makefile.pre.in Python-3.7.3/Makefile.pre.in
|
||||
--- Python-3.7.3.orig/Makefile.pre.in 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Makefile.pre.in 2019-03-30 16:51:16.486130686 +0100
|
||||
@@ -142,7 +142,7 @@
|
||||
MANDIR= @mandir@
|
||||
INCLUDEDIR= @includedir@
|
||||
CONFINCLUDEDIR= $(exec_prefix)/include
|
||||
-SCRIPTDIR= $(prefix)/lib
|
||||
+SCRIPTDIR= $(prefix)/lib64
|
||||
ABIFLAGS= @ABIFLAGS@
|
||||
|
||||
# Detailed destination directories
|
||||
Only in Python-3.7.3: Makefile.pre.in.orig
|
||||
diff -ru Python-3.7.3.orig/Modules/getpath.c Python-3.7.3/Modules/getpath.c
|
||||
--- Python-3.7.3.orig/Modules/getpath.c 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/Modules/getpath.c 2019-03-30 16:54:33.220886416 +0100
|
||||
@@ -787,7 +787,7 @@
|
||||
else {
|
||||
wcsncpy(calculate->zip_path, calculate->prefix, MAXPATHLEN);
|
||||
}
|
||||
- joinpath(calculate->zip_path, L"lib/python00.zip");
|
||||
+ joinpath(calculate->zip_path, L"lib64/python00.zip");
|
||||
|
||||
/* Replace "00" with version */
|
||||
size_t bufsz = wcslen(calculate->zip_path);
|
||||
@@ -912,7 +912,7 @@
|
||||
if (!calculate->prefix) {
|
||||
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
|
||||
}
|
||||
- calculate->lib_python = Py_DecodeLocale("lib/python" VERSION, &len);
|
||||
+ calculate->lib_python = Py_DecodeLocale("lib64/python" VERSION, &len);
|
||||
if (!calculate->lib_python) {
|
||||
return DECODE_LOCALE_ERR("EXEC_PREFIX define", len);
|
||||
}
|
||||
Only in Python-3.7.3/Modules: getpath.c.orig
|
||||
Only in Python-3.7.3/Modules: getpath.c.rej
|
||||
diff -ru Python-3.7.3.orig/setup.py Python-3.7.3/setup.py
|
||||
--- Python-3.7.3.orig/setup.py 2019-03-25 21:21:05.000000000 +0100
|
||||
+++ Python-3.7.3/setup.py 2019-03-30 16:56:03.735242523 +0100
|
||||
@@ -546,7 +546,7 @@
|
||||
# directories (i.e. '.' and 'Include') must be first. See issue
|
||||
# 10520.
|
||||
if not cross_compiling:
|
||||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
||||
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||
# only change this for cross builds for 3.3, issues on Mageia
|
||||
if cross_compiling:
|
||||
Only in Python-3.7.3: setup.py.orig
|
||||
Only in Python-3.7.3: setup.py.rej
|
86
python3.spec
86
python3.spec
@ -3,8 +3,8 @@
|
||||
%define libname libpython3
|
||||
%define __libdir %{_libdir}
|
||||
Name: python3
|
||||
Version: 3.3.5
|
||||
Release: 1mamba
|
||||
Version: 3.7.4
|
||||
Release: 4mamba
|
||||
Summary: An interpreted, interactive, object-oriented programming language
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
@ -13,17 +13,18 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.python.org
|
||||
Source: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
|
||||
Source1: python-3.2-macros.python
|
||||
Source2: pythondeps3.sh
|
||||
Patch0: python-2.4.2-tex3-fix.patch
|
||||
Patch1: python-2.4.2-cgi.patch
|
||||
Patch2: python-2.7.3-use_system_Sphinx.patch
|
||||
Patch3: python3-3.3.3-lib64.patch
|
||||
Patch3: python3-3.7.3-lib64.patch
|
||||
License: GPL
|
||||
BuildRequires: glibc-devel >= 2.3.5
|
||||
BuildRequires: libbluez-devel >= 2.21
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libdb51-devel
|
||||
BuildRequires: libdb53-devel
|
||||
BuildRequires: libgdbm-devel
|
||||
BuildRequires: libncurses-devel >= 5.4
|
||||
BuildRequires: libopenssl-devel
|
||||
@ -43,6 +44,7 @@ Requires: %{libname} = %{version}
|
||||
Provides: python-abi = %{majversion}
|
||||
Provides: python(abi) = %{majversion}
|
||||
Provides: /usr/bin/python
|
||||
Provides: /usr/bin/python3
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -111,14 +113,17 @@ This package contains the tk library for Python.
|
||||
|
||||
%prep
|
||||
%setup -q -n Python-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
#%patch2 -p1
|
||||
%ifarch x86_64
|
||||
%patch3 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%configure \
|
||||
--libdir=%{__libdir} \
|
||||
--enable-ipv6 \
|
||||
@ -157,24 +162,39 @@ rm -f `find %{buildroot}%{_defaultdocdir}/%{name}-%{version}/html/.cvsignore`
|
||||
%endif
|
||||
rm -f `find %{buildroot}%{_docdir}/%{name}-%{version}/html/.buildinfo`
|
||||
install -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/rpm/macros.python3
|
||||
install -D -m0644 %{SOURCE2} %{buildroot}%{_prefix}/lib/rpm/pythondeps3.sh
|
||||
|
||||
rm %{buildroot}%{_includedir}/python
|
||||
rm %{buildroot}%{_bindir}/2to3
|
||||
rm %{buildroot}%{_bindir}/python3
|
||||
rm -f %{buildroot}%{_bindir}/pip3*
|
||||
rm -f %{buildroot}%{_bindir}/easy_install-3*
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
/usr/sbin/update-alternatives --install %{_bindir}/python python %{_bindir}/python%{majversion} 70
|
||||
/usr/sbin/update-alternatives --auto python
|
||||
if [ $1 -ge 1 ]; then
|
||||
/usr/sbin/update-alternatives --install %{_bindir}/python python %{_bindir}/python%{majversion} 72
|
||||
/usr/sbin/update-alternatives --install %{_bindir}/python3 python3 %{_bindir}/python%{majversion} 80
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
if [ $1 -eq 0 ]; then
|
||||
/usr/sbin/update-alternatives --remove python %{_bindir}/python%{majversion}
|
||||
/usr/sbin/update-alternatives --remove python %{_bindir}/python%{majversion}
|
||||
/usr/sbin/update-alternatives --remove python3 %{_bindir}/python%{majversion}
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%posttrans
|
||||
if [ $1 -ge 1 ]; then
|
||||
# fix missing link when upgrading the package which provided a real /usr/bin/python*
|
||||
[ -e %{_bindir}/python ] || /usr/sbin/update-alternatives --auto python
|
||||
[ -e %{_bindir}/python3 ] || /usr/sbin/update-alternatives --auto python3
|
||||
fi
|
||||
:
|
||||
|
||||
%post -n %{libname} -p /sbin/ldconfig
|
||||
%postun -n %{libname} -p /sbin/ldconfig
|
||||
|
||||
@ -187,7 +207,6 @@ exit 0
|
||||
%{_bindir}/pydoc%{majversion}
|
||||
%{_bindir}/pyvenv
|
||||
%{_bindir}/pyvenv-%{majversion}
|
||||
%{_bindir}/python3
|
||||
%{_bindir}/python%{majversion}m
|
||||
%{_bindir}/python%{majversion}
|
||||
%{_mandir}/man1/*
|
||||
@ -196,6 +215,10 @@ exit 0
|
||||
%defattr(-,root,root)
|
||||
%dir %{__libdir}/python%{majversion}
|
||||
%{__libdir}/python%{majversion}/*
|
||||
%ifarch x86_64
|
||||
%dir %{_prefix}/lib/python%{majversion}
|
||||
%{_prefix}/lib/python%{majversion}/*
|
||||
%endif
|
||||
%{_libdir}/libpython3.so
|
||||
%{_libdir}/libpython%{majversion}.so
|
||||
%{_libdir}/libpython%{majversion}m.so
|
||||
@ -211,9 +234,12 @@ exit 0
|
||||
%{_bindir}/python%{majversion}-config
|
||||
%{_bindir}/python%{majversion}m-config
|
||||
%{_includedir}/python%{majversion}m/*.h
|
||||
%dir %{_includedir}/python%{majversion}m/internal
|
||||
%{_includedir}/python%{majversion}m/internal/*.h
|
||||
%{_libdir}/pkgconfig/python-%{majversion}.pc
|
||||
%{_libdir}/pkgconfig/python-%{majversion}m.pc
|
||||
%{_libdir}/pkgconfig/python3.pc
|
||||
%{_prefix}/lib/rpm/pythondeps3.sh
|
||||
|
||||
%if "%{?bootstrap}" != "1"
|
||||
%files tk
|
||||
@ -229,6 +255,42 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Aug 08 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.7.4-4mamba
|
||||
- fix installation name of pythondeps3.sh
|
||||
|
||||
* Mon Aug 05 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.7.4-3mamba
|
||||
- add pythondeps3.sh file required by rpm macros.python3
|
||||
|
||||
* Mon Aug 05 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.7.4-2mamba
|
||||
- configure %{_bindir}/python3 as an alternative
|
||||
|
||||
* Thu Aug 01 2019 Automatic Build System <autodist@mambasoft.it> 3.7.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Apr 01 2019 Automatic Build System <autodist@mambasoft.it> 3.7.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jun 27 2016 Automatic Build System <autodist@mambasoft.it> 3.5.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Dec 07 2015 Automatic Build System <autodist@mambasoft.it> 3.5.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Sep 14 2015 Automatic Build System <autodist@mambasoft.it> 3.5.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Mar 01 2015 Automatic Build System <autodist@mambasoft.it> 3.4.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 09 2014 Automatic Build System <autodist@mambasoft.it> 3.4.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jun 28 2014 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 18 2014 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Mar 12 2014 Automatic Build System <autodist@mambasoft.it> 3.3.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
@ -299,10 +361,10 @@ exit 0
|
||||
* Thu Oct 02 2008 gil <puntogil@libero.it> 2.6-1mamba
|
||||
- update to 2.6
|
||||
|
||||
* Wed Jun 28 2008 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.5.2-1mamba
|
||||
* Sat Jun 28 2008 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.5.2-1mamba
|
||||
- update to 2.5.2.
|
||||
|
||||
* Sat Jun 25 2008 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.4.4-1mamba
|
||||
* Wed Jun 25 2008 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.4.4-1mamba
|
||||
- renamed to legacy python24 - changed doc to pdf due to a problem with latex2html
|
||||
|
||||
* Fri Mar 30 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.4-1mamba
|
||||
@ -342,7 +404,7 @@ exit 0
|
||||
- new version rebuild (bugfix release)
|
||||
- added the doc package with the Python documentation in HTML format
|
||||
|
||||
* Tue Dec 24 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.3-2qilnx
|
||||
* Wed Dec 24 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.3-2qilnx
|
||||
- renamed lib and includes destdir to /usr/include/python
|
||||
|
||||
* Tue Dec 23 2003 Davide Madrisan <davide.madrisan@qilinux.it> 2.3.3-1qilnx
|
||||
|
22
pythondeps3.sh
Normal file
22
pythondeps3.sh
Normal file
@ -0,0 +1,22 @@
|
||||
#!/bin/sh
|
||||
|
||||
[ $# -ge 1 ] || {
|
||||
cat > /dev/null
|
||||
exit 0
|
||||
}
|
||||
|
||||
PYVER=`python3 -c "import sys; v=sys.version_info[:2]; print ('%d.%d'%v)"`
|
||||
case $1 in
|
||||
-P|--provides)
|
||||
shift
|
||||
grep "/usr/lib[^/]*/libpython${PYVER}\..*\.so.*\$" >/dev/null && echo "python(abi) = ${PYVER}"
|
||||
exit 0
|
||||
;;
|
||||
-R|--requires)
|
||||
shift
|
||||
grep "/usr/\(lib[^/]*\|share\)/python${PYVER}/" >/dev/null && echo "python(abi) = ${PYVER}"
|
||||
exit 0
|
||||
;;
|
||||
esac
|
||||
|
||||
exit 0
|
Loading…
Reference in New Issue
Block a user