python27/python27-2.7.3-gcc-4.8.patch

63 lines
1.8 KiB
Diff

# HG changeset patch
# User Benjamin Peterson <benjamin@python.org>
# Date 1368295205 18000
# Node ID 94a7475d3a5f84d940121d059d145d504b4d996a
# Parent 0f8022ac88ad5a11ca9120d356615940d24a341d
-Wformat is needed by gcc 4.8 (closes #17547)
diff --git a/Misc/NEWS b/Misc/NEWS
--- a/Misc/NEWS
+++ b/Misc/NEWS
@@ -223,6 +223,12 @@ Documentation
- Issue #6696: add documentation for the Profile objects, and improve
profile/cProfile docs. Patch by Tom Pinckney.
+Build
+-----
+
+- Issue #17547: In configure, explicitly pass -Wformat for the benefit for GCC
+ 4.8.
+
What's New in Python 3.3.1?
===========================
diff --git a/configure b/configure
--- a/configure
+++ b/configure
@@ -6525,7 +6525,7 @@ then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether gcc supports ParseTuple __format__" >&5
$as_echo_n "checking whether gcc supports ParseTuple __format__... " >&6; }
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
diff --git a/configure.in b/configure.in
--- a/configure.in
+++ b/configure.in
@@ -1331,7 +1331,7 @@ if test "$GCC" = "yes"
then
AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
],[
diff --git a/pyconfig.h.in b/pyconfig.h.in
--- a/pyconfig.h.in
+++ b/pyconfig.h.in
@@ -1187,9 +1187,6 @@
/* Define if setpgrp() must be called as setpgrp(0, 0). */
#undef SETPGRP_HAVE_ARG
-/* Define this to be extension of shared libraries (including the dot!). */
-#undef SHLIB_EXT
-
/* Define if i>>j for signed int i does not extend the sign bit when i < 0 */
#undef SIGNED_RIGHT_SHIFT_ZERO_FILLS