update to 2.7.8 [release 2.7.8-1mamba;Sun Nov 23 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 16:58:20 +01:00
parent 3a570de24d
commit ceae24dc92
2 changed files with 20 additions and 19 deletions

View File

@ -128,19 +128,17 @@ diff -up Python-2.6.8/Modules/getpath.c.lib64 Python-2.6.8/Modules/getpath.c
# Interface to the Expat XML parser # Interface to the Expat XML parser
# #
diff -up Python-2.6.8/setup.py.lib64 Python-2.6.8/setup.py --- Python-2.7.8/setup.py.orig 2014-06-30 04:05:48.000000000 +0200
--- Python-2.6.8/setup.py.lib64 2012-04-12 13:23:24.657431631 -0400 +++ Python-2.7.8/setup.py 2014-11-23 18:08:31.091091727 +0100
+++ Python-2.6.8/setup.py 2012-04-12 13:23:24.935428157 -0400 @@ -439,6 +439,7 @@
@@ -356,7 +356,7 @@ class PyBuildExt(build_ext):
def detect_modules(self):
# Ensure that /usr/local is always used # Ensure that /usr/local is always used
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib') if not cross_compiling:
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64') + add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
# Add paths specified in the environment variables LDFLAGS and self.add_gcc_paths()
@@ -677,11 +677,11 @@ class PyBuildExt(build_ext): @@ -760,11 +761,11 @@
elif curses_library: elif curses_library:
readline_libs.append(curses_library) readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs + elif self.compiler.find_library_file(lib_dirs +
@ -154,7 +152,7 @@ diff -up Python-2.6.8/setup.py.lib64 Python-2.6.8/setup.py
extra_link_args=readline_extra_link_args, extra_link_args=readline_extra_link_args,
libraries=readline_libs) ) libraries=readline_libs) )
else: else:
@@ -703,8 +703,8 @@ class PyBuildExt(build_ext): @@ -799,8 +800,8 @@
if krb5_h: if krb5_h:
ssl_incs += krb5_h ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs, ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,

View File

@ -6,15 +6,15 @@
#% define __libdir %{_prefix}/lib #% define __libdir %{_prefix}/lib
%define __libdir %{_libdir} %define __libdir %{_libdir}
Name: python27 Name: python27
Version: 2.7.3 Version: 2.7.8
Release: 9mamba Release: 1mamba
Summary: An interpreted, interactive, object-oriented programming language Summary: An interpreted, interactive, object-oriented programming language
Group: Applications/Development Group: Applications/Development
Vendor: openmamba Vendor: openmamba
Distribution: openmamba Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.python.org URL: http://www.python.org
Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2 Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
Source1: python-2.7-macros.python Source1: python-2.7-macros.python
Source2: python-macros.python Source2: python-macros.python
Patch1: %{name}-2.7.3-cgi.patch Patch1: %{name}-2.7.3-cgi.patch
@ -25,7 +25,7 @@ Patch5: Python-2.6.5-xcompile.patch
Patch6: python-2.6.7-pkgconfig.patch Patch6: python-2.6.7-pkgconfig.patch
Patch7: python27-2.7.3-gcc-4.8.patch Patch7: python27-2.7.3-gcc-4.8.patch
Patch8: python-2.7.3-use_system_Sphinx.patch Patch8: python-2.7.3-use_system_Sphinx.patch
Patch9: python27-2.7.3-lib64.patch Patch9: python27-2.7.8-lib64.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -156,8 +156,8 @@ This package contains the tk library for Python.
%if "%{_host}" != "%{_build}" %if "%{_host}" != "%{_build}"
%patch5 -p1 %patch5 -p1
%endif %endif
%patch7 -p1 #%patch7 -p1
%patch8 -p1 #%patch8 -p1
%ifarch x86_64 %ifarch x86_64
%patch9 -p1 %patch9 -p1
%endif %endif
@ -359,6 +359,9 @@ exit 0
%endif %endif
%changelog %changelog
* Sun Nov 23 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.8-1mamba
- update to 2.7.8
* Sat Feb 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.3-9mamba * Sat Feb 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.3-9mamba
- move pyconfig.h and %{__libdir}/python/config from libpython27 to python27 - move pyconfig.h and %{__libdir}/python/config from libpython27 to python27