update to 2.7.15 [release 2.7.15-1mamba;Thu Sep 06 2018]
This commit is contained in:
parent
30b4819544
commit
189355e646
@ -1,7 +1,7 @@
|
||||
diff -up Python-2.6.8/Lib/distutils/command/install.py.lib64 Python-2.6.8/Lib/distutils/command/install.py
|
||||
--- Python-2.6.8/Lib/distutils/command/install.py.lib64 2012-04-10 11:32:04.000000000 -0400
|
||||
+++ Python-2.6.8/Lib/distutils/command/install.py 2012-04-12 13:23:24.929428232 -0400
|
||||
@@ -42,14 +42,14 @@ else:
|
||||
diff -ru Python-2.7.15/Lib/distutils/command/install.py Python-2.7.15.patched/Lib/distutils/command/install.py
|
||||
--- Python-2.7.15/Lib/distutils/command/install.py 2018-04-30 00:47:33.000000000 +0200
|
||||
+++ Python-2.7.15.patched/Lib/distutils/command/install.py 2018-09-06 15:10:51.535589859 +0200
|
||||
@@ -42,14 +42,14 @@
|
||||
INSTALL_SCHEMES = {
|
||||
'unix_prefix': {
|
||||
'purelib': '$base/lib/python$py_version_short/site-packages',
|
||||
@ -18,10 +18,10 @@ diff -up Python-2.6.8/Lib/distutils/command/install.py.lib64 Python-2.6.8/Lib/di
|
||||
'headers': '$base/include/python/$dist_name',
|
||||
'scripts': '$base/bin',
|
||||
'data' : '$base',
|
||||
diff -up Python-2.6.8/Lib/distutils/sysconfig.py.lib64 Python-2.6.8/Lib/distutils/sysconfig.py
|
||||
--- Python-2.6.8/Lib/distutils/sysconfig.py.lib64 2012-04-10 11:32:04.000000000 -0400
|
||||
+++ Python-2.6.8/Lib/distutils/sysconfig.py 2012-04-12 13:23:24.930428219 -0400
|
||||
@@ -119,8 +119,12 @@ def get_python_lib(plat_specific=0, stan
|
||||
diff -ru Python-2.7.15/Lib/distutils/sysconfig.py Python-2.7.15.patched/Lib/distutils/sysconfig.py
|
||||
--- Python-2.7.15/Lib/distutils/sysconfig.py 2018-04-30 00:47:33.000000000 +0200
|
||||
+++ Python-2.7.15.patched/Lib/distutils/sysconfig.py 2018-09-06 15:10:51.535589859 +0200
|
||||
@@ -119,8 +119,12 @@
|
||||
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
||||
|
||||
if os.name == "posix":
|
||||
@ -35,10 +35,10 @@ diff -up Python-2.6.8/Lib/distutils/sysconfig.py.lib64 Python-2.6.8/Lib/distutil
|
||||
if standard_lib:
|
||||
return libpython
|
||||
else:
|
||||
diff -up Python-2.6.8/Lib/site.py.lib64 Python-2.6.8/Lib/site.py
|
||||
--- Python-2.6.8/Lib/site.py.lib64 2012-04-10 11:32:06.000000000 -0400
|
||||
+++ Python-2.6.8/Lib/site.py 2012-04-12 13:23:24.931428206 -0400
|
||||
@@ -300,12 +300,16 @@ def getsitepackages():
|
||||
diff -ru Python-2.7.15/Lib/site.py Python-2.7.15.patched/Lib/site.py
|
||||
--- Python-2.7.15/Lib/site.py 2018-04-30 00:47:33.000000000 +0200
|
||||
+++ Python-2.7.15.patched/Lib/site.py 2018-09-06 15:10:51.535589859 +0200
|
||||
@@ -288,12 +288,16 @@
|
||||
if sys.platform in ('os2emx', 'riscos'):
|
||||
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
||||
elif os.sep == '/':
|
||||
@ -53,12 +53,13 @@ diff -up Python-2.6.8/Lib/site.py.lib64 Python-2.6.8/Lib/site.py
|
||||
sitepackages.append(prefix)
|
||||
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
||||
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
||||
if sys.platform == "darwin":
|
||||
# for framework builds *only* we add the standard Apple
|
||||
diff -up Python-2.6.8/Makefile.pre.in.lib64 Python-2.6.8/Makefile.pre.in
|
||||
--- Python-2.6.8/Makefile.pre.in.lib64 2012-04-12 13:23:24.000000000 -0400
|
||||
+++ Python-2.6.8/Makefile.pre.in 2012-04-12 13:24:31.619594491 -0400
|
||||
@@ -91,7 +91,7 @@ LIBDIR= @libdir@
|
||||
return sitepackages
|
||||
|
||||
Only in Python-2.7.15.patched/Lib: site.py.orig
|
||||
diff -ru Python-2.7.15/Makefile.pre.in Python-2.7.15.patched/Makefile.pre.in
|
||||
--- Python-2.7.15/Makefile.pre.in 2018-04-30 00:47:33.000000000 +0200
|
||||
+++ Python-2.7.15.patched/Makefile.pre.in 2018-09-06 15:10:51.536589863 +0200
|
||||
@@ -110,7 +110,7 @@
|
||||
MANDIR= @mandir@
|
||||
INCLUDEDIR= @includedir@
|
||||
CONFINCLUDEDIR= $(exec_prefix)/include
|
||||
@ -67,50 +68,11 @@ diff -up Python-2.6.8/Makefile.pre.in.lib64 Python-2.6.8/Makefile.pre.in
|
||||
|
||||
# Detailed destination directories
|
||||
BINLIBDEST= $(LIBDIR)/python$(VERSION)
|
||||
diff -up Python-2.6.8/Modules/getpath.c.lib64 Python-2.6.8/Modules/getpath.c
|
||||
--- Python-2.6.8/Modules/getpath.c.lib64 2012-04-10 11:32:09.000000000 -0400
|
||||
+++ Python-2.6.8/Modules/getpath.c 2012-04-12 13:24:52.443334157 -0400
|
||||
@@ -117,8 +117,8 @@
|
||||
#endif
|
||||
|
||||
#ifndef PYTHONPATH
|
||||
-#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
|
||||
- EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
|
||||
+#define PYTHONPATH PREFIX "/lib64/python" VERSION ":" \
|
||||
+ EXEC_PREFIX "/lib64/python" VERSION "/lib-dynload"
|
||||
#endif
|
||||
|
||||
#ifndef LANDMARK
|
||||
@@ -129,7 +129,7 @@ static char prefix[MAXPATHLEN+1];
|
||||
static char exec_prefix[MAXPATHLEN+1];
|
||||
static char progpath[MAXPATHLEN+1];
|
||||
static char *module_search_path = NULL;
|
||||
-static char lib_python[] = "lib/python" VERSION;
|
||||
+static char lib_python[] = "lib64/python" VERSION;
|
||||
|
||||
static void
|
||||
reduce(char *dir)
|
||||
@@ -524,7 +524,7 @@ calculate_path(void)
|
||||
}
|
||||
else
|
||||
strncpy(zip_path, PREFIX, MAXPATHLEN);
|
||||
- joinpath(zip_path, "lib/python00.zip");
|
||||
+ joinpath(zip_path, "lib64/python00.zip");
|
||||
bufsz = strlen(zip_path); /* Replace "00" with version */
|
||||
zip_path[bufsz - 6] = VERSION[0];
|
||||
zip_path[bufsz - 5] = VERSION[2];
|
||||
@@ -534,7 +534,7 @@ calculate_path(void)
|
||||
fprintf(stderr,
|
||||
"Could not find platform dependent libraries <exec_prefix>\n");
|
||||
strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
|
||||
- joinpath(exec_prefix, "lib/lib-dynload");
|
||||
+ joinpath(exec_prefix, "lib64/lib-dynload");
|
||||
}
|
||||
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
||||
|
||||
--- Python-2.7.3/Modules/Setup.dist.lib64 2012-08-31 14:26:12.000000000 -0700
|
||||
+++ Python-2.7.3/Modules/Setup.dist 2012-08-31 14:28:58.000000000 -0700
|
||||
@@ -414,7 +414,7 @@
|
||||
Only in Python-2.7.15.patched: Makefile.pre.in.orig
|
||||
diff -ru Python-2.7.15/Modules/Setup.dist Python-2.7.15.patched/Modules/Setup.dist
|
||||
--- Python-2.7.15/Modules/Setup.dist 2018-04-30 00:47:33.000000000 +0200
|
||||
+++ Python-2.7.15.patched/Modules/Setup.dist 2018-09-06 15:10:51.536589863 +0200
|
||||
@@ -418,7 +418,7 @@
|
||||
#DB=/usr/local/BerkeleyDB.4.0
|
||||
#DBLIBVER=4.0
|
||||
#DBINC=$(DB)/include
|
||||
@ -119,7 +81,7 @@ diff -up Python-2.6.8/Modules/getpath.c.lib64 Python-2.6.8/Modules/getpath.c
|
||||
#_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb-$(DBLIBVER)
|
||||
|
||||
# Historical Berkeley DB 1.85
|
||||
@@ -460,7 +460,7 @@ GLHACK=-Dclear=__GLclear
|
||||
@@ -464,7 +464,7 @@
|
||||
# Andrew Kuchling's zlib module.
|
||||
# This require zlib 1.1.3 (or later).
|
||||
# See http://www.gzip.org/zlib/
|
||||
@ -128,9 +90,43 @@ diff -up Python-2.6.8/Modules/getpath.c.lib64 Python-2.6.8/Modules/getpath.c
|
||||
|
||||
# Interface to the Expat XML parser
|
||||
#
|
||||
--- Python-2.7.8/setup.py.orig 2014-06-30 04:05:48.000000000 +0200
|
||||
+++ Python-2.7.8/setup.py 2014-11-23 18:08:31.091091727 +0100
|
||||
@@ -439,6 +439,7 @@
|
||||
Only in Python-2.7.15.patched/Modules: Setup.dist.orig
|
||||
diff -ru Python-2.7.15/Modules/getpath.c Python-2.7.15.patched/Modules/getpath.c
|
||||
--- Python-2.7.15/Modules/getpath.c 2018-04-30 00:47:33.000000000 +0200
|
||||
+++ Python-2.7.15.patched/Modules/getpath.c 2018-09-06 15:10:51.536589863 +0200
|
||||
@@ -108,7 +108,7 @@
|
||||
static char exec_prefix[MAXPATHLEN+1];
|
||||
static char progpath[MAXPATHLEN+1];
|
||||
static char *module_search_path = NULL;
|
||||
-static char lib_python[] = "lib/python" VERSION;
|
||||
+static char lib_python[] = "lib64/python" VERSION;
|
||||
|
||||
static void
|
||||
reduce(char *dir)
|
||||
@@ -520,7 +520,7 @@
|
||||
}
|
||||
else
|
||||
strncpy(zip_path, PREFIX, MAXPATHLEN);
|
||||
- joinpath(zip_path, "lib/python00.zip");
|
||||
+ joinpath(zip_path, "lib64/python00.zip");
|
||||
bufsz = strlen(zip_path); /* Replace "00" with version */
|
||||
zip_path[bufsz - 6] = VERSION[0];
|
||||
zip_path[bufsz - 5] = VERSION[2];
|
||||
@@ -530,7 +530,7 @@
|
||||
fprintf(stderr,
|
||||
"Could not find platform dependent libraries <exec_prefix>\n");
|
||||
strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
|
||||
- joinpath(exec_prefix, "lib/lib-dynload");
|
||||
+ joinpath(exec_prefix, "lib64/lib-dynload");
|
||||
}
|
||||
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
||||
|
||||
Only in Python-2.7.15.patched/Modules: getpath.c.orig
|
||||
Only in Python-2.7.15.patched/Modules: getpath.c.rej
|
||||
diff -ru Python-2.7.15/setup.py Python-2.7.15.patched/setup.py
|
||||
--- Python-2.7.15/setup.py 2018-04-30 00:47:33.000000000 +0200
|
||||
+++ Python-2.7.15.patched/setup.py 2018-09-06 15:10:51.536589863 +0200
|
||||
@@ -457,6 +457,7 @@
|
||||
# Ensure that /usr/local is always used
|
||||
if not cross_compiling:
|
||||
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
||||
@ -138,7 +134,7 @@ diff -up Python-2.6.8/Modules/getpath.c.lib64 Python-2.6.8/Modules/getpath.c
|
||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||
if cross_compiling:
|
||||
self.add_gcc_paths()
|
||||
@@ -760,11 +761,11 @@
|
||||
@@ -782,11 +783,11 @@
|
||||
elif curses_library:
|
||||
readline_libs.append(curses_library)
|
||||
elif self.compiler.find_library_file(lib_dirs +
|
||||
@ -152,7 +148,7 @@ diff -up Python-2.6.8/Modules/getpath.c.lib64 Python-2.6.8/Modules/getpath.c
|
||||
extra_link_args=readline_extra_link_args,
|
||||
libraries=readline_libs) )
|
||||
else:
|
||||
@@ -799,8 +800,8 @@
|
||||
@@ -821,8 +822,8 @@
|
||||
if krb5_h:
|
||||
ssl_incs += krb5_h
|
||||
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
||||
@ -163,3 +159,4 @@ diff -up Python-2.6.8/Modules/getpath.c.lib64 Python-2.6.8/Modules/getpath.c
|
||||
] )
|
||||
|
||||
if (ssl_incs is not None and
|
||||
Only in Python-2.7.15.patched: setup.py.orig
|
@ -6,7 +6,7 @@
|
||||
#% define __libdir %{_prefix}/lib
|
||||
%define __libdir %{_libdir}
|
||||
Name: python27
|
||||
Version: 2.7.9
|
||||
Version: 2.7.15
|
||||
Release: 1mamba
|
||||
Summary: An interpreted, interactive, object-oriented programming language
|
||||
Group: Applications/Development
|
||||
@ -25,7 +25,7 @@ Patch5: Python-2.6.5-xcompile.patch
|
||||
Patch6: python-2.6.7-pkgconfig.patch
|
||||
Patch7: python27-2.7.3-gcc-4.8.patch
|
||||
Patch8: python-2.7.3-use_system_Sphinx.patch
|
||||
Patch9: python27-2.7.8-lib64.patch
|
||||
Patch9: python-2.7.15-lib64.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -359,6 +359,9 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Sep 06 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.15-1mamba
|
||||
- update to 2.7.15
|
||||
|
||||
* Sat May 16 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.9-1mamba
|
||||
- update to 2.7.9
|
||||
- macros.python: added %pyver_package macro
|
||||
|
Loading…
Reference in New Issue
Block a user