83 lines
2.4 KiB
RPMSpec
83 lines
2.4 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
|
Name: python-yapf
|
|
Version: 0.40.2
|
|
Release: 2mamba
|
|
Summary: A formatter for Python code
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://pypi.org/project/yapf/
|
|
Source: http://pypi.debian.net/yapf/yapf-%{version}.tar.gz
|
|
License: Apache License 2.0
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: python3.11dist(importlib-metadata)
|
|
BuildRequires: python3.11dist(platformdirs)
|
|
BuildRequires: python3.11dist(tomli)
|
|
## AUTOBUILDREQ-END
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%if "0%{?with_pyver}" == "03"
|
|
%define py_requires_append \
|
|
Obsoletes: python-yapf-py310 <= 0.40.2-1mamba
|
|
%endif
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n yapf-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
# Rename any conflicting file outside of python site packages tree
|
|
for f in %{_bindir}/{yapf,yapf-diff}; do
|
|
mv %{buildroot}${f}{,-%{?pyappend}}
|
|
done
|
|
%endif
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%{_bindir}/yapf*
|
|
%{_bindir}/yapf-diff*
|
|
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
|
|
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
|
|
%dir %{python_sitelib}/%{pkgname}
|
|
%{python_sitelib}/%{pkgname}/*
|
|
%dir %{python_sitelib}/yapf_third_party
|
|
%{python_sitelib}/yapf_third_party/*
|
|
%dir %{python_sitelib}/%{pkgname}tests
|
|
%{python_sitelib}/%{pkgname}tests/*
|
|
%doc AUTHORS LICENSE
|
|
|
|
%changelog
|
|
* Sun Mar 24 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.40.2-2mamba
|
|
- obsolete python-yapf-py310
|
|
|
|
* Sat Sep 23 2023 Automatic Build System <autodist@mambasoft.it> 0.40.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 21 2023 Automatic Build System <autodist@mambasoft.it> 0.40.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 16 2023 Automatic Build System <autodist@mambasoft.it> 0.40.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Apr 19 2023 Automatic Build System <autodist@mambasoft.it> 0.33.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 07 2023 Sdk Build System <sdk@mambasoft.it> 0.32.0-2mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Wed Nov 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.32.0-1mamba
|
|
- package created using the webbuild interface
|