fix again obsolete for python-wxPython-tools [release 4.2.1-5mamba;Mon Oct 02 2023]
This commit is contained in:
parent
e6a29d0032
commit
2ce5b9c445
10
python-wxPython-4.2.1-cpython-3.0.2.patch
Normal file
10
python-wxPython-4.2.1-cpython-3.0.2.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- wxPython-4.2.1/wx/svg/_nanosvg.pyx.orig 2023-09-28 21:23:46.483810300 +0200
|
||||
+++ wxPython-4.2.1/wx/svg/_nanosvg.pyx 2023-09-28 21:23:57.769839809 +0200
|
||||
@@ -42,7 +42,6 @@
|
||||
|
||||
import sys
|
||||
|
||||
-cimport cython.object
|
||||
from cpython.buffer cimport (
|
||||
Py_buffer, PyObject_CheckBuffer, PyObject_GetBuffer, PyBUF_SIMPLE,
|
||||
PyBuffer_Release)
|
@ -1,101 +1,104 @@
|
||||
%define pkgname %(echo %name | cut -d- -f2-)
|
||||
Name: python-wxPython
|
||||
Version: 4.1.1
|
||||
Release: 1mamba
|
||||
Version: 4.2.1
|
||||
Release: 5mamba
|
||||
Summary: Cross platform GUI toolkit for Python, "Phoenix" version
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://wxpython.org/
|
||||
URL: https://wxpython.org/
|
||||
Source: https://pypi.debian.net/wxPython/wxPython-%{version}.tar.gz
|
||||
Patch0: python-wxPython-4.2.1-cpython-3.0.2.patch
|
||||
License: wxWindows Library License
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gst-plugins-bad-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXtst-devel
|
||||
BuildRequires: libXxf86vm-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjbig-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libnotify-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libsecret-devel
|
||||
BuildRequires: libsoup-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libwayland-devel
|
||||
BuildRequires: libwayland-egl-devel
|
||||
BuildRequires: libwebkit2gtk-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: python3.7dist(numpy)
|
||||
BuildRequires: python3.7dist(pillow)
|
||||
BuildRequires: python3.7dist(setuptools)
|
||||
BuildRequires: python3.7dist(six)
|
||||
BuildRequires: python3.11dist(numpy)
|
||||
BuildRequires: python3.11dist(pillow)
|
||||
BuildRequires: python3.11dist(setuptools)
|
||||
BuildRequires: python3.11dist(six)
|
||||
BuildRequires: wxwidgets-devel
|
||||
BuildRequires: wxwidgets-gtk3-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python3-devel >= 3.11.5-3mamba
|
||||
BuildRequires: python-attrdict-py3
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package tools
|
||||
Summary: Tools provided with %{name}
|
||||
Group: System/Tools
|
||||
|
||||
%description tools
|
||||
Tools provided with %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%if 0%{?with_pyver}
|
||||
%define py_requires_append \
|
||||
Provides: python-wxPython-tools \
|
||||
Obsoletes: python-wxPython-tools < 4.2.1-3mamba \
|
||||
Obsoletes: wxPython <= 2.8.12.1
|
||||
%pyver_package
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n wxPython-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch 0 -p1
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags}" %{__python} setup.py build
|
||||
#:<< _EOF
|
||||
CFLAGS="%{optflags}" \
|
||||
WX_CONFIG=/usr/bin/wx-config-unicode-3 \
|
||||
%{__python} build.py --nodoc sip build --use_syswx --release
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python} setup.py install \
|
||||
-O1 --skip-build \
|
||||
--root="%{buildroot}" \
|
||||
--install-headers=%{python_inc} \
|
||||
--install-lib=%{python_sitearch} \
|
||||
--record=%{name}.filelist
|
||||
|
||||
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
||||
%{__python} build.py install --destdir="%{buildroot}"
|
||||
|
||||
%files %{?pyappend} -f %{name}.filelist
|
||||
%if "%{?with_pyver}" != "3"
|
||||
# Rename any conflicting file outside of python site packages tree
|
||||
for f in %{_bindir}/{helpviewer,img2png,img2py,img2xpm,pycrust,pyshell,pyslices,pyslicesshell,pywxrc,wxdemo,wxdocs,wxget}; do
|
||||
mv %{buildroot}${f}{,-%{?pyappend}}
|
||||
done
|
||||
%endif
|
||||
|
||||
%files %{?pyappend}
|
||||
%defattr(-,root,root)
|
||||
%dir %{python_sitearch}/%{pkgname}-%{version}-py*.egg-info
|
||||
%{python_sitearch}/%{pkgname}-%{version}-py*.egg-info/*
|
||||
%exclude %{_bindir}/*
|
||||
|
||||
%files tools
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_bindir}/helpviewer*
|
||||
%{_bindir}/img2png*
|
||||
%{_bindir}/img2py*
|
||||
%{_bindir}/img2xpm*
|
||||
%{_bindir}/pycrust*
|
||||
%{_bindir}/pyshell*
|
||||
%{_bindir}/pyslices*
|
||||
%{_bindir}/pywxrc*
|
||||
%{_bindir}/wxdemo*
|
||||
%{_bindir}/wxdocs*
|
||||
%{_bindir}/wxget*
|
||||
%dir %{python_sitearch}/wxPython-%{version}-py*.egg-info
|
||||
%{python_sitearch}/wxPython-%{version}-py*.egg-info/*
|
||||
%dir %{python_sitearch}/wx
|
||||
%{python_sitearch}/wx/*
|
||||
|
||||
%changelog
|
||||
* Mon Oct 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.1-5mamba
|
||||
- fix again obsolete for python-wxPython-tools
|
||||
|
||||
* Mon Oct 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.1-4mamba
|
||||
- fixed obsolete for python-wxPython-tools
|
||||
|
||||
* Sat Sep 30 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.1-3mamba
|
||||
- rebuilt with system wx
|
||||
|
||||
* Thu Sep 28 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2.1-2mamba
|
||||
- rebuilt with python3 == 3.11
|
||||
|
||||
* Fri Jun 09 2023 Automatic Build System <autodist@mambasoft.it> 4.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 08 2022 Automatic Build System <autodist@mambasoft.it> 4.2.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 14 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 4.1.1-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user