75 lines
2.3 KiB
RPMSpec
75 lines
2.3 KiB
RPMSpec
Name: python-wheel
|
|
Version: 0.37.1
|
|
Release: 2mamba
|
|
Summary: The reference implementation of the Python wheel packaging standard, as defined in PEP 427
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://pypi.org/project/wheel/
|
|
Source: https://pypi.debian.net/wheel/wheel-%{version}.tar.gz
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython3-devel
|
|
BuildRequires: python3.7dist(setuptools)
|
|
## AUTOBUILDREQ-END
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n wheel-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} setup.py build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} setup.py install \
|
|
-O1 --skip-build \
|
|
--root="%{buildroot}" \
|
|
--install-headers=%{python_inc} \
|
|
--install-lib=%{python_sitearch} \
|
|
--record=%{name}.filelist
|
|
|
|
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
|
|
|
%if "%{?with_pyver}" != ""
|
|
mv %{buildroot}%{_bindir}/wheel %{buildroot}%{_bindir}/wheel%{?with_pyver}
|
|
sed -i "s|%{_bindir}/wheel$|%{_bindir}/wheel%{?with_pyver}|" %{name}.filelist
|
|
%endif
|
|
|
|
%files %{?pyappend} -f %{name}.filelist
|
|
%defattr(-,root,root)
|
|
%dir %{python_sitearch}/wheel-%{version}-py*.egg-info
|
|
%{python_sitearch}/wheel-%{version}-py*.egg-info/*
|
|
|
|
%changelog
|
|
* Sat May 28 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.37.1-2mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Thu Dec 23 2021 Automatic Build System <autodist@mambasoft.it> 0.37.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 10 2021 Automatic Build System <autodist@mambasoft.it> 0.37.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 18 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.36.2-2mamba
|
|
- rebuilt with python dist deps; resolve conflicts for /usr/bin/wheel
|
|
|
|
* Mon Dec 14 2020 Automatic Build System <autodist@mambasoft.it> 0.36.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 05 2020 Automatic Build System <autodist@mambasoft.it> 0.36.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 02 2020 Automatic Build System <autodist@mambasoft.it> 0.36.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 27 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.35.1-1mamba
|
|
- package created using the webbuild interface
|