382 lines
14 KiB
RPMSpec
382 lines
14 KiB
RPMSpec
Name: python-virtualenv
|
|
Version: 20.17.0
|
|
Release: 1mamba
|
|
Summary: Virtual Python Environment builder
|
|
Group: System/Libraries/Python
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://virtualenv.pypa.io/en/latest/
|
|
Source: http://pypi.debian.net/virtualenv/virtualenv-%{version}.tar.gz
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython3-devel
|
|
BuildRequires: python3.7dist(distlib)
|
|
BuildRequires: python3.7dist(filelock)
|
|
BuildRequires: python3.7dist(importlib-metadata)
|
|
BuildRequires: python3.7dist(platformdirs)
|
|
BuildRequires: python3.7dist(setuptools)
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: help2man
|
|
BuildArch: noarch
|
|
|
|
%description
|
|
virtualenv is a tool to create isolated Python environments.
|
|
|
|
%if "%{?with_pyver}" == "3"
|
|
%define py_requires_append \
|
|
Provides: python-virtualenv \
|
|
Obsoletes: python-virtualenv <= 20.7.2-1mamba \
|
|
Obsoletes: python-virtualenv-py36 < 20.4.0
|
|
%endif
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n virtualenv-%{version}
|
|
# Removed unsatisfyable requirement versions
|
|
sed -i "s|platformdirs.*|platformdirs|" setup.cfg
|
|
sed -i "s|backports.entry_points_selectable.*|backports.entry_points_selectable|" setup.cfg
|
|
|
|
%build
|
|
%{__python} setup.py build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} setup.py install \
|
|
-O1 --skip-build \
|
|
--root="%{buildroot}" \
|
|
--install-headers=%{_includedir}/python \
|
|
--install-lib=%{python_sitearch} \
|
|
--single-version-externally-managed \
|
|
--record=%{name}.filelist
|
|
|
|
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
|
|
|
install -d %{buildroot}%{_mandir}/man1
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
mv %{buildroot}%{_bindir}/virtualenv{,-%{?pyappend}}
|
|
sed -i "s|%{_bindir}/virtualenv|%{_bindir}/virtualenv-%{?pyappend}|" %{name}.filelist
|
|
%endif
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files %{?pyappend} -f %{name}.filelist
|
|
%defattr(-,root,root)
|
|
%dir %{python_sitearch}/virtualenv-%{version}-py*.egg-info
|
|
%{python_sitearch}/virtualenv-%{version}-py*.egg-info/*
|
|
|
|
%changelog
|
|
* Mon Nov 28 2022 Automatic Build System <autodist@mambasoft.it> 20.17.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 13 2022 Automatic Build System <autodist@mambasoft.it> 20.16.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 26 2022 Automatic Build System <autodist@mambasoft.it> 20.16.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 10 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 20.16.5-3mamba
|
|
- provide/obsolete python-virtualenv* only in py3 package
|
|
|
|
* Sun Oct 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 20.16.5-2mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Mon Sep 12 2022 Automatic Build System <autodist@mambasoft.it> 20.16.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 29 2022 Automatic Build System <autodist@mambasoft.it> 20.16.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 27 2022 Automatic Build System <autodist@mambasoft.it> 20.16.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 27 2022 Automatic Build System <autodist@mambasoft.it> 20.16.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 29 2022 Automatic Build System <autodist@mambasoft.it> 20.15.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jun 26 2022 Automatic Build System <autodist@mambasoft.it> 20.15.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 12 2022 Automatic Build System <autodist@mambasoft.it> 20.14.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 26 2022 Automatic Build System <autodist@mambasoft.it> 20.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 19 2022 Automatic Build System <autodist@mambasoft.it> 20.13.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 08 2022 Automatic Build System <autodist@mambasoft.it> 20.13.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 25 2022 Automatic Build System <autodist@mambasoft.it> 20.13.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 06 2022 Automatic Build System <autodist@mambasoft.it> 20.13.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 03 2022 Automatic Build System <autodist@mambasoft.it> 20.13.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 01 2022 Automatic Build System <autodist@mambasoft.it> 20.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 01 2022 Automatic Build System <autodist@mambasoft.it> 20.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 30 2021 Automatic Build System <autodist@mambasoft.it> 20.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 29 2021 Automatic Build System <autodist@mambasoft.it> 20.11.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 29 2021 Automatic Build System <autodist@mambasoft.it> 20.11.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 02 2021 Automatic Build System <autodist@mambasoft.it> 20.10.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 23 2021 Automatic Build System <autodist@mambasoft.it> 20.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 24 2021 Automatic Build System <autodist@mambasoft.it> 20.8.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Sep 18 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 20.8.0-1mamba
|
|
- update to 20.8.0
|
|
|
|
* Tue Aug 31 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 20.7.2-2mamba
|
|
- rebuilt with distdeps
|
|
|
|
* Wed Aug 11 2021 Automatic Build System <autodist@mambasoft.it> 20.7.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 10 2021 Automatic Build System <autodist@mambasoft.it> 20.7.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 31 2021 Automatic Build System <autodist@mambasoft.it> 20.7.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 15 2021 Automatic Build System <autodist@mambasoft.it> 20.6.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jul 14 2021 Automatic Build System <autodist@mambasoft.it> 20.5.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 20.4.7-1mamba
|
|
- update to 20.4.7
|
|
|
|
* Thu May 06 2021 Automatic Build System <autodist@mambasoft.it> 20.4.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 05 2021 Automatic Build System <autodist@mambasoft.it> 20.4.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 20 2021 Automatic Build System <autodist@mambasoft.it> 20.4.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 17 2021 Automatic Build System <autodist@mambasoft.it> 20.4.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 03 2021 Automatic Build System <autodist@mambasoft.it> 20.4.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 01 2021 Automatic Build System <autodist@mambasoft.it> 20.4.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 25 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 20.4.0-2mamba
|
|
- added missing requirements
|
|
|
|
* Tue Jan 19 2021 Automatic Build System <autodist@mambasoft.it> 20.4.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 18 2021 Automatic Build System <autodist@mambasoft.it> 20.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 13 2021 Automatic Build System <autodist@mambasoft.it> 20.3.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 08 2020 Automatic Build System <autodist@mambasoft.it> 20.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 05 2020 Automatic Build System <autodist@mambasoft.it> 20.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 02 2020 Automatic Build System <autodist@mambasoft.it> 20.2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 04 2020 Automatic Build System <autodist@mambasoft.it> 20.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 02 2020 Automatic Build System <autodist@mambasoft.it> 20.0.35-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 01 2020 Automatic Build System <autodist@mambasoft.it> 20.0.34-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 29 2020 Automatic Build System <autodist@mambasoft.it> 20.0.33-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 25 2020 Automatic Build System <autodist@mambasoft.it> 20.0.32-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 24 2020 Automatic Build System <autodist@mambasoft.it> 20.0.31-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 22 2020 Automatic Build System <autodist@mambasoft.it> 20.0.30-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 20 2020 Automatic Build System <autodist@mambasoft.it> 20.0.29-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 19 2020 Automatic Build System <autodist@mambasoft.it> 20.0.28-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 18 2020 Automatic Build System <autodist@mambasoft.it> 20.0.27-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 17 2020 Automatic Build System <autodist@mambasoft.it> 20.0.25-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 16 2020 Automatic Build System <autodist@mambasoft.it> 20.0.24-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 24 2020 Automatic Build System <autodist@mambasoft.it> 20.0.23-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 22 2020 Automatic Build System <autodist@mambasoft.it> 20.0.21-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 21 2020 Automatic Build System <autodist@mambasoft.it> 20.0.20-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 20 2020 Automatic Build System <autodist@mambasoft.it> 20.0.19-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 23 2020 Automatic Build System <autodist@mambasoft.it> 20.0.18-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 21 2020 Automatic Build System <autodist@mambasoft.it> 20.0.17-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 31 2020 Automatic Build System <autodist@mambasoft.it> 20.0.15-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 16.7.9-1mamba
|
|
- update to 16.7.9
|
|
|
|
* Fri Aug 09 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 16.7.2-1mamba
|
|
- update to 16.7.2
|
|
|
|
* Thu Jan 03 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 16.1.0-1mamba
|
|
- update to 16.1.0
|
|
|
|
* Fri Aug 17 2018 Automatic Build System <autodist@mambasoft.it> 16.0.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 19 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 15.1.0-3mamba
|
|
- added requirement for py3 version
|
|
|
|
* Thu Jul 13 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 15.1.0-2mamba
|
|
- rename virtualenv to virtualenv2 in py2 package to support co-existence
|
|
|
|
* Mon Mar 06 2017 Automatic Build System <autodist@mambasoft.it> 15.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 14 2016 Automatic Build System <autodist@mambasoft.it> 15.0.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jun 26 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 15.0.2-2mamba
|
|
- rebuilt with -py3 package
|
|
|
|
* Thu Jun 02 2016 Automatic Build System <autodist@mambasoft.it> 15.0.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 01 2016 Automatic Build System <autodist@mambasoft.it> 15.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 23 2016 Automatic Build System <autodist@mambasoft.it> 15.0.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 05 2016 Automatic Build System <autodist@mambasoft.it> 14.0.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 24 2016 Automatic Build System <autodist@mambasoft.it> 14.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 30 2015 Automatic Build System <autodist@mambasoft.it> 13.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 02 2015 Automatic Build System <autodist@mambasoft.it> 13.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 19 2015 Automatic Build System <autodist@mambasoft.it> 13.0.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 24 2015 Automatic Build System <autodist@mambasoft.it> 13.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 07 2015 Automatic Build System <autodist@mambasoft.it> 12.1.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 06 2015 Automatic Build System <autodist@mambasoft.it> 12.0.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 04 2015 Automatic Build System <autodist@mambasoft.it> 12.0.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 27 2014 Automatic Build System <autodist@mambasoft.it> 1.11.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 09 2014 Automatic Build System <autodist@mambasoft.it> 1.11.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Mar 03 2014 Automatic Build System <autodist@mambasoft.it> 1.11.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 27 2014 Automatic Build System <autodist@mambasoft.it> 1.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 22 2014 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.11.1-1mamba
|
|
- update to 1.11.1
|
|
|
|
* Sat Aug 10 2013 Automatic Build System <autodist@mambasoft.it> 1.10.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jul 29 2013 Automatic Build System <autodist@mambasoft.it> 1.10-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.1-2mamba
|
|
- python 2.7 mass rebuild
|
|
|
|
* Sat Mar 09 2013 Automatic Build System <autodist@mambasoft.it> 1.9.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 12 2013 Automatic Build System <autodist@mambasoft.it> 1.8.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 24 2012 Automatic Build System <autodist@mambasoft.it> 1.8.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 14 2012 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 08 2012 Automatic Build System <autodist@mambasoft.it> 1.7.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 30 2011 Automatic Build System <autodist@mambasoft.it> 1.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 20 2011 Automatic Build System <autodist@mambasoft.it> 1.5.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Oct 12 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.5.1-1mamba
|
|
- package created by autospec
|