python-twisted/python-twisted.spec

221 lines
7.8 KiB
RPMSpec

%define pkgmajver %(echo %{version} | cut -d. -f 1-2)
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
Name: python-twisted
Version: 23.10.0
Release: 1mamba
Summary: Event-driven networking framework written in Python
Group: System/Libraries/Python
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://twisted.org/
Source: https://pypi.debian.net/Twisted/twisted-%{version}.tar.gz
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: libpython311-devel
BuildRequires: python3.11dist(attrs)
BuildRequires: python3.11dist(automat)
BuildRequires: python3.11dist(constantly)
BuildRequires: python3.11dist(hyperlink)
BuildRequires: python3.11dist(incremental)
BuildRequires: python3.11dist(typing-extensions)
BuildRequires: python3.11dist(zope-interface)
## AUTOBUILDREQ-END
BuildRequires: python3-devel >= 3.11.5-3mamba
%description
An event-driven networking framework written in Python and licensed under the LGPL.
Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols (including HTTP, NNTP, SSH, IRC, FTP, andothers), and much more.
%if 0%{?with_pyver}
%define py_requires_append \
Obsoletes: python-twisted < 23.10.0 \
Obsoletes: python-twisted-py310 < 23.10.0
%pyver_package
%endif
%package docs
Summary: Documentation for the Twisted networking framework
Group: Documentation
%description docs
An event-driven networking framework written in Python and licensed under the LGPL.
Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols (including HTTP, NNTP, SSH, IRC, FTP, andothers), and much more.
This package contains all the documentation for Twisted.
%prep
%setup -q -n twisted-%{version}
sed -i "s|zope-interface|zope.interface|" PKG-INFO
%build
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
%if "%{?with_pyver}" != "3"
# Rename any conflicting file outside of python site packages tree
for f in %{_bindir}/{cftp,ckeygen,conch,mailmail,pyhtmlizer,tkconch,trial,twist,twistd}; do
mv %{buildroot}${f}{,-%{?pyappend}}
done
%endif
%files %{?pyappend}
%defattr(-,root,root)
%{_bindir}/cftp*
%{_bindir}/ckeygen*
%{_bindir}/conch*
%{_bindir}/mailmail*
%{_bindir}/pyhtmlizer*
%{_bindir}/tkconch*
%{_bindir}/trial*
%{_bindir}/twist*
%{_bindir}/twistd*
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
%dir %{python_sitelib}/%{pkgname}
%{python_sitelib}/%{pkgname}/*
%changelog
* Sat Dec 09 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 23.10.0-1mamba
- update to 23.10.0
* Wed Sep 27 2023 Automatic Build System <autodist@mambasoft.it> 22.10.0-2mamba
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
* Thu Nov 24 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 22.10.0-1mamba
- update to 22.10.0
* Thu Sep 08 2022 Automatic Build System <autodist@mambasoft.it> 22.8.0-1mamba
- automatic version update by autodist
* Tue Apr 12 2022 Automatic Build System <autodist@mambasoft.it> 22.4.0-1mamba
- automatic version update by autodist
* Fri Mar 04 2022 Automatic Build System <autodist@mambasoft.it> 22.2.0-1mamba
- automatic version update by autodist
* Tue Feb 08 2022 Automatic Build System <autodist@mambasoft.it> 22.1.0-1mamba
- automatic version update by autodist
* Thu Jul 29 2021 Automatic Build System <autodist@mambasoft.it> 21.7.0-1mamba
- automatic version update by autodist
* Fri Apr 09 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 21.2.0-1mamba
- update to 21.2.0
* Thu Apr 23 2020 Automatic Build System <autodist@mambasoft.it> 20.3.0-1mamba
- automatic version update by autodist
* Thu Nov 21 2019 Automatic Build System <autodist@mambasoft.it> 19.10.0-1mamba
- automatic version update by autodist
* Sun Oct 27 2019 Automatic Build System <autodist@mambasoft.it> 19.7.0-1mamba
- automatic version update by autodist
* Sat Jun 08 2019 Automatic Build System <autodist@mambasoft.it> 19.2.1-1mamba
- automatic version update by autodist
* Sat May 25 2019 Automatic Build System <autodist@mambasoft.it> 19.2.0-1mamba
- automatic version update by autodist
* Thu Jan 10 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 18.9.0-2mamba
- rebuild with python 3.6 support
* Tue Oct 23 2018 Automatic Build System <autodist@mambasoft.it> 18.9.0-1mamba
- automatic version update by autodist
* Tue Oct 09 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 18.7.0-2mamba
- rebuilt with multiple python versions
* Mon Aug 06 2018 Automatic Build System <autodist@mambasoft.it> 18.7.0-1mamba
- automatic version update by autodist
* Fri May 25 2018 Automatic Build System <autodist@mambasoft.it> 18.4.0-1mamba
- automatic version update by autodist
* Wed Oct 04 2017 Automatic Build System <autodist@mambasoft.it> 17.9.0-1mamba
- automatic version update by autodist
* Wed Aug 09 2017 Automatic Build System <autodist@mambasoft.it> 17.5.0-1mamba
- automatic version update by autodist
* Fri Mar 31 2017 Automatic Build System <autodist@mambasoft.it> 17.1.0-1mamba
- automatic version update by autodist
* Thu Dec 01 2016 Automatic Build System <autodist@mambasoft.it> 16.6.0-1mamba
- automatic version update by autodist
* Thu Nov 24 2016 Automatic Build System <autodist@mambasoft.it> 16.5.0-1mamba
- automatic version update by autodist
* Mon Sep 19 2016 Automatic Build System <autodist@mambasoft.it> 16.4.1-1mamba
- automatic update by autodist
* Fri Aug 19 2016 Automatic Build System <autodist@mambasoft.it> 16.3.2-1mamba
- automatic version update by autodist
* Wed Aug 17 2016 Automatic Build System <autodist@mambasoft.it> 16.3.1-1mamba
- automatic version update by autodist
* Wed Jul 13 2016 Automatic Build System <autodist@mambasoft.it> 16.3.0-1mamba
- automatic version update by autodist
* Thu Jun 02 2016 Automatic Build System <autodist@mambasoft.it> 16.2.0-1mamba
- automatic version update by autodist
* Sat Apr 30 2016 Automatic Build System <autodist@mambasoft.it> 16.1.1-1mamba
- automatic version update by autodist
* Sat Mar 19 2016 Automatic Build System <autodist@mambasoft.it> 16.0.0-1mamba
- automatic version update by autodist
* Thu Dec 03 2015 Automatic Build System <autodist@mambasoft.it> 15.5.0-1mamba
- automatic version update by autodist
* Thu Sep 24 2015 Automatic Build System <autodist@mambasoft.it> 15.4.0-1mamba
- automatic version update by autodist
* Sat Sep 12 2015 Automatic Build System <autodist@mambasoft.it> 15.3.0-1mamba
- automatic version update by autodist
* Fri Jun 05 2015 Automatic Build System <autodist@mambasoft.it> 15.2.1-1mamba
- automatic version update by autodist
* Mon Apr 13 2015 Automatic Build System <autodist@mambasoft.it> 15.1.0-1mamba
- automatic version update by autodist
* Sat Jan 31 2015 Automatic Build System <autodist@mambasoft.it> 15.0.0-1mamba
- automatic version update by autodist
* Fri Sep 19 2014 Automatic Build System <autodist@mambasoft.it> 14.0.2-1mamba
- automatic version update by autodist
* Thu Sep 18 2014 Automatic Build System <autodist@mambasoft.it> 14.0.1-1mamba
- automatic version update by autodist
* Sun Jun 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 14.0.0-1mamba
- update to 14.0.0
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 10.2.0-2mamba
- python 2.7 mass rebuild
* Wed Oct 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 10.2.0-1mamba
- update to 10.2.0
* Mon Aug 23 2010 Davide Madrisan <davide.madrisan@gmail.com> 8.2.0-1mamba
- update to 8.2.0
* Sun Dec 07 2008 gil <puntogil@libero.it> 8.1.0-2mamba
- built with python 2.6 and new python-twisted
* Mon Aug 11 2008 gil <puntogil@libero.it> 8.1.0-1mamba
- update to 8.1.0
- changed buildrequires python-devel with libpython-devel
- edit source
* Thu Aug 16 2007 Tiziana Ferro <tiziana.ferro@email.it> 2.5.0-1mamba
- package created by autospec