update to 2018.1.1 [release 2018.1.1-1mamba;Wed Mar 31 2021]
This commit is contained in:
parent
ff111b226c
commit
549b0739f0
17
python-tagpy-2018.1.1-id3-build.patch
Normal file
17
python-tagpy-2018.1.1-id3-build.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -Naur ./tagpy-2018.1.1.orig/src/wrapper/id3.cpp ./tagpy-2018.1.1/src/wrapper/id3.cpp
|
||||
--- ./tagpy-2018.1.1.orig/src/wrapper/id3.cpp 2019-03-23 08:26:04.975722018 -0400
|
||||
+++ ./tagpy-2018.1.1/src/wrapper/id3.cpp 2019-03-23 08:26:54.438399217 -0400
|
||||
@@ -220,12 +220,7 @@
|
||||
.DEF_SIMPLE_METHOD(removeFrame)
|
||||
.DEF_SIMPLE_METHOD(removeFrames)
|
||||
|
||||
- #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
|
||||
- .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)() const)
|
||||
- .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)(int) const)
|
||||
- #else
|
||||
- .def("render", (ByteVector (cl::*)() const) &cl::render)
|
||||
- #endif
|
||||
+ .def("render", (ByteVector (cl::*)() const) &cl::render)
|
||||
;
|
||||
}
|
||||
|
@ -1,27 +1,29 @@
|
||||
Name: python-tagpy
|
||||
Version: 2013.1
|
||||
Release: 3mamba
|
||||
Version: 2018.1.1
|
||||
Release: 1mamba
|
||||
Summary: Python Bindings for TagLib
|
||||
Group: System/Libraries/Python
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Automatic Build System <autodist@mambasoft.it>
|
||||
URL: http://pypi.python.org/pypi/tagpy
|
||||
Source: http://pypi.python.org/packages/source/t/tagpy/tagpy-%{version}.tar.gz
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://mathema.tician.de/software/tagpy/
|
||||
Source: https://pypi.debian.net/tagpy/tagpy-%{version}.tar.gz
|
||||
Patch0: tagpy-0.94.8-aksetup_helper.patch
|
||||
Patch1: python-tagpy-2018.1.1-id3-build.patch
|
||||
License: MIT
|
||||
Requires: python >= %python_version
|
||||
BuildRequires: libboost-devel
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
#python3.7dist(pytest): unidentified build requirement
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libpython-devel >= %python_version
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtag-devel
|
||||
BuildRequires: python-boost-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python-boost-py3
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libtag-devel >= 1.9.1
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires: python-boost-py3
|
||||
|
||||
%description
|
||||
TagPy is a set of Python bindings for Scott Wheeler's TagLib.
|
||||
@ -35,18 +37,26 @@ Just like TagLib, TagPy can:
|
||||
|
||||
All these features have their own specific interfaces, but TagLib's generic tag reading and writing mechanism is also supported. It comes with a bunch of examples.
|
||||
|
||||
%if 0%{?with_pyver}
|
||||
%pyver_package
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n tagpy-%{version}
|
||||
#%patch0 -p1
|
||||
%patch1 -p2
|
||||
|
||||
%build
|
||||
export PYTHON_EGG_CACHE=/tmp
|
||||
./configure.py \
|
||||
%{__python} ./configure.py \
|
||||
--taglib-lib-dir=%{_libdir} \
|
||||
--taglib-inc-dir=%{_includedir}/taglib \
|
||||
--boost-lib-dir=%{_libdir} \
|
||||
--boost-inc-dir=%{_includedir}/boost \
|
||||
--boost-python-libname=boost_python
|
||||
%if "%{?with_pyver}" == "3"
|
||||
--boost-python-libname=boost_python37
|
||||
%else
|
||||
--boost-python-libname=boost_python%{?with_pyver}
|
||||
%endif
|
||||
|
||||
%{__python} setup.py build
|
||||
|
||||
@ -55,25 +65,23 @@ export PYTHON_EGG_CACHE=/tmp
|
||||
%{__python} setup.py install \
|
||||
--root="%{buildroot}" \
|
||||
--install-headers=%{_includedir}/python \
|
||||
--install-lib=%{python_sitearch}
|
||||
--install-lib=%{python_sitearch} \
|
||||
--record=%{name}.filelist
|
||||
|
||||
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%files %{?pyappend} -f %{name}.filelist
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/_tagpy.so
|
||||
%dir %{python_sitearch}/tagpy
|
||||
%{python_sitearch}/tagpy/*.py
|
||||
%{python_sitearch}/tagpy/*.pyc
|
||||
%dir %{python_sitearch}/tagpy-%{version}-py*.egg-info
|
||||
%{python_sitearch}/tagpy-%{version}-py*.egg-info/PKG-INFO
|
||||
%{python_sitearch}/tagpy-%{version}-py*.egg-info/*.txt
|
||||
%dir %{python_sitearch}/tagpy/ogg
|
||||
%{python_sitearch}/tagpy/ogg/*.py
|
||||
%{python_sitearch}/tagpy/ogg/*.pyc
|
||||
%{python_sitearch}/tagpy-%{version}-py*.egg-info/*
|
||||
|
||||
%changelog
|
||||
* Wed Mar 31 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2018.1.1-1mamba
|
||||
- update to 2018.1.1
|
||||
|
||||
* Tue Dec 29 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2013.1-3mamba
|
||||
- mass rebuild with libtag 1.9.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user