rebuilt with python 2.7 [release 2013.1-2mamba;Mon Dec 30 2013]
This commit is contained in:
parent
d9e06ab40f
commit
14c9a34945
11
README.md
11
README.md
@ -1,2 +1,13 @@
|
||||
# python-tagpy
|
||||
|
||||
TagPy is a set of Python bindings for Scott Wheeler's TagLib.
|
||||
It builds upon Boost.Python, a wrapper generation library which is part of the renowned Boost set of C++ libraries.
|
||||
|
||||
Just like TagLib, TagPy can:
|
||||
|
||||
* read and write ID3 tags of version 1 and 2, with many supported frame types for version 2 (in MPEG Layer 2 and MPEG Layer 3, FLAC and MPC),
|
||||
* access Xiph Comments in Ogg Vorbis Files and Ogg Flac Files,
|
||||
* access APE tags in Musepack and MP3 files.
|
||||
|
||||
All these features have their own specific interfaces, but TagLib's generic tag reading and writing mechanism is also supported. It comes with a bunch of examples.
|
||||
|
||||
|
95
python-tagpy.spec
Normal file
95
python-tagpy.spec
Normal file
@ -0,0 +1,95 @@
|
||||
Name: python-tagpy
|
||||
Version: 2013.1
|
||||
Release: 2mamba
|
||||
Summary: Python Bindings for TagLib
|
||||
Group: System/Libraries/Python
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Automatic Build System <autodist@mambasoft.it>
|
||||
URL: http://pypi.python.org/pypi/tagpy
|
||||
Source: http://pypi.python.org/packages/source/t/tagpy/tagpy-%{version}.tar.gz
|
||||
Patch0: tagpy-0.94.8-aksetup_helper.patch
|
||||
License: MIT
|
||||
Requires: python >= %python_version
|
||||
BuildRequires: libboost-devel
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libpython-devel >= %python_version
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtag-devel
|
||||
BuildRequires: python-boost-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
TagPy is a set of Python bindings for Scott Wheeler's TagLib.
|
||||
It builds upon Boost.Python, a wrapper generation library which is part of the renowned Boost set of C++ libraries.
|
||||
|
||||
Just like TagLib, TagPy can:
|
||||
|
||||
* read and write ID3 tags of version 1 and 2, with many supported frame types for version 2 (in MPEG Layer 2 and MPEG Layer 3, FLAC and MPC),
|
||||
* access Xiph Comments in Ogg Vorbis Files and Ogg Flac Files,
|
||||
* access APE tags in Musepack and MP3 files.
|
||||
|
||||
All these features have their own specific interfaces, but TagLib's generic tag reading and writing mechanism is also supported. It comes with a bunch of examples.
|
||||
|
||||
%prep
|
||||
%setup -q -n tagpy-%{version}
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
export PYTHON_EGG_CACHE=/tmp
|
||||
./configure.py \
|
||||
--taglib-lib-dir=%{_libdir} \
|
||||
--taglib-inc-dir=%{_includedir}/taglib \
|
||||
--boost-lib-dir=%{_libdir} \
|
||||
--boost-inc-dir=%{_includedir}/boost \
|
||||
--boost-python-libname=boost_python
|
||||
|
||||
%{__python} setup.py build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python} setup.py install \
|
||||
--root="%{buildroot}" \
|
||||
--install-headers=%{_includedir}/python \
|
||||
--install-lib=%{python_sitearch}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/_tagpy.so
|
||||
%dir %{python_sitearch}/tagpy
|
||||
%{python_sitearch}/tagpy/*.py
|
||||
%{python_sitearch}/tagpy/*.pyc
|
||||
%dir %{python_sitearch}/tagpy-%{version}-py*.egg-info
|
||||
%{python_sitearch}/tagpy-%{version}-py*.egg-info/PKG-INFO
|
||||
%{python_sitearch}/tagpy-%{version}-py*.egg-info/*.txt
|
||||
%dir %{python_sitearch}/tagpy/ogg
|
||||
%{python_sitearch}/tagpy/ogg/*.py
|
||||
%{python_sitearch}/tagpy/ogg/*.pyc
|
||||
|
||||
%changelog
|
||||
* Mon Dec 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2013.1-2mamba
|
||||
- rebuilt with python 2.7
|
||||
|
||||
* Mon Jan 07 2013 Automatic Build System <autodist@mambasoft.it> 2013.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Mar 06 2011 Tiziana Ferro <tiziana.ferro@email.it> 0.94.8-1mamba
|
||||
- update to 0.94.8
|
||||
|
||||
* Wed Dec 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.94.7-2mamba
|
||||
- rebuilt with libboost 1.45.0
|
||||
|
||||
* Mon Jun 14 2010 Automatic Build System <autodist@mambasoft.it> 0.94.7-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jun 08 2009 Automatic Build System <autodist@mambasoft.it> 0.94.5-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Aug 18 2008 gil <puntogil@libero.it> 0.94.5-1mamba
|
||||
- buildrequires: file /usr/lib/libboost_python-mt.so is not owned by any package
|
17
tagpy-0.94.8-aksetup_helper.patch
Normal file
17
tagpy-0.94.8-aksetup_helper.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- ./aksetup_helper.py.orig 2010-12-17 17:12:20.000000000 +0100
|
||||
+++ ./aksetup_helper.py 2010-12-17 17:12:30.000000000 +0100
|
||||
@@ -1,11 +1,11 @@
|
||||
# dealings with ez_setup ------------------------------------------------------
|
||||
-import distribute_setup
|
||||
-distribute_setup.use_setuptools()
|
||||
+#import distribute_setup
|
||||
+#distribute_setup.use_setuptools()
|
||||
|
||||
import setuptools
|
||||
from setuptools import Extension
|
||||
|
||||
-if 'distribute' not in setuptools.__file__:
|
||||
+if False and 'distribute' not in setuptools.__file__:
|
||||
print "-------------------------------------------------------------------------"
|
||||
print "Setuptools conflict detected."
|
||||
print "-------------------------------------------------------------------------"
|
Loading…
Reference in New Issue
Block a user