diff --git a/python-sphinxcontrib-htmlhelp.spec b/python-sphinxcontrib-htmlhelp.spec
index 4e1f6bc..59c45df 100644
--- a/python-sphinxcontrib-htmlhelp.spec
+++ b/python-sphinxcontrib-htmlhelp.spec
@@ -1,6 +1,7 @@
+%define pkgname %(echo %name | cut -d- -f2- | tr - _)
Name: python-sphinxcontrib-htmlhelp
-Version: 2.0.0
-Release: 2mamba
+Version: 2.0.1
+Release: 1mamba
Summary: A sphinx extension which renders HTML help files
Group: System/Libraries
Vendor: openmamba
@@ -26,26 +27,31 @@ Obsoletes: python-sphinxcontrib-htmlhelp < 2.0.0
%setup -q -n sphinxcontrib-htmlhelp-%{version}
%build
-CFLAGS="%{optflags}" %{__python} setup.py build
+CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
-%{__python} setup.py install \
- -O1 --skip-build \
- --root="%{buildroot}" \
- --install-headers=%{python_inc} \
- --install-lib=%{python_sitearch} \
- --record=%{name}.filelist
+%{__python} -m installer --destdir=%{buildroot} dist/*.whl
-sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
+#%if "%{?with_pyver}" != "3"
+## Rename any conflicting file outside of python site packages tree
+#for f in %{_bindir}/pdm; do
+# mv %{buildroot}${f}{,-%{?pyappend}}
+#done
+#%endif
-%files %{?pyappend} -f %{name}.filelist
+%files %{?pyappend}
%defattr(-,root,root)
-%dir %{python_sitearch}/sphinxcontrib_htmlhelp-%{version}-py*.egg-info
-%{python_sitearch}/sphinxcontrib_htmlhelp-%{version}-py*.egg-info/*
+%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
+%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
+%dir %{python_sitelib}/sphinxcontrib/htmlhelp
+%{python_sitelib}/sphinxcontrib/htmlhelp/*
%doc LICENSE
%changelog
+* Tue Mar 07 2023 Automatic Build System 2.0.1-1mamba
+- automatic version update by autodist
+
* Thu Jun 03 2021 Silvan Calarco 2.0.0-2mamba
- obsolete python-sphinxconfig-htmlhelp