82 lines
2.5 KiB
RPMSpec
82 lines
2.5 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
|
Name: python-scikit_build
|
|
Version: 0.18.1
|
|
Release: 1mamba
|
|
Summary: Improved build system generator for Python C/C++/Fortran/Cython extensions
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/scikit-build/scikit-build
|
|
Source: https://pypi.debian.net/scikit-build/scikit_build-%{version}.tar.gz
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: python3.11dist(distro)
|
|
BuildRequires: python3.11dist(packaging)
|
|
BuildRequires: python3.11dist(setuptools)
|
|
BuildRequires: python3.11dist(wheel)
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libpython3-devel >= 3.11.5
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%if "0%{?with_pyver}" == "03"
|
|
%define py_requires_append \
|
|
Obsoletes: python-scikit_build-py310 <= 0.17.6-2mamba
|
|
%endif
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n scikit_build-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
#%if "%{?with_pyver}" != "3"
|
|
## Rename any conflicting file outside of python site packages tree
|
|
#for f in %{_bindir}/pdm; do
|
|
# mv %{buildroot}${f}{,-%{?pyappend}}
|
|
#done
|
|
#%endif
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
|
|
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
|
|
%dir %{python_sitelib}/skbuild
|
|
%{python_sitelib}/skbuild/*
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Thu Aug 29 2024 Automatic Build System <autodist@openmamba.org> 0.18.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jun 22 2024 Automatic Build System <autodist@openmamba.org> 0.18.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 24 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.17.6-3mamba
|
|
- obsolete python-scikit_build-py310
|
|
|
|
* Sat Sep 30 2023 Automatic Build System <autodist@mambasoft.it> 0.17.6-2mamba
|
|
- rebuilt with python3 = 3.11.5
|
|
|
|
* Thu Jun 01 2023 Automatic Build System <autodist@mambasoft.it> 0.17.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 18 2023 Automatic Build System <autodist@mambasoft.it> 0.17.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 11 2023 Automatic Build System <autodist@mambasoft.it> 0.17.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 06 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.17.3-1mamba
|
|
- package created using the webbuild interface
|