python 2.7 mass rebuild [release 0.1.1-3mamba;Fri May 17 2013]
This commit is contained in:
parent
487c80ccef
commit
5e9beb23ba
25
python-pynotify-0.1.1-fix-GTK-symbols.patch
Normal file
25
python-pynotify-0.1.1-fix-GTK-symbols.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -up notify-python-0.1.1/src/__init__.py.BAD notify-python-0.1.1/src/__init__.py
|
||||
--- notify-python-0.1.1/src/__init__.py.BAD 2010-08-31 09:04:45.353844005 -0400
|
||||
+++ notify-python-0.1.1/src/__init__.py 2010-08-31 09:04:49.281844300 -0400
|
||||
@@ -1 +1,21 @@
|
||||
+"""
|
||||
+Fedora's libnotify.so is not linked against GTK2 or GTK3. The idea
|
||||
+was to support being linked against different parallel-installable
|
||||
+GTK stacks.
|
||||
+
|
||||
+Unfortunately, python needs to jump through some special hoops in order
|
||||
+to share symbols with extension modules, specifically, pygtk, which does
|
||||
+link against GTK2.
|
||||
+
|
||||
+Without using sys.setdlopenflags(sys.getdlopenflags() | ctypes.RTLD_GLOBAL),
|
||||
+the result is:
|
||||
+libnotify-WARNING **: Missing symbol 'gdk_screen_make_display_name'
|
||||
+
|
||||
+Thanks to David Malcolm for figuring out the workaround.
|
||||
+"""
|
||||
+import ctypes
|
||||
+import sys
|
||||
+sys.setdlopenflags(sys.getdlopenflags() | ctypes.RTLD_GLOBAL)
|
||||
+import gtk
|
||||
+
|
||||
from _pynotify import *
|
36
python-pynotify-0.1.1-libnotify-0.7.patch
Normal file
36
python-pynotify-0.1.1-libnotify-0.7.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -up notify-python-0.1.1/src/pynotify.defs.notify070 notify-python-0.1.1/src/pynotify.defs
|
||||
--- notify-python-0.1.1/src/pynotify.defs.notify070 2010-11-02 17:11:14.928179237 -0400
|
||||
+++ notify-python-0.1.1/src/pynotify.defs 2010-11-02 17:11:51.153180231 -0400
|
||||
@@ -38,7 +38,6 @@
|
||||
'("const-gchar*" "summary")
|
||||
'("const-gchar*" "message" (null-ok) (default "NULL"))
|
||||
'("const-gchar*" "icon" (null-ok) (default "NULL"))
|
||||
- '("GtkWidget*" "attach" (null-ok) (default "NULL"))
|
||||
)
|
||||
)
|
||||
|
||||
@@ -53,24 +52,6 @@
|
||||
)
|
||||
)
|
||||
|
||||
-(define-method attach_to_widget
|
||||
- (of-object "NotifyNotification")
|
||||
- (c-name "notify_notification_attach_to_widget")
|
||||
- (return-type "none")
|
||||
- (parameters
|
||||
- '("GtkWidget*" "attach")
|
||||
- )
|
||||
-)
|
||||
-
|
||||
-(define-method attach_to_status_icon
|
||||
- (of-object "NotifyNotification")
|
||||
- (c-name "notify_notification_attach_to_status_icon")
|
||||
- (return-type "none")
|
||||
- (parameters
|
||||
- '("GtkStatusIcon*" "attach")
|
||||
- )
|
||||
-)
|
||||
-
|
||||
(define-method show
|
||||
(of-object "NotifyNotification")
|
||||
(c-name "notify_notification_show")
|
67
python-pynotify.spec
Normal file
67
python-pynotify.spec
Normal file
@ -0,0 +1,67 @@
|
||||
Name: python-pynotify
|
||||
Version: 0.1.1
|
||||
Release: 3mamba
|
||||
Summary: Python bindings for libnotify
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://galago-project.org/files/releases/source/notify-python
|
||||
Source: http://galago-project.org/files/releases/source/notify-python/notify-python-%{version}.tar.gz
|
||||
Patch0: %{name}-0.1.1-libnotify-0.7.patch
|
||||
Patch1: %{name}-0.1.1-fix-GTK-symbols.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libnotify-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpython-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: pygtk-devel
|
||||
BuildRequires: pygobject-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires: pygtk
|
||||
|
||||
%description
|
||||
Python bindings for libnotify.
|
||||
|
||||
%prep
|
||||
%setup -q -n notify-python-%{version}
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/gtk-2.0/pynotify/*
|
||||
%{_datadir}/pygtk/2.0/defs/pynotify.defs
|
||||
%{_libdir}/pkgconfig/notify-python.pc
|
||||
%doc AUTHORS COPYING ChangeLog NEWS
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.1-3mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Mon Oct 03 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.1-2mamba
|
||||
- added patch for libnotify >= 0.7
|
||||
|
||||
* Tue Jun 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.1-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user