update to 2.2.8 [release 2.2.8-1mamba;Fri Sep 29 2023]
This commit is contained in:
parent
2e3da6818c
commit
67196e5e79
@ -1,2 +1,4 @@
|
||||
# python-pymssql
|
||||
|
||||
A simple database interface to Microsoft SQL Server (MS-SQL) for Python that builds on top of FreeTDS to provide a Python DB-API (PEP-249) interface to SQL Server.
|
||||
|
||||
|
12
pymssql-2.0.1-github_issue_142.patch
Normal file
12
pymssql-2.0.1-github_issue_142.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- pymssql-2.0.1/setup.py 2013-10-27 17:34:37.000000000 +0100
|
||||
+++ pymssql-2.0.1-b/setup.py 2014-01-18 17:01:35.000000000 +0100
|
||||
@@ -442,9 +442,6 @@
|
||||
"Operating System :: POSIX",
|
||||
"Operating System :: Unix",
|
||||
],
|
||||
- data_files = [
|
||||
- ('', ['_mssql.pyx', 'pymssql.pyx'])
|
||||
- ],
|
||||
zip_safe = False,
|
||||
tests_require=['nose', 'unittest2'],
|
||||
test_suite='nose.collector',
|
70
python-pymssql.spec
Normal file
70
python-pymssql.spec
Normal file
@ -0,0 +1,70 @@
|
||||
%define pkgname pymssql
|
||||
|
||||
Name: python-pymssql
|
||||
Version: 2.2.8
|
||||
Release: 1mamba
|
||||
Summary: A simple database interface to MS-SQL for Python
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.pymssql.org/
|
||||
Source: https://pypi.debian.net/pymssql/pymssql-%{version}.tar.gz
|
||||
Patch0: pymssql-2.0.1-github_issue_142.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libfreetds-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpython311-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python3-devel >= 3.11.5-3mamba
|
||||
|
||||
%description
|
||||
A simple database interface to Microsoft SQL Server (MS-SQL) for Python that builds on top of FreeTDS to provide a Python DB-API (PEP-249) interface to SQL Server.
|
||||
|
||||
%if 0%{?with_pyver}
|
||||
%define py_requires_append \
|
||||
Obsoletes: pymssql < 2.2.8
|
||||
%pyver_package
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n pymssql-%{version}
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags}" %{__python} setup.py build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python} setup.py install \
|
||||
-O1 --skip-build \
|
||||
--root="%{buildroot}" \
|
||||
--install-headers=%{_includedir}/python \
|
||||
--install-lib=%{python_sitearch} \
|
||||
--record=%{name}.filelist
|
||||
|
||||
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
||||
|
||||
%files %{?pyappend} -f %{name}.filelist
|
||||
%defattr(-,root,root)
|
||||
%dir %{python_sitearch}/%{pkgname}-%{version}-py*.egg-info
|
||||
%{python_sitearch}/%{pkgname}-%{version}-py*.egg-info/*
|
||||
|
||||
%changelog
|
||||
* Fri Sep 29 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.8-1mamba
|
||||
- update to 2.2.8
|
||||
|
||||
* Fri Sep 29 2023 Automatic Build System <autodist@mambasoft.it> 2.2.5-2mamba
|
||||
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
||||
|
||||
* Mon May 23 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.5-1mamba
|
||||
- update to 2.2.5
|
||||
|
||||
* Sat Jan 18 2014 Davide Madrisan <davide.madrisan@gmail.com> 2.0.1-2mamba
|
||||
- donot instqll *.pyx files
|
||||
|
||||
* Sat Jan 18 2014 Davide Madrisan <davide.madrisan@gmail.com> 2.0.1-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user