python-pylint/python-pylint.spec

240 lines
8.9 KiB
RPMSpec

%define pkgname %(echo %name | cut -d- -f2- | tr - _)
Name: python-pylint
Version: 3.0.4
Release: 1mamba
Summary: Python code static checker
Group: Development/Libraries/Python
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://pypi.org/project/pylint/
Source: https://pypi.debian.net/pylint/pylint-%{version}.tar.gz
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: (python3.11dist(isort) < 5.13 or python3.11dist(isort) > 5.13)
BuildRequires: libpython311-devel
BuildRequires: python3.11dist(astroid)
BuildRequires: python3.11dist(dill)
BuildRequires: python3.11dist(isort)
BuildRequires: python3.11dist(mccabe)
BuildRequires: python3.11dist(platformdirs)
BuildRequires: python3.11dist(tomlkit)
## AUTOBUILDREQ-END
%description
Pylint is a python tool that checks if a module satisfies a coding standard.
Pylint is similar to PyChecker but offers more features, like checking line-code's length, checking if variable names are well-formed according to your coding standard, or checking if declared interfaces are truly implemented, and much more (see the complete check list).
The big advantage with Pylint is that it is highly configurable, customizable, and you can easily write a small plugin to add a personal feature.
%if "%{?with_pyver}"
%if "%{?with_pyver}" == "3"
%define py_requires_append \
Obsoletes: python-pylint-tools <= 2.14.5-2mamba \
Obsoletes: pylint-tools < 2.12.2-2mamba \
Obsoletes: pylint-gui < 2.6.0 \
Provides: pylint \
Obsoletes: pylint < 2.6.0 \
Provides: pylint-py3 \
Obsoletes: pylint-py3 < 2.12.2-2mamba
%endif
%pyver_package
%endif
%prep
%setup -q -n pylint-%{version}
# Remove conflicting build time dependencies
sed -i -E '/^requires/s/~=[0-9.]+//g' pyproject.toml
# Remove overly restrictive dependency
sed -i -e '/>=/{s/>.*//;p}' -e '/python_requires/d' setup.cfg
%build
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
# Do not package testsuite
rm -rf %{buildroot}%{python_sitelib}/pylint/test
%if "%{?with_pyver}" != "3"
# Rename any conflicting file outside of python site packages tree
for f in %{_bindir}/{pylint,pylint-config,pyreverse,symilar}; do
mv %{buildroot}${f}{,-%{?pyappend}}
done
%endif
%files %{?pyappend}
%defattr(-,root,root)
%{_bindir}/pylint*
%{_bindir}/pyreverse*
%{_bindir}/symilar*
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
%dir %{python_sitelib}/%{pkgname}
%{python_sitelib}/%{pkgname}/*
%doc LICENSE
%changelog
* Sat Feb 24 2024 Automatic Build System <autodist@openmamba.org> 3.0.4-1mamba
- automatic version update by autodist
* Mon Dec 11 2023 Automatic Build System <autodist@mambasoft.it> 3.0.3-1mamba
- automatic version update by autodist
* Sun Oct 22 2023 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba
- automatic version update by autodist
* Fri Oct 06 2023 Automatic Build System <autodist@mambasoft.it> 3.0.1-1mamba
- automatic version update by autodist
* Wed Oct 04 2023 Automatic Build System <autodist@mambasoft.it> 3.0.0-1mamba
- automatic version update by autodist
* Sun Oct 01 2023 Automatic Build System <autodist@mambasoft.it> 2.17.7-1mamba
- automatic version update by autodist
* Mon Sep 25 2023 Automatic Build System <autodist@mambasoft.it> 2.17.6-1mamba
- automatic version update by autodist
* Sun Sep 10 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.17.5-2mamba
- fix conflicting binary pylint-config
* Sat Sep 09 2023 Automatic Build System <autodist@mambasoft.it> 2.17.5-1mamba
- automatic version update by autodist
* Tue Apr 11 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.14.5-3mamba
- fix cross-obsolete in -py3 and -py310 subpackages; remove python-pylint-tools subpackage in favour of renamed binaries
* Fri Apr 07 2023 Sdk Build System <sdk@mambasoft.it> 2.14.5-2mamba
- rebuilt with python 3.10
* Mon Jul 18 2022 Automatic Build System <autodist@mambasoft.it> 2.14.5-1mamba
- automatic version update by autodist
* Wed Jun 29 2022 Automatic Build System <autodist@mambasoft.it> 2.14.4-1mamba
- automatic version update by autodist
* Sun Jun 19 2022 Automatic Build System <autodist@mambasoft.it> 2.14.3-1mamba
- automatic version update by autodist
* Thu Jun 16 2022 Automatic Build System <autodist@mambasoft.it> 2.14.2-1mamba
- automatic version update by autodist
* Thu Jun 09 2022 Automatic Build System <autodist@mambasoft.it> 2.14.1-1mamba
- automatic version update by autodist
* Fri Jun 03 2022 Automatic Build System <autodist@mambasoft.it> 2.14.0-1mamba
- automatic version update by autodist
* Sat May 14 2022 Automatic Build System <autodist@mambasoft.it> 2.13.9-1mamba
- automatic version update by autodist
* Tue May 03 2022 Automatic Build System <autodist@mambasoft.it> 2.13.8-1mamba
- automatic version update by autodist
* Thu Apr 21 2022 Automatic Build System <autodist@mambasoft.it> 2.13.7-1mamba
- automatic version update by autodist
* Thu Apr 07 2022 Automatic Build System <autodist@mambasoft.it> 2.13.5-1mamba
- automatic version update by autodist
* Sat Apr 02 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.13.4-1mamba
- update to 2.13.4
* Sun Feb 13 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.2-2mamba
- rebuilt with distdeps
* Sat Dec 04 2021 Automatic Build System <autodist@mambasoft.it> 2.12.2-1mamba
- automatic version update by autodist
* Fri Nov 26 2021 Automatic Build System <autodist@mambasoft.it> 2.12.1-1mamba
- automatic version update by autodist
* Thu Nov 25 2021 Automatic Build System <autodist@mambasoft.it> 2.12.0-1mamba
- automatic version update by autodist
* Fri Sep 17 2021 Automatic Build System <autodist@mambasoft.it> 2.11.1-1mamba
- automatic version update by autodist
* Sun Aug 22 2021 Automatic Build System <autodist@mambasoft.it> 2.10.2-1mamba
- automatic version update by autodist
* Sun Aug 22 2021 Automatic Build System <autodist@mambasoft.it> 2.10.1-1mamba
- automatic version update by autodist
* Sat Aug 21 2021 Automatic Build System <autodist@mambasoft.it> 2.10.0-1mamba
- automatic version update by autodist
* Thu Jul 29 2021 Automatic Build System <autodist@mambasoft.it> 2.9.6-1mamba
- automatic version update by autodist
* Wed Jul 21 2021 Automatic Build System <autodist@mambasoft.it> 2.9.5-1mamba
- automatic version update by autodist
* Wed Jul 21 2021 Automatic Build System <autodist@mambasoft.it> 2.9.4-1mamba
- automatic version update by autodist
* Sun Jul 18 2021 Automatic Build System <autodist@mambasoft.it> 2.9.3-1mamba
- automatic version update by autodist
* Tue Jun 01 2021 Automatic Build System <autodist@mambasoft.it> 2.8.3-1mamba
- automatic version update by autodist
* Sun May 23 2021 Automatic Build System <autodist@mambasoft.it> 2.8.2-1mamba
- automatic version update by autodist
* Tue Mar 30 2021 Automatic Build System <autodist@mambasoft.it> 2.7.4-1mamba
- automatic version update by autodist
* Tue Mar 30 2021 Automatic Build System <autodist@mambasoft.it> 2.7.3-1mamba
- automatic version update by autodist
* Mon Mar 01 2021 Automatic Build System <autodist@mambasoft.it> 2.7.2-1mamba
- automatic version update by autodist
* Wed Feb 24 2021 Automatic Build System <autodist@mambasoft.it> 2.7.1-1mamba
- automatic version update by autodist
* Mon Feb 22 2021 Automatic Build System <autodist@mambasoft.it> 2.7.0-1mamba
- automatic version update by autodist
* Sun Feb 21 2021 Automatic Build System <autodist@mambasoft.it> 2.6.2-1mamba
- automatic version update by autodist
* Thu Jan 21 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.0-1mamba
- update to 2.6.0
* Sun Dec 07 2014 Automatic Build System <autodist@mambasoft.it> 1.4.0-1mamba
- automatic update by autodist
* Mon May 26 2014 Automatic Build System <autodist@mambasoft.it> 1.2.0-1mamba
- automatic update by autodist
* Tue Feb 25 2014 Automatic Build System <autodist@mambasoft.it> 1.1.0-1mamba
- automatic update by autodist
* Sun Sep 01 2013 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
- automatic update by autodist
* Fri May 24 2013 Automatic Build System <autodist@mambasoft.it> 0.28.0-1mamba
- automatic version update by autodist
* Fri Mar 08 2013 Automatic Build System <autodist@mambasoft.it> 0.27.0-1mamba
- automatic version update by autodist
* Sun Oct 14 2012 Automatic Build System <autodist@mambasoft.it> 0.26.0-1mamba
- automatic version update by autodist
* Sun Sep 02 2012 Automatic Build System <autodist@mambasoft.it> 0.25.2-1mamba
- automatic version update by autodist
* Sat Aug 06 2011 Automatic Build System <autodist@mambasoft.it> 0.24.0-1mamba
- automatic version update by autodist
* Mon Feb 28 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.23.0-1mamba
- update to 0.23.0
* Mon May 31 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.21.0-1mamba
- package created by autospec