214 lines
7.7 KiB
RPMSpec
214 lines
7.7 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2-)
|
|
Name: python-pygments
|
|
Version: 2.18.0
|
|
Release: 1mamba
|
|
Summary: A syntax highlighting package written in Python
|
|
Group: System/Libraries/Python
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://pygments.org/
|
|
Source: http://pypi.debian.net/Pygments/pygments-%{version}.tar.gz
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python3-devel >= 3.11.5-3mamba
|
|
BuildArch: noarch
|
|
|
|
%description
|
|
Pygments is a generic syntax highlighter for general use in all kinds of software such as forum systems, wikis or other applications that need to prettify source code.
|
|
|
|
Highlights are:
|
|
* a wide range of common languages and markup formats is supported
|
|
* special attention is paid to details, increasing quality by a fair amount
|
|
* support for new languages and formats are added easily
|
|
* a number of output formats, presently HTML, LaTeX, RTF, SVG, all image formats that PIL supports and ANSI sequences
|
|
* it is usable as a command-line tool and as a library
|
|
* ... and it highlights even Brainfuck!
|
|
|
|
%package %{?pyappend:%pyappend-}tools
|
|
Group: Development/Tools
|
|
Summary: Utilities for %{name}
|
|
Requires: %{name}%{?pyappend:-%pyappend} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description %{?pyappend:%pyappend-}tools
|
|
This package contains utilities for %{name}.
|
|
|
|
%if "%{?with_pyver}"
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n pygments-%{version}
|
|
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
# Rename any conflicting file outside of python site packages tree
|
|
for f in %{_bindir}/pygmentize; do
|
|
mv %{buildroot}${f}{,-%{?pyappend}}
|
|
done
|
|
install -D -m 0644 doc/pygmentize.1 \
|
|
%{buildroot}%{_mandir}/man1/pygmentize-%{?pyappend}.1
|
|
%else
|
|
# install manual page
|
|
install -D -m 0644 doc/pygmentize.1 \
|
|
%{buildroot}%{_mandir}/man1/pygmentize.1
|
|
%endif
|
|
|
|
#sed -i "\,lexer.py[co]$,d" %{name}.filelist
|
|
#sed -i "\,style.py[co]$,d" %{name}.filelist
|
|
#sed -i "\,cmdline.py[co]$,d" %{name}.filelist
|
|
#sed -i "\,html.py[co]$,d" %{name}.filelist
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%{_bindir}/pygmentize*
|
|
%{_mandir}/man1/pygmentize*.1*
|
|
%dir %{python_sitelib}/pygments-%{version}.dist-info
|
|
%{python_sitelib}/pygments-%{version}.dist-info/*
|
|
%dir %{python_sitelib}/pygments
|
|
%{python_sitelib}/pygments/*
|
|
%doc AUTHORS LICENSE
|
|
|
|
%changelog
|
|
* Thu May 09 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.18.0-1mamba
|
|
- update to 2.18.0
|
|
|
|
* Tue Sep 26 2023 Automatic Build System <autodist@mambasoft.it> 2.16.1-2mamba
|
|
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
|
|
|
* Sun Sep 03 2023 Automatic Build System <autodist@mambasoft.it> 2.16.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 09 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.14.0-2mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Mon Jan 02 2023 Automatic Build System <autodist@mambasoft.it> 2.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 16 2022 Automatic Build System <autodist@mambasoft.it> 2.13.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 24 2022 Automatic Build System <autodist@mambasoft.it> 2.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 07 2022 Automatic Build System <autodist@mambasoft.it> 2.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 01 2022 Automatic Build System <autodist@mambasoft.it> 2.11.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 31 2021 Automatic Build System <autodist@mambasoft.it> 2.11.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 16 2021 Automatic Build System <autodist@mambasoft.it> 2.10.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 04 2021 Automatic Build System <autodist@mambasoft.it> 2.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 07 2021 Automatic Build System <autodist@mambasoft.it> 2.8.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 21 2021 Automatic Build System <autodist@mambasoft.it> 2.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 12 2021 Automatic Build System <autodist@mambasoft.it> 2.7.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 07 2020 Automatic Build System <autodist@mambasoft.it> 2.7.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 25 2020 Automatic Build System <autodist@mambasoft.it> 2.7.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 18 2020 Automatic Build System <autodist@mambasoft.it> 2.7.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 13 2020 Automatic Build System <autodist@mambasoft.it> 2.7.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 13 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1-2mamba
|
|
- python 2.7 no longer supported: remove; needed to build firefox, will do a legacy package of 2.5.2
|
|
|
|
* Sun Mar 29 2020 Automatic Build System <autodist@mambasoft.it> 2.6.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 29 2019 Automatic Build System <autodist@mambasoft.it> 2.5.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 27 2019 Automatic Build System <autodist@mambasoft.it> 2.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 09 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-2mamba
|
|
- rebuilt with python3 3.7.4
|
|
|
|
* Tue May 28 2019 Automatic Build System <autodist@mambasoft.it> 2.4.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 25 2019 Automatic Build System <autodist@mambasoft.it> 2.4.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 10 2019 Automatic Build System <autodist@mambasoft.it> 2.4.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Dec 23 2018 Automatic Build System <autodist@mambasoft.it> 2.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 27 2018 Automatic Build System <autodist@mambasoft.it> 2.3.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 26 2017 Automatic Build System <autodist@mambasoft.it> 2.2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 11 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.3-3mamba
|
|
- move conflicting py2/py3 binart tool to -tools subpackage
|
|
|
|
* Sun Jul 24 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.3-2mamba
|
|
- added py3 support
|
|
|
|
* Thu Mar 03 2016 Automatic Build System <autodist@mambasoft.it> 2.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 15 2016 Automatic Build System <autodist@mambasoft.it> 2.1.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 17 2016 Automatic Build System <autodist@mambasoft.it> 2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 20 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.2-1mamba
|
|
- update to 2.0.2
|
|
|
|
* Tue Nov 04 2014 Automatic Build System <autodist@mambasoft.it> 2.0rc1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6rc1-2mamba
|
|
- python 2.7 mass rebuild
|
|
|
|
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6rc1-1mamba
|
|
- python 2.7 mass rebuild
|
|
|
|
* Mon Apr 22 2013 Automatic Build System <autodist@mambasoft.it> 1.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 11 2012 Automatic Build System <autodist@mambasoft.it> 1.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 10 2011 Automatic Build System <autodist@mambasoft.it> 1.4-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Jun 05 2010 Automatic Build System <autodist@mambasoft.it> 1.3.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Jan 19 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.2.2-1mamba
|
|
- package created by autospec
|