python-ply/python-ply.spec

97 lines
3.4 KiB
RPMSpec

%define pkgname %(echo %name | cut -d- -f2- | tr - _)
Name: python-ply
Version: 3.11
Release: 4mamba
Summary: Python Lex & Yacc
Group: System/Libraries/Python
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.dabeaz.com/ply/
Source: http://www.dabeaz.com/ply/ply-%{version}.tar.gz
License: BSD, LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: libpython311-devel
## AUTOBUILDREQ-END
BuildRequires: libpython3-devel >= 3.11.5
%description
PLY is a straightforward lex/yacc implementation. Here is a list of its essential features:
* It is implemented entirely in Python.
* It uses LR-parsing which is reasonably efficient and well suited for larger grammars.
* PLY provides most of the standard lex/yacc features including support for empty productions, precedence rules, error recovery, and support for ambiguous grammars.
* PLY is straightforward to use and provides very extensive error checking.
* PLY doesn't try to do anything more or less than provide the basic lex/yacc functionality. In other words, it's not a large parsing framework or a component of some larger system..
%if 0%{?with_pyver}
%pyver_package
%endif
%prep
%setup -q -n ply-%{version}
sed -i 's|/usr/local/bin/python|%{__python}|g' $(find . -name "*.py")
chmod -x example/yply/yply.py example/newclasscalc/calc.py example/classcalc/calc.py example/cleanup.sh
%build
%{__python} setup.py build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%{__python} setup.py install \
-O1 --skip-build \
--root="%{buildroot}" \
--install-headers=%{python_inc} \
--install-lib=%{python_sitearch} \
--record=%{name}.filelist
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files %{?pyappend} -f %{name}.filelist
%defattr(-,root,root)
%dir %{python_sitearch}/%{pkgname}-%{version}-py*.egg-info
%{python_sitearch}/%{pkgname}-%{version}-py*.egg-info/*
%changelog
* Sun Sep 24 2023 Automatic Build System <autodist@mambasoft.it> 3.11-4mamba
- rebuilt with python3 = 3.11.5
* Sat May 21 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11-3mamba
- rebuilt with python 3.10 and distdeps
* Fri Jan 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.11-2mamba
- rebuilt with -py3
* Mon Feb 26 2018 Automatic Build System <autodist@mambasoft.it> 3.11-1mamba
- automatic version update by autodist
* Sat Feb 04 2017 Automatic Build System <autodist@mambasoft.it> 3.10-1mamba
- automatic version update by autodist
* Thu Sep 01 2016 Automatic Build System <autodist@mambasoft.it> 3.9-1mamba
- automatic version update by autodist
* Sat Oct 03 2015 Automatic Build System <autodist@mambasoft.it> 3.8-1mamba
- automatic version update by autodist
* Sat Aug 29 2015 Automatic Build System <autodist@mambasoft.it> 3.7-1mamba
- automatic version update by autodist
* Mon Apr 27 2015 Automatic Build System <autodist@mambasoft.it> 3.6-1mamba
- automatic version update by autodist
* Thu Apr 23 2015 Automatic Build System <autodist@mambasoft.it> 3.5-1mamba
- automatic version update by autodist
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4-2mamba
- python 2.7 mass rebuild
* Sat Feb 23 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4-1mamba
- update to 3.4
* Mon Jul 20 2009 gil <puntogil@libero.it> 3.2-1mamba
- package created by autospec