205 lines
7.2 KiB
RPMSpec
205 lines
7.2 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
|
Name: python-matplotlib
|
|
Version: 3.9.2
|
|
Release: 1mamba
|
|
Summary: Python plotting library
|
|
Group: System/Libraries/Python
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://matplotlib.org/
|
|
Source0: https://github.com/matplotlib/matplotlib.git/v%{version}/matplotlib-%{version}.tar.bz2
|
|
Source1: python-matplotlib-1.0.1-setup.cfg
|
|
License: Python
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: python3.11dist(contourpy)
|
|
BuildRequires: python3.11dist(cycler)
|
|
BuildRequires: python3.11dist(fonttools)
|
|
BuildRequires: python3.11dist(kiwisolver)
|
|
BuildRequires: python3.11dist(numpy)
|
|
BuildRequires: python3.11dist(packaging)
|
|
BuildRequires: python3.11dist(pillow)
|
|
BuildRequires: python3.11dist(pyparsing)
|
|
BuildRequires: python3.11dist(python-dateutil)
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libpython3-devel >= 3.11.5
|
|
%if 0%{?with_pyver}
|
|
BuildRequires: python3-tk
|
|
%endif
|
|
Requires: dejavu-fonts-ttf
|
|
|
|
%description
|
|
Matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats and interactive environments across platforms.
|
|
Matplotlib can be used in python scripts, the python and ipython shell (ala MATLAB or Mathematica), web application servers, and six graphical user interface toolkits.
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n matplotlib-%{version}
|
|
|
|
chmod -x lib/matplotlib/mpl-data/images/*.svg
|
|
cp %{SOURCE1} ./setup.cfg
|
|
|
|
%if 0%{?with_pyver}
|
|
sed -i "s|gtk = True|gtk = False|" setup.cfg
|
|
sed -i "s|gtkagg = True|gtkagg = False|" setup.cfg
|
|
%endif
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
#%if "%{?with_pyver}" != "3"
|
|
## Rename any conflicting file outside of python site packages tree
|
|
#for f in %{_bindir}/pdm; do
|
|
# mv %{buildroot}${f}{,-%{?pyappend}}
|
|
#done
|
|
#%endif
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%dir %{python_sitearch}/%{pkgname}-%{version}.dist-info
|
|
%{python_sitearch}/%{pkgname}-%{version}.dist-info/*
|
|
%{python3_sitearch}/pylab.py
|
|
%dir %{python_sitearch}/%{pkgname}
|
|
%{python_sitearch}/%{pkgname}/*
|
|
%dir %{python_sitearch}/mpl_toolkits
|
|
%{python_sitearch}/mpl_toolkits/*
|
|
%{python3_sitearch}/__pycache__/pylab.cpython-311*.pyc
|
|
%doc LICENSE/LICENSE
|
|
|
|
%changelog
|
|
* Wed Aug 14 2024 Automatic Build System <autodist@openmamba.org> 3.9.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 07 2024 Automatic Build System <autodist@openmamba.org> 3.9.1.post1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 21 2024 Automatic Build System <autodist@openmamba.org> 3.9.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 07 2024 Automatic Build System <autodist@openmamba.org> 3.8.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 15 2024 Automatic Build System <autodist@openmamba.org> 3.8.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 18 2023 Automatic Build System <autodist@mambasoft.it> 3.8.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 01 2023 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 06 2023 Automatic Build System <autodist@mambasoft.it> 3.8.0-2mamba
|
|
- rebuilt with python3 = 3.11.5
|
|
|
|
* Fri Sep 15 2023 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 12 2023 Automatic Build System <autodist@mambasoft.it> 3.7.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 05 2023 Automatic Build System <autodist@mambasoft.it> 3.7.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 11 2022 Automatic Build System <autodist@mambasoft.it> 3.5.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 04 2022 Automatic Build System <autodist@mambasoft.it> 3.5.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Dec 12 2021 Automatic Build System <autodist@mambasoft.it> 3.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 16 2021 Automatic Build System <autodist@mambasoft.it> 3.5.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 28 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.3-1mamba
|
|
- update to 3.4.3
|
|
|
|
* Sun May 09 2021 Automatic Build System <autodist@mambasoft.it> 3.4.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 10 2021 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 29 2021 Automatic Build System <autodist@mambasoft.it> 3.3.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 13 2020 Automatic Build System <autodist@mambasoft.it> 3.3.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 18 2020 Automatic Build System <autodist@mambasoft.it> 3.3.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 15 2020 Automatic Build System <autodist@mambasoft.it> 3.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 19 2020 Automatic Build System <autodist@mambasoft.it> 3.3.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 18 2020 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 19 2020 Automatic Build System <autodist@mambasoft.it> 3.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 03 2020 Automatic Build System <autodist@mambasoft.it> 3.1.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 31 2019 Automatic Build System <autodist@mambasoft.it> 3.1.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 11 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1.1-1mamba
|
|
- update to 3.1.1
|
|
|
|
* Sun Mar 17 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.3-1mamba
|
|
- update to 2.2.3
|
|
|
|
* Sat Oct 22 2016 Automatic Build System <autodist@mambasoft.it> 1.5.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 12 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-1mamba
|
|
- update to 1.5.2
|
|
|
|
* Wed Aug 03 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-5mamba
|
|
- fix pyNcairo requirement according to %pyver
|
|
|
|
* Sun Jul 24 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.1-4mamba
|
|
- fixed requirement for py[2|3]cairo
|
|
|
|
* Mon Jul 18 2016 Davide Madrisan <davide.madrisan@gmail.com> 1.5.1-3mamba
|
|
- add some missing runtime requirements
|
|
|
|
* Fri Mar 18 2016 Davide Madrisan <davide.madrisan@gmail.com> 1.5.1-2mamba
|
|
- update the specfile for python3
|
|
|
|
* Mon Jan 11 2016 Automatic Build System <autodist@mambasoft.it> 1.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 23 2015 Automatic Build System <autodist@mambasoft.it> 1.5.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 21 2015 Automatic Build System <autodist@mambasoft.it> 1.4.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 26 2014 Automatic Build System <autodist@mambasoft.it> 1.4.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 18 2014 Automatic Build System <autodist@mambasoft.it> 1.4.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1-1mamba
|
|
- update to 1.3.1
|
|
|
|
* Sun Feb 06 2011 gil <puntogil@libero.it> 1.0.1-1mamba
|
|
- package created by autospec |