python-lsp-server/python-lsp-server.spec

138 lines
4.9 KiB
RPMSpec

%define pkgname %(echo %name | cut -d- -f2- | tr - _)
Name: python-lsp-server
Version: 1.12.0
Release: 1mamba
Summary: A Python 3.6+ implementation of the Language Server Protocol
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/python-lsp/python-lsp-server
Source: https://pypi.debian.net/python-lsp-server/python_lsp_server-%{version}.tar.gz
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: libpython311-devel
BuildRequires: python3.11dist(docstring-to-markdown)
BuildRequires: python3.11dist(jedi)
BuildRequires: python3.11dist(pluggy)
BuildRequires: python3.11dist(python-lsp-jsonrpc)
BuildRequires: python3.11dist(ujson)
## AUTOBUILDREQ-END
BuildRequires: python3-devel >= 3.11.5-3mamba
%description
%{summary}.
%if 0%{?with_pyver}
%define py_requires_append \
Requires: python-whatthepatch%{?pyappend:-%pyappend} \
Requires: python-yapf%{?pyappend:-%pyappend} \
Requires: python-rope%{?pyappend:-%pyappend} \
Requires: python-pydocstyle%{?pyappend:-%pyappend} \
Requires: python-pycodestyle%{?pyappend:-%pyappend} \
Requires: python-flake8%{?pyappend:-%pyappend} \
Requires: python-autopep8%{?pyappend:-%pyappend} \
Obsoletes: python-lsp-server-py310 <= 1.10.1-1mamba
%pyver_package
%endif
%prep
%setup -q -n python_lsp_server-%{version}
sed 's|autopep8>=1.6.0,<1.7.0|autopep8>=1.6.0|' -i pyproject.toml
sed 's|flake8>=5.0.0,<5.1.0|flake8>=5.0.0|' -i pyproject.toml
sed 's|mccabe>=0.7.0,<0.8.0|mccabe>=0.7.0|' -i pyproject.toml
sed 's|pycodestyle>=2.9.0,<2.10.0|pycodestyle>=2.9.0|' -i pyproject.toml
sed 's|pyflakes>=2.5.0,<2.6.0|pyflakes>=2.5.0|' -i pyproject.toml
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
%if "%{?with_pyver}" != "3"
# Rename any conflicting file outside of python site packages tree
for f in %{_bindir}/pylsp; do
mv %{buildroot}${f}{,-%{?pyappend}}
done
%endif
%files %{?pyappend}
%defattr(-,root,root)
%{_bindir}/pylsp*
%dir %{python_sitelib}/python_%{pkgname}-%{version}.dist-info
%{python_sitelib}/python_%{pkgname}-%{version}.dist-info/*
%dir %{python_sitelib}/pylsp
%{python_sitelib}/pylsp/*
%doc LICENSE
%changelog
* Tue Sep 03 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.0-1mamba
- update to 1.12.0
* Sun Mar 31 2024 Automatic Build System <autodist@openmamba.org> 1.11.0-1mamba
- automatic version update by autodist
* Sun Mar 24 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.1-2mamba
- obsolete python-lsp-server-p310
* Sat Mar 16 2024 Automatic Build System <autodist@openmamba.org> 1.10.1-1mamba
- automatic version update by autodist
* Sat Jan 27 2024 Automatic Build System <autodist@openmamba.org> 1.10.0-1mamba
- automatic version update by autodist
* Fri Nov 10 2023 Automatic Build System <autodist@mambasoft.it> 1.9.0-1mamba
- automatic version update by autodist
* Fri Oct 13 2023 Automatic Build System <autodist@mambasoft.it> 1.8.2-1mamba
- automatic version update by autodist
* Tue Oct 10 2023 Automatic Build System <autodist@mambasoft.it> 1.8.1-1mamba
- automatic version update by autodist
* Mon Oct 02 2023 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
- automatic version update by autodist
* Wed Sep 27 2023 Automatic Build System <autodist@mambasoft.it> 1.7.4-2mamba
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
* Sun Jul 02 2023 Automatic Build System <autodist@mambasoft.it> 1.7.4-1mamba
- automatic version update by autodist
* Tue May 23 2023 Automatic Build System <autodist@mambasoft.it> 1.7.3-1mamba
- automatic version update by autodist
* Sun Apr 09 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.2-3mamba
- py310: fix requirement for python-autopep8
* Fri Apr 07 2023 Sdk Build System <sdk@mambasoft.it> 1.7.2-2mamba
- rebuilt with python 3.10
* Tue Apr 04 2023 Automatic Build System <autodist@mambasoft.it> 1.7.2-1mamba
- automatic version update by autodist
* Thu Jan 19 2023 Automatic Build System <autodist@mambasoft.it> 1.7.1-1mamba
- automatic version update by autodist
* Sat Dec 31 2022 Automatic Build System <autodist@mambasoft.it> 1.7.0-1mamba
- automatic version update by autodist
* Thu Dec 08 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-3mamba
- remove requirements for older deps versions
* Wed Nov 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-2mamba
- add requirements
* Mon Nov 07 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
- update to 1.6.0
* Sat Oct 08 2022 Automatic Build System <autodist@mambasoft.it> 1.5.0-1mamba
- automatic version update by autodist
* Fri Apr 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.1-1mamba
- update to 1.4.1
* Sun Feb 13 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.3-1mamba
- package created using the webbuild interface