automatic update by autodist [release 1.1.90-1mamba;Tue Nov 19 2013]
This commit is contained in:
parent
6a596eed49
commit
cadbaab7ae
@ -1,2 +1,7 @@
|
||||
# python-gst
|
||||
|
||||
GStreamer is a library that allows the construction of graphs of media-handling components, ranging from simple Ogg/Vorbis playback to complex audio (mixing) and video (non-linear editing) processing.
|
||||
Applications can take advantage of advances in codec and filter technology transparently.
|
||||
Developers can add new codecs and filters by writing a simple plugin with a clean, generic interface.
|
||||
|
||||
|
||||
|
11
gst-python-0.10.13-configure-python26.patch
Normal file
11
gst-python-0.10.13-configure-python26.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- gst-python-0.10.13/configure 2008-10-03 01:48:09.000000000 +0200
|
||||
+++ gst-python-0.10.13/configure-gil 2008-11-18 20:56:18.000000000 +0100
|
||||
@@ -21403,7 +21403,7 @@
|
||||
|
||||
# Find any Python interpreter.
|
||||
if test -z "$PYTHON"; then
|
||||
- for ac_prog in python python2 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
|
||||
+ for ac_prog in python python2 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
|
||||
do
|
||||
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
||||
set dummy $ac_prog; ac_word=$2
|
157
python-gst.spec
Normal file
157
python-gst.spec
Normal file
@ -0,0 +1,157 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: python-gst
|
||||
Version: 1.1.90
|
||||
Release: 1mamba
|
||||
Summary: Python bindings for GStreamer
|
||||
Group: Development/Languages
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Automatic Build System <autodist@mambasoft.it>
|
||||
URL: http://gstreamer.freedesktop.org/
|
||||
Source: http://gstreamer.freedesktop.org/src/gst-python/gst-python-%{version}.tar.gz
|
||||
Patch: gst-python-0.10.13-configure-python26.patch
|
||||
License: LGPL
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: xmlto
|
||||
#BuildRequires: links2
|
||||
BuildRequires: gst-plugins-base
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: pygobject-devel
|
||||
BuildRequires: pygtk-devel
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libxml2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Provides: gst-python
|
||||
Obsoletes: gst-python
|
||||
Provides: python-gst-devel
|
||||
Obsoletes: python-gst-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
GStreamer is a library that allows the construction of graphs of media-handling components, ranging from simple Ogg/Vorbis playback to complex audio (mixing) and video (non-linear editing) processing.
|
||||
Applications can take advantage of advances in codec and filter technology transparently.
|
||||
Developers can add new codecs and filters by writing a simple plugin with a clean, generic interface.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
GStreamer is a library that allows the construction of graphs of media-handling components, ranging from simple Ogg/Vorbis playback to complex audio (mixing) and video (non-linear editing) processing.
|
||||
Applications can take advantage of advances in codec and filter technology transparently.
|
||||
Developers can add new codecs and filters by writing a simple plugin with a clean, generic interface.
|
||||
|
||||
This package contains static libraries need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n gst-python-%{version}
|
||||
#%patch -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{python_sitearch}/gi/overrides/
|
||||
%{python_sitearch}/gi/overrides/*
|
||||
#%{_libdir}/gstreamer-%{majver}/libgstpython.la
|
||||
#%{_libdir}/gstreamer-%{majver}/libgstpython.so
|
||||
#%{python_sitearch}/pygst.pth
|
||||
#%{python_sitearch}//pygst.py
|
||||
#%dir %{python_sitearch}/gst-0.10/gst
|
||||
#%{python_sitearch}/gst-0.10/gst/__init__.py
|
||||
#%{python_sitearch}/gst-0.10/gst/__init__.pyc
|
||||
#%{python_sitearch}/gst-0.10/gst/__init__.pyo
|
||||
#%{python_sitearch}/gst-0.10/gst/*.so
|
||||
#%dir %{python_sitearch}/gst-0.10/gst/extend
|
||||
#%{python_sitearch}/gst-0.10/gst/extend/*.py
|
||||
#%{python_sitearch}/gst-0.10/gst/extend/*.pyc
|
||||
#%{python_sitearch}/gst-0.10/gst/extend/*.pyo
|
||||
#%dir %{_datadir}/gst-python/0.10/defs
|
||||
#%{_datadir}/gst-python/0.10/defs/*.defs
|
||||
#%dir %{_datadir}/gst-python/0.10/examples
|
||||
#%{_datadir}/gst-python/0.10/examples/gst-discover
|
||||
#%{_datadir}/gst-python/0.10/examples/pipeline-tester
|
||||
#%{_datadir}/gst-python/0.10/examples/*.py
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
#%files devel
|
||||
#%defattr(-,root,root)
|
||||
#%{_includedir}/gstreamer-0.10/gst/pygst.h
|
||||
#%{_includedir}/gstreamer-0.10/gst/pygstexception.h
|
||||
#%{_includedir}/gstreamer-0.10/gst/pygstminiobject.h
|
||||
#%{_includedir}/gstreamer-0.10/gst/pygstvalue.h
|
||||
#%dir %{python_sitearch}/gst-0.10/gst
|
||||
#%{python_sitearch}/gst-0.10/gst/*.la
|
||||
#%{python_sitearch}/*.la
|
||||
#%{python_sitearch}/*.so
|
||||
#%{_libdir}/pkgconfig/*.pc
|
||||
#%doc ChangeLog NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Tue Nov 19 2013 Automatic Build System <autodist@mambasoft.it> 1.1.90-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.22-2mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 0.10.22-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Oct 28 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.21-2mamba
|
||||
- move pkgconfig file to -devel package
|
||||
|
||||
* Fri Jun 17 2011 Automatic Build System <autodist@mambasoft.it> 0.10.21-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Jul 16 2010 Automatic Build System <autodist@mambasoft.it> 0.10.19-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Jun 06 2010 Automatic Build System <autodist@mambasoft.it> 0.10.18-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Jan 12 2010 Automatic Build System <autodist@mambasoft.it> 0.10.17-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Aug 09 2009 Automatic Build System <autodist@mambasoft.it> 0.10.16-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jun 01 2009 Automatic Build System <autodist@mambasoft.it> 0.10.15-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Mar 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.14-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Dec 06 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.13-2mamba
|
||||
- rename to python-gst
|
||||
- use python_sitearch marco in files sections
|
||||
|
||||
* Tue Nov 18 2008 gil <puntogil@libero.it> 0.10.13-1mamba
|
||||
- update to 0.10.13
|
||||
- added support for python 2.6
|
||||
|
||||
* Tue Jul 08 2008 gil <puntogil@libero.it> 0.10.12-1mamba
|
||||
- update to 0.10.12
|
||||
- new buildrequires: pygtk-devel , pygobject-devel
|
||||
- added package devel
|
||||
|
||||
* Mon May 12 2008 gil <puntogil@libero.it> 0.10.11-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user