78 lines
2.3 KiB
RPMSpec
78 lines
2.3 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
|
Name: python-flake8
|
|
Version: 7.1.1
|
|
Release: 1mamba
|
|
Summary: The modular source code checker: pep8 pyflakes and co
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/pycqa/flake8
|
|
Source: http://pypi.debian.net/flake8/flake8-%{version}.tar.gz
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: python3.11dist(mccabe)
|
|
BuildRequires: python3.11dist(pycodestyle)
|
|
BuildRequires: python3.11dist(pyflakes)
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python3-devel >= 3.11.5-3mamba
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n flake8-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
# Rename any conflicting file outside of python site packages tree
|
|
for f in %{_bindir}/flake8; do
|
|
mv %{buildroot}${f}{,-%{?pyappend}}
|
|
done
|
|
%endif
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%{_bindir}/flake8*
|
|
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
|
|
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
|
|
%dir %{python_sitelib}/%{pkgname}
|
|
%{python_sitelib}/%{pkgname}/*
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Mon Aug 05 2024 Automatic Build System <autodist@openmamba.org> 7.1.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jun 16 2024 Automatic Build System <autodist@openmamba.org> 7.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 05 2024 Automatic Build System <autodist@mambasoft.it> 7.0.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Sep 27 2023 Automatic Build System <autodist@mambasoft.it> 6.1.0-2mamba
|
|
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
|
|
|
* Sun Jul 30 2023 Automatic Build System <autodist@mambasoft.it> 6.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 07 2023 Sdk Build System <sdk@mambasoft.it> 6.0.0-2mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Wed Dec 07 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0.0-1mamba
|
|
- update to 6.0.0
|
|
|
|
* Wed Nov 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 5.0.4-1mamba
|
|
- package created using the webbuild interface
|