55 lines
1.5 KiB
RPMSpec
55 lines
1.5 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2-)
|
|
Name: python-entrypoints
|
|
Version: 0.4
|
|
Release: 1mamba
|
|
Summary: Discover and load entry points from installed packages
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/takluyver/entrypoints
|
|
Source: https://pypi.debian.net/entrypoints/entrypoints-%{version}.tar.gz
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython3-devel
|
|
## AUTOBUILDREQ-END
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n entrypoints-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
#%if "%{?with_pyver}" != "3"
|
|
## Rename any conflicting file outside of python site packages tree
|
|
#for f in %{_bindir}/pdm; do
|
|
# mv %{buildroot}${f}{,-%{?pyappend}}
|
|
#done
|
|
#%endif
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
|
|
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
|
|
%{python_sitelib}/entrypoints.py
|
|
%{python_sitelib}/__pycache__/entrypoints*.pyc
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Mon Mar 06 2023 Automatic Build System <autodist@mambasoft.it> 0.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 19 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3-1mamba
|
|
- package created using the webbuild interface
|