219 lines
7.8 KiB
RPMSpec
219 lines
7.8 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
|
Name: python-dulwich
|
|
Version: 0.22.7
|
|
Release: 1mamba
|
|
Summary: Python implementation of Git
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.dulwich.io/
|
|
Source: https://pypi.debian.net/dulwich/dulwich-%{version}.tar.gz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: python3.11dist(urllib3)
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python3-devel >= 3.11.5-3mamba
|
|
BuildRequires: python-setuptools-rust-py3
|
|
BuildRequires: python-wheel-py3
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if "%{?with_pyver}"
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n dulwich-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
# Rename any conflicting file outside of python site packages tree
|
|
for f in %{_bindir}/{dulwich,dul-receive-pack,dul-upload-pack}; do
|
|
mv %{buildroot}${f}{,-%{?pyappend}}
|
|
done
|
|
%endif
|
|
|
|
rm -rf %{buildroot}%{python_sitearch}/docs/
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%{_bindir}/dulwich*
|
|
%{_bindir}/dul-receive-pack*
|
|
%{_bindir}/dul-upload-pack*
|
|
%dir %{python_sitearch}/%{pkgname}-%{version}.dist-info
|
|
%{python_sitearch}/%{pkgname}-%{version}.dist-info/*
|
|
%dir %{python_sitearch}/%{pkgname}
|
|
%{python_sitearch}/%{pkgname}/*
|
|
%doc COPYING NEWS
|
|
|
|
%changelog
|
|
* Sat Dec 21 2024 Automatic Build System <autodist@openmamba.org> 0.22.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 18 2024 Automatic Build System <autodist@openmamba.org> 0.22.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 13 2024 Automatic Build System <autodist@openmamba.org> 0.22.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 02 2024 Automatic Build System <autodist@openmamba.org> 0.22.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 17 2024 Automatic Build System <autodist@openmamba.org> 0.22.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 23 2024 Automatic Build System <autodist@openmamba.org> 0.22.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 13 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.21.7-2mamba
|
|
- rebuild with python-build and resolve bindir conflicts
|
|
|
|
* Wed Dec 06 2023 Automatic Build System <autodist@mambasoft.it> 0.21.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Sep 27 2023 Automatic Build System <autodist@mambasoft.it> 0.21.6-2mamba
|
|
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
|
|
|
* Sat Sep 02 2023 Automatic Build System <autodist@mambasoft.it> 0.21.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 04 2023 Automatic Build System <autodist@mambasoft.it> 0.21.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 18 2023 Automatic Build System <autodist@mambasoft.it> 0.21.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 22 2023 Automatic Build System <autodist@mambasoft.it> 0.21.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 18 2023 Automatic Build System <autodist@mambasoft.it> 0.21.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 17 2023 Automatic Build System <autodist@mambasoft.it> 0.21.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 30 2022 Automatic Build System <autodist@mambasoft.it> 0.20.50-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Sep 07 2022 Automatic Build System <autodist@mambasoft.it> 0.20.46-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 16 2022 Automatic Build System <autodist@mambasoft.it> 0.20.45-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jul 04 2022 Automatic Build System <autodist@mambasoft.it> 0.20.44-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jun 07 2022 Automatic Build System <autodist@mambasoft.it> 0.20.43-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 25 2022 Automatic Build System <autodist@mambasoft.it> 0.20.42-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 20 2022 Automatic Build System <autodist@mambasoft.it> 0.20.40-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed May 18 2022 Automatic Build System <autodist@mambasoft.it> 0.20.38-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 17 2022 Automatic Build System <autodist@mambasoft.it> 0.20.37-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 16 2022 Automatic Build System <autodist@mambasoft.it> 0.20.36-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Mar 21 2022 Automatic Build System <autodist@mambasoft.it> 0.20.35-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 15 2022 Automatic Build System <autodist@mambasoft.it> 0.20.34-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 06 2022 Automatic Build System <autodist@mambasoft.it> 0.20.33-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 25 2022 Automatic Build System <autodist@mambasoft.it> 0.20.32-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 22 2022 Automatic Build System <autodist@mambasoft.it> 0.20.31-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 08 2022 Automatic Build System <autodist@mambasoft.it> 0.20.30-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 06 2022 Automatic Build System <autodist@mambasoft.it> 0.20.28-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 06 2022 Automatic Build System <autodist@mambasoft.it> 0.20.27-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 29 2021 Automatic Build System <autodist@mambasoft.it> 0.20.26-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 23 2021 Automatic Build System <autodist@mambasoft.it> 0.20.25-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 18 2021 Automatic Build System <autodist@mambasoft.it> 0.20.24-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 25 2021 Automatic Build System <autodist@mambasoft.it> 0.20.23-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 24 2021 Automatic Build System <autodist@mambasoft.it> 0.20.22-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 06 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20.21-2mamba
|
|
- fix missing %pyappend in files section
|
|
|
|
* Mon Apr 05 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20.21-1mamba
|
|
- update to 0.20.21
|
|
|
|
* Sat Apr 18 2020 Automatic Build System <autodist@mambasoft.it> 0.19.16-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 27 2020 Automatic Build System <autodist@mambasoft.it> 0.19.15-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Dec 01 2019 Automatic Build System <autodist@mambasoft.it> 0.19.14-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 21 2019 Automatic Build System <autodist@mambasoft.it> 0.19.13-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 18 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.19.12-1mamba
|
|
- update to 0.19.12
|
|
|
|
* Thu Feb 07 2019 Automatic Build System <autodist@mambasoft.it> 0.19.11-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 15 2019 Automatic Build System <autodist@mambasoft.it> 0.19.10-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 09 2019 Automatic Build System <autodist@mambasoft.it> 0.19.9-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 10 2015 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.10.1a-1mamba
|
|
- update to 0.10.1a
|
|
|
|
* Thu Dec 18 2014 Automatic Build System <autodist@mambasoft.it> 0.9.8-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Jul 11 2014 Automatic Build System <autodist@mambasoft.it> 0.9.7-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed May 28 2014 Automatic Build System <autodist@mambasoft.it> 0.9.6-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Feb 19 2014 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.9.4-1mamba
|
|
- package created using the webbuild interface
|