87 lines
2.7 KiB
RPMSpec
87 lines
2.7 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2-)
|
|
Name: python-dotenv
|
|
Version: 1.0.1
|
|
Release: 1mamba
|
|
Summary: Read key-value pairs from a .env file and set them as environment variables
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/theskumar/python-dotenv
|
|
Source: https://pypi.debian.net/python-dotenv/python-dotenv-%{version}.tar.gz
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: python3.11dist(setuptools)
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python3-devel >= 3.11.5-3mamba
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} setup.py build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} setup.py install \
|
|
-O1 --skip-build \
|
|
--root="%{buildroot}" \
|
|
--install-headers=%{python_inc} \
|
|
--install-lib=%{python_sitearch} \
|
|
--record=%{name}.filelist
|
|
|
|
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
# Rename any conflicting file outside of python site packages tree
|
|
for f in %{_bindir}/dotenv; do
|
|
mv %{buildroot}${f}{,-%{?pyappend}}
|
|
sed -i "s|${f}|${f}-%{?pyappend}|" %{name}.filelist
|
|
done
|
|
%endif
|
|
|
|
%files %{?pyappend} -f %{name}.filelist
|
|
%defattr(-,root,root)
|
|
%dir %{python_sitearch}/python_dotenv-%{version}-py*.egg-info
|
|
%{python_sitearch}/python_dotenv-%{version}-py*.egg-info/*
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Wed Jan 24 2024 Automatic Build System <autodist@openmamba.org> 1.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 26 2023 Automatic Build System <autodist@mambasoft.it> 1.0.0-2mamba
|
|
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
|
|
|
* Sat Feb 25 2023 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 23 2023 Automatic Build System <autodist@mambasoft.it> 0.21.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.21.0-2mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Thu Sep 08 2022 Automatic Build System <autodist@mambasoft.it> 0.21.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 25 2022 Automatic Build System <autodist@mambasoft.it> 0.20.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 11 2021 Automatic Build System <autodist@mambasoft.it> 0.19.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 11 2021 Automatic Build System <autodist@mambasoft.it> 0.19.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Aug 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.19.0-1mamba
|
|
- package created using the webbuild interface
|