182 lines
6.5 KiB
RPMSpec
182 lines
6.5 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
||
Name: python-docker
|
||
Version: 7.1.0
|
||
Release: 1mamba
|
||
Summary: An API client for docker written in Python
|
||
Group: System/Libraries
|
||
Vendor: openmamba
|
||
Distribution: openmamba
|
||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||
URL: https://github.com/docker/docker-py
|
||
Source: https://pypi.debian.net/docker/docker-%{version}.tar.gz
|
||
License: Apache License 2.0
|
||
## AUTOBUILDREQ-BEGIN
|
||
BuildRequires: libpython311-devel
|
||
BuildRequires: python3.11dist(requests)
|
||
BuildRequires: python3.11dist(urllib3)
|
||
## AUTOBUILDREQ-END
|
||
BuildRequires: python3-devel >= 3.11.5-3mamba
|
||
|
||
%description
|
||
A Python library for the Docker Remote API.
|
||
It does everything the docker command does, but from within Python – run containers, manage them, pull/push images, etc.
|
||
|
||
%if 0%{?with_pyver}
|
||
%pyver_package
|
||
%endif
|
||
|
||
%prep
|
||
%setup -q -n docker-%{version}
|
||
|
||
%build
|
||
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
||
|
||
%install
|
||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
||
|
||
#%if "%{?with_pyver}" != "3"
|
||
## Rename any conflicting file outside of python site packages tree
|
||
#for f in %{_bindir}/pdm; do
|
||
# mv %{buildroot}${f}{,-%{?pyappend}}
|
||
#done
|
||
#%endif
|
||
|
||
%files %{?pyappend}
|
||
%defattr(-,root,root)
|
||
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
|
||
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
|
||
%dir %{python_sitelib}/%{pkgname}
|
||
%{python_sitelib}/%{pkgname}/*
|
||
%doc LICENSE README.md
|
||
|
||
%changelog
|
||
* Mon May 27 2024 Automatic Build System <autodist@openmamba.org> 7.1.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Wed Apr 03 2024 Automatic Build System <autodist@openmamba.org> 7.0.0b3-1mamba
|
||
- automatic update by autodist
|
||
|
||
* Sat Dec 09 2023 Automatic Build System <autodist@mambasoft.it> 7.0.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Wed Sep 27 2023 Automatic Build System <autodist@mambasoft.it> 6.1.3-2mamba
|
||
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
||
|
||
* Fri Jun 02 2023 Automatic Build System <autodist@mambasoft.it> 6.1.3-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Fri May 12 2023 Automatic Build System <autodist@mambasoft.it> 6.1.2-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Mon May 08 2023 Automatic Build System <autodist@mambasoft.it> 6.1.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sat May 06 2023 Automatic Build System <autodist@mambasoft.it> 6.1.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Tue Apr 11 2023 Automatic Build System <autodist@mambasoft.it> 6.0.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Mon Oct 11 2021 Automatic Build System <autodist@mambasoft.it> 5.0.3-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Wed Sep 01 2021 Automatic Build System <autodist@mambasoft.it> 5.0.2-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Tue Aug 31 2021 Automatic Build System <autodist@mambasoft.it> 5.0.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Mon Aug 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.0.0-2mamba
|
||
- rebuilt for python3
|
||
|
||
* Wed Apr 07 2021 Automatic Build System <autodist@mambasoft.it> 5.0.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Thu Feb 25 2021 Automatic Build System <autodist@mambasoft.it> 4.4.4-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sun Feb 21 2021 Automatic Build System <autodist@mambasoft.it> 4.4.3-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Fri Dec 25 2020 Automatic Build System <autodist@mambasoft.it> 4.4.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Thu Dec 03 2020 Automatic Build System <autodist@mambasoft.it> 4.4.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sat Aug 22 2020 Automatic Build System <autodist@mambasoft.it> 4.3.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Tue Aug 11 2020 Automatic Build System <autodist@mambasoft.it> 4.3.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Wed Jul 01 2020 Automatic Build System <autodist@mambasoft.it> 4.2.2-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Wed Jun 03 2020 Automatic Build System <autodist@mambasoft.it> 4.2.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Thu Feb 06 2020 Automatic Build System <autodist@mambasoft.it> 4.2.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Fri Oct 04 2019 Automatic Build System <autodist@mambasoft.it> 4.1.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Fri Jun 21 2019 Automatic Build System <autodist@mambasoft.it> 4.0.2-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Tue May 21 2019 Automatic Build System <autodist@mambasoft.it> 4.0.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Tue Apr 02 2019 Automatic Build System <autodist@mambasoft.it> 3.7.2-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sat Jan 12 2019 Automatic Build System <autodist@mambasoft.it> 3.7.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Tue Dec 04 2018 Automatic Build System <autodist@mambasoft.it> 3.6.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Mon Oct 22 2018 Automatic Build System <autodist@mambasoft.it> 3.5.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sat Aug 11 2018 Automatic Build System <autodist@mambasoft.it> 3.5.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Tue Jul 03 2018 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Wed Jun 20 2018 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Fri Apr 27 2018 Automatic Build System <autodist@mambasoft.it> 3.3.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sat Mar 31 2018 Automatic Build System <autodist@mambasoft.it> 3.2.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Fri Mar 30 2018 Automatic Build System <autodist@mambasoft.it> 3.2.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Thu Mar 22 2018 Automatic Build System <autodist@mambasoft.it> 3.1.4-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Wed Mar 21 2018 Automatic Build System <autodist@mambasoft.it> 3.1.3-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Thu Mar 08 2018 Automatic Build System <autodist@mambasoft.it> 3.1.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sat Feb 17 2018 Automatic Build System <autodist@mambasoft.it> 3.0.1-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Mon Dec 25 2017 Automatic Build System <autodist@mambasoft.it> 2.7.0-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Mon Feb 06 2017 Automatic Build System <autodist@mambasoft.it> 2.0.2-1mamba
|
||
- automatic version update by autodist
|
||
|
||
* Sat Oct 15 2016 Davide Madrisan <davide.madrisan@gmail.com> 1.10.3-1mamba
|
||
- package created using the webbuild interface
|