78 lines
2.3 KiB
RPMSpec
78 lines
2.3 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
|
Name: python-distro
|
|
Version: 1.8.0
|
|
Release: 3mamba
|
|
Summary: An OS platform information API
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/python-distro/distro
|
|
Source: https://pypi.debian.net/distro/distro-%{version}.tar.gz
|
|
License: Apache License 2.0
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python3-devel >= 3.11.5-3mamba
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n distro-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
# Rename any conflicting file outside of python site packages tree
|
|
for f in %{_bindir}/distro; do
|
|
mv %{buildroot}${f}{,-%{?pyappend}}
|
|
done
|
|
%endif
|
|
|
|
%files %{?pyappend}
|
|
%defattr(-,root,root)
|
|
%{_bindir}/distro*
|
|
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
|
|
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
|
|
%dir %{python_sitelib}/%{pkgname}
|
|
%{python_sitelib}/%{pkgname}/*
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Tue Sep 26 2023 Automatic Build System <autodist@mambasoft.it> 1.8.0-3mamba
|
|
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
|
|
|
* Sat May 06 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.0-2mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Mon Mar 06 2023 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 16 2022 Automatic Build System <autodist@mambasoft.it> 1.7.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 31 2021 Automatic Build System <autodist@mambasoft.it> 1.6.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 09 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.0-2mamba
|
|
- rebuilt with distdeps
|
|
|
|
* Sun Apr 26 2020 Automatic Build System <autodist@mambasoft.it> 1.5.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 11 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.0-2mamba
|
|
- fix conflicting /usr/bin/distro file
|
|
|
|
* Wed Oct 23 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.0-1mamba
|
|
- package created using the webbuild interface
|