python-build/python-build.spec

75 lines
2.2 KiB
RPMSpec

%define pkgname %(echo %name | cut -d- -f2-)
Name: python-build
Version: 1.0.3
Release: 1mamba
Summary: A simple, correct PEP517 package builder
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/pypa/build
Source: https://pypi.debian.net/build/build-%{version}.tar.gz
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: libpython3-devel
BuildRequires: python3.7dist(importlib-metadata)
BuildRequires: python3.7dist(packaging)
BuildRequires: python3.7dist(pyproject-hooks)
BuildRequires: python3.7dist(tomli)
## AUTOBUILDREQ-END
%description
%{summary}.
%if 0%{?with_pyver}
%pyver_package
%endif
%prep
%setup -q -n build-%{version}
%build
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
%if "%{?with_pyver}" != "3"
# Rename any conflicting file outside of python site packages tree
for f in %{_bindir}/pyproject-build; do
mv %{buildroot}${f}{,-%{?pyappend}}
done
%endif
%files %{?pyappend}
%defattr(-,root,root)
%{_bindir}/pyproject-build*
%dir %{python_sitelib}/%{pkgname}-%{version}.dist-info
%{python_sitelib}/%{pkgname}-%{version}.dist-info/*
%dir %{python_sitelib}/%{pkgname}
%{python_sitelib}/%{pkgname}/*
%doc LICENSE
%changelog
* Thu Sep 07 2023 Automatic Build System <autodist@mambasoft.it> 1.0.3-1mamba
- automatic version update by autodist
* Sat Sep 02 2023 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
- automatic version update by autodist
* Mon Mar 06 2023 Automatic Build System <autodist@mambasoft.it> 0.10.0-1mamba
- automatic version update by autodist
* Fri Oct 28 2022 Automatic Build System <autodist@mambasoft.it> 0.9.0-1mamba
- automatic version update by autodist
* Sat May 28 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.0-2mamba
- rebuilt with python 3.10 subpackage
* Mon May 23 2022 Automatic Build System <autodist@mambasoft.it> 0.8.0-1mamba
- automatic version update by autodist
* Fri Jan 14 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.0-1mamba
- package created using the webbuild interface