python 2.7 mass rebuild [release 1.6.4-2mamba;Fri May 17 2013]
This commit is contained in:
parent
f8478e6894
commit
15b658d169
19
README.md
19
README.md
@ -1,2 +1,21 @@
|
||||
# python-beaker
|
||||
|
||||
Beaker is a web session and general caching library that includes WSGI middleware for use in web applications.
|
||||
As a general caching library, Beaker can handle storing for various times any Python object that can be pickled with optional back-ends on a fine-grained basis.
|
||||
Beaker was built largely on the code from MyghtyUtils, then refactored and extended with database support.
|
||||
|
||||
Beaker includes Cache and Session WSGI middleware to ease integration with WSGI capable frameworks, and is automatically used by Pylons http://pylonshq.com/.
|
||||
|
||||
Features
|
||||
========
|
||||
|
||||
* Fast, robust performance
|
||||
* Multiple reader/single writer lock system to avoid duplicate simultaneous cache creation
|
||||
* Cache back-ends include dbm, file, memory, memcached, and database (Using SQLAlchemy for multiple-db vendor support)
|
||||
* Signed cookie's to prevent session hijacking/spoofing
|
||||
* Cookie-only sessions to remove the need for a db or file backend (ideal for clustered systems)
|
||||
* Extensible Container object to support new back-ends
|
||||
* Cache's can be divided into namespaces (to represent templates, objects, etc.) then keyed for different copies
|
||||
* Create functions for automatic call-backs to create new cache copies after expiration
|
||||
* Fine-grained toggling of back-ends, keys, and expiration per Cache object
|
||||
|
||||
|
7
python-beaker-1.5-absimport.patch
Normal file
7
python-beaker-1.5-absimport.patch
Normal file
@ -0,0 +1,7 @@
|
||||
--- beaker/ext/google.py 2009-10-19 19:09:50.000000000 +0200
|
||||
+++ beaker/ext/google.py-gil 2009-11-27 03:19:22.000000000 +0100
|
||||
@@ -1,4 +1,3 @@
|
||||
-from __future__ import absolute_import
|
||||
import cPickle
|
||||
import logging
|
||||
from datetime import datetime
|
86
python-beaker.spec
Normal file
86
python-beaker.spec
Normal file
@ -0,0 +1,86 @@
|
||||
Name: python-beaker
|
||||
Version: 1.6.4
|
||||
Release: 2mamba
|
||||
Summary: A Session and Caching library with WSGI Middleware
|
||||
Group: System/Libraries/Python
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://beaker.groovie.org
|
||||
Source: http://pypi.python.org/packages/source/B/Beaker/Beaker-%{version}.tar.gz
|
||||
Patch0: python-beaker-1.5-absimport.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python-setuptools-devel
|
||||
Requires: python >= %python_version
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Beaker is a web session and general caching library that includes WSGI middleware for use in web applications.
|
||||
As a general caching library, Beaker can handle storing for various times any Python object that can be pickled with optional back-ends on a fine-grained basis.
|
||||
Beaker was built largely on the code from MyghtyUtils, then refactored and extended with database support.
|
||||
|
||||
Beaker includes Cache and Session WSGI middleware to ease integration with WSGI capable frameworks, and is automatically used by Pylons http://pylonshq.com/.
|
||||
|
||||
Features
|
||||
========
|
||||
|
||||
* Fast, robust performance
|
||||
* Multiple reader/single writer lock system to avoid duplicate simultaneous cache creation
|
||||
* Cache back-ends include dbm, file, memory, memcached, and database (Using SQLAlchemy for multiple-db vendor support)
|
||||
* Signed cookie's to prevent session hijacking/spoofing
|
||||
* Cookie-only sessions to remove the need for a db or file backend (ideal for clustered systems)
|
||||
* Extensible Container object to support new back-ends
|
||||
* Cache's can be divided into namespaces (to represent templates, objects, etc.) then keyed for different copies
|
||||
* Create functions for automatic call-backs to create new cache copies after expiration
|
||||
* Fine-grained toggling of back-ends, keys, and expiration per Cache object
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -n Beaker-%{version}
|
||||
#%patch0 -p0
|
||||
|
||||
%build
|
||||
%{__python} setup.py build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python} setup.py install \
|
||||
--root="%{buildroot}" \
|
||||
--install-headers=%{_includedir}/python \
|
||||
--install-lib=%{python_sitearch}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{python_sitearch}/Beaker-%{version}-py%{python_version}.egg-info
|
||||
%{python_sitearch}/Beaker-%{version}-py%{python_version}.egg-info/PKG-INFO
|
||||
%{python_sitearch}/Beaker-%{version}-py%{python_version}.egg-info/*.txt
|
||||
%{python_sitearch}/Beaker-%{version}-py%{python_version}.egg-info/not-zip-safe
|
||||
%dir %{python_sitearch}/beaker
|
||||
%{python_sitearch}/beaker/*.py
|
||||
%{python_sitearch}/beaker/*.pyc
|
||||
%dir %{python_sitearch}/beaker/crypto
|
||||
%{python_sitearch}/beaker/crypto/*.py
|
||||
%{python_sitearch}/beaker/crypto/*.pyc
|
||||
%dir %{python_sitearch}/beaker/ext
|
||||
%{python_sitearch}/beaker/ext/*.py
|
||||
%{python_sitearch}/beaker/ext/*.pyc
|
||||
%doc LICENSE CHANGELOG
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.4-2mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Thu Mar 07 2013 Automatic Build System <autodist@mambasoft.it> 1.6.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat May 01 2010 gil <puntogil@libero.it> 1.5.3-1mamba
|
||||
- update to 1.5.3
|
||||
|
||||
* Fri Nov 27 2009 gil <puntogil@libero.it> 1.5-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user